aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorDavid Barksdale <amatus@amat.us>2019-08-27 14:29:17 -0500
committerDavid Barksdale <amatus@amat.us>2019-08-27 14:29:17 -0500
commit53fd26b7e0deef386aeb207bfc1e3f7c00a1f775 (patch)
treedb4ed21ae7fb6677b7f7092f529175a76e3d4f6b /src/namestore/Makefile.am
parentba2cae9617e32bf789001415cd787f50af8b3ce9 (diff)
downloadgnunet-53fd26b7e0deef386aeb207bfc1e3f7c00a1f775.tar.gz
gnunet-53fd26b7e0deef386aeb207bfc1e3f7c00a1f775.zip
Use pkg-config to check for MHD
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index e95add6c7..ad99a3f0b 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -143,9 +143,10 @@ libgnunet_plugin_rest_namestore_la_LIBADD = \
143 $(top_builddir)/src/json/libgnunetjson.la \ 143 $(top_builddir)/src/json/libgnunetjson.la \
144 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 144 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
145 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \ 145 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
146 $(LTLIBINTL) -ljansson -lmicrohttpd 146 $(LTLIBINTL) -ljansson $(MHD_LIBS)
147libgnunet_plugin_rest_namestore_la_LDFLAGS = \ 147libgnunet_plugin_rest_namestore_la_LDFLAGS = \
148 $(GN_PLUGIN_LDFLAGS) 148 $(GN_PLUGIN_LDFLAGS)
149libgnunet_plugin_rest_namestore_la_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
149 150
150 151
151libgnunetnamestore_la_SOURCES = \ 152libgnunetnamestore_la_SOURCES = \
@@ -185,12 +186,13 @@ gnunet_namestore_LDADD = \
185 186
186gnunet_namestore_fcfsd_SOURCES = \ 187gnunet_namestore_fcfsd_SOURCES = \
187 gnunet-namestore-fcfsd.c 188 gnunet-namestore-fcfsd.c
188gnunet_namestore_fcfsd_LDADD = -lmicrohttpd \ 189gnunet_namestore_fcfsd_LDADD = $(MHD_LIBS) \
189 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 190 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
190 $(top_builddir)/src/identity/libgnunetidentity.la \ 191 $(top_builddir)/src/identity/libgnunetidentity.la \
191 libgnunetnamestore.la \ 192 libgnunetnamestore.la \
192 $(top_builddir)/src/util/libgnunetutil.la \ 193 $(top_builddir)/src/util/libgnunetutil.la \
193 $(GN_LIBINTL) 194 $(GN_LIBINTL)
195gnunet_namestore_fcfsd_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
194 196
195 197
196gnunet_service_namestore_SOURCES = \ 198gnunet_service_namestore_SOURCES = \