aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authort3sserakt <t3ss@posteo.de>2022-10-05 13:35:00 +0200
committert3sserakt <t3ss@posteo.de>2022-10-05 13:35:00 +0200
commit8e4312d5e44a83e2baeb3fc15465b5e70919e6cf (patch)
treee4fe3388c0c18d9fa025c95820089d4ec5a801d4 /src/namestore/Makefile.am
parent247230d737e3e4709392148bfabbde25871b6914 (diff)
parent95fd039097d261626916cfc260a06a29d3d4fc15 (diff)
downloadgnunet-8e4312d5e44a83e2baeb3fc15465b5e70919e6cf.tar.gz
gnunet-8e4312d5e44a83e2baeb3fc15465b5e70919e6cf.zip
Merge branch 'master' of ssh://git.gnunet.org/gnunet
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am342
1 files changed, 60 insertions, 282 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 51708dd67..da563a9e8 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -15,25 +15,6 @@ if USE_COVERAGE
15 XLIBS = -lgcov 15 XLIBS = -lgcov
16endif 16endif
17 17
18HEAP_PLUGIN = libgnunet_plugin_namestore_flat.la
19HEAP_TESTS = test_plugin_namestore_flat \
20 test_namestore_api_store_flat \
21 test_namestore_api_store_update_flat \
22 test_namestore_api_remove_flat \
23 test_namestore_api_zone_iteration_flat \
24 test_namestore_api_lookup_nick_flat \
25 test_namestore_api_monitoring_flat \
26 test_namestore_api_lookup_public_flat \
27 test_namestore_api_lookup_private_flat \
28 test_namestore_api_lookup_shadow_flat \
29 test_namestore_api_lookup_shadow_filter_flat \
30 test_namestore_api_remove_not_existing_record_flat \
31 test_namestore_api_zone_iteration_nick_flat \
32 test_namestore_api_zone_iteration_specific_zone_flat \
33 test_namestore_api_zone_iteration_stop_flat \
34 test_namestore_api_monitoring_existing_flat \
35 test_namestore_api_zone_to_name_flat \
36 perf_namestore_api_zone_iteration_flat
37 18
38if HAVE_SQLITE 19if HAVE_SQLITE
39SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la 20SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
@@ -44,19 +25,19 @@ SQLITE_TESTS = test_plugin_namestore_sqlite \
44 test_namestore_api_remove_sqlite \ 25 test_namestore_api_remove_sqlite \
45 test_namestore_api_lookup_nick_sqlite \ 26 test_namestore_api_lookup_nick_sqlite \
46 test_namestore_api_monitoring_sqlite \ 27 test_namestore_api_monitoring_sqlite \
47 test_namestore_api_lookup_public_sqlite \
48 test_namestore_api_lookup_private_sqlite \
49 test_namestore_api_lookup_shadow_sqlite \
50 test_namestore_api_lookup_shadow_filter_sqlite \
51 test_namestore_api_remove_not_existing_record_sqlite \ 28 test_namestore_api_remove_not_existing_record_sqlite \
52 test_namestore_api_zone_iteration_nick_sqlite \ 29 test_namestore_api_zone_iteration_nick_sqlite \
53 test_namestore_api_zone_iteration_specific_zone_sqlite \ 30 test_namestore_api_zone_iteration_specific_zone_sqlite \
54 test_namestore_api_zone_iteration_stop_sqlite \ 31 test_namestore_api_zone_iteration_stop_sqlite \
55 test_namestore_api_monitoring_existing_sqlite \ 32 test_namestore_api_monitoring_existing_sqlite \
56 test_namestore_api_zone_to_name_sqlite \ 33 test_namestore_api_zone_to_name_sqlite \
57 perf_namestore_api_zone_iteration_sqlite 34 perf_namestore_api_zone_iteration_sqlite \
35 perf_namestore_api_import_sqlite \
36 perf_namestore_api_import_postgres \
37 test_namestore_api_tx_rollback_sqlite
58endif 38endif
59 39
40
60if HAVE_POSTGRESQL 41if HAVE_POSTGRESQL
61POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la 42POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la
62POSTGRES_TESTS = test_plugin_namestore_postgres \ 43POSTGRES_TESTS = test_plugin_namestore_postgres \
@@ -66,24 +47,23 @@ POSTGRES_TESTS = test_plugin_namestore_postgres \
66 test_namestore_api_zone_iteration_postgres \ 47 test_namestore_api_zone_iteration_postgres \
67 test_namestore_api_lookup_nick_postgres \ 48 test_namestore_api_lookup_nick_postgres \
68 test_namestore_api_monitoring_postgres \ 49 test_namestore_api_monitoring_postgres \
69 test_namestore_api_lookup_public_postgres \
70 test_namestore_api_lookup_private_postgres \
71 test_namestore_api_lookup_shadow_postgres \
72 test_namestore_api_lookup_shadow_filter_postgres \
73 test_namestore_api_remove_not_existing_record_postgres \ 50 test_namestore_api_remove_not_existing_record_postgres \
74 test_namestore_api_zone_iteration_nick_postgres \ 51 test_namestore_api_zone_iteration_nick_postgres \
75 test_namestore_api_zone_iteration_specific_zone_postgres \ 52 test_namestore_api_zone_iteration_specific_zone_postgres \
76 test_namestore_api_zone_iteration_stop_postgres \ 53 test_namestore_api_zone_iteration_stop_postgres \
77 test_namestore_api_monitoring_existing_postgres \ 54 test_namestore_api_monitoring_existing_postgres \
78 test_namestore_api_zone_to_name_postgres \ 55 test_namestore_api_zone_to_name_postgres \
79 perf_namestore_api_zone_iteration_postgres 56 perf_namestore_api_zone_iteration_postgres \
57 test_namestore_api_tx_rollback_postgres
58if HAVE_EXPERIMENTAL
59POSTGRES_TESTS += test_namestore_api_edit_records_postgres
60endif
80endif 61endif
81 62
82if HAVE_SQLITE 63if HAVE_SQLITE
83check_PROGRAMS = \ 64check_PROGRAMS = \
84 $(SQLITE_TESTS) \ 65 $(SQLITE_TESTS) \
85 $(POSTGRES_TESTS) \ 66 $(POSTGRES_TESTS)
86 $(HEAP_TESTS)
87endif 67endif
88 68
89if ENABLE_TEST_RUN 69if ENABLE_TEST_RUN
@@ -104,6 +84,7 @@ libexec_PROGRAMS = \
104 84
105bin_PROGRAMS = \ 85bin_PROGRAMS = \
106 gnunet-namestore \ 86 gnunet-namestore \
87 gnunet-namestore-dbtool \
107 gnunet-zoneimport 88 gnunet-zoneimport
108 89
109libexec_PROGRAMS += \ 90libexec_PROGRAMS += \
@@ -113,7 +94,6 @@ libexec_PROGRAMS += \
113plugin_LTLIBRARIES = \ 94plugin_LTLIBRARIES = \
114 $(SQLITE_PLUGIN) \ 95 $(SQLITE_PLUGIN) \
115 $(POSTGRES_PLUGIN) \ 96 $(POSTGRES_PLUGIN) \
116 $(HEAP_PLUGIN) \
117 $(REST_PLUGIN) 97 $(REST_PLUGIN)
118 98
119 99
@@ -168,6 +148,14 @@ gnunet_namestore_LDADD = \
168 libgnunetnamestore.la \ 148 libgnunetnamestore.la \
169 $(GN_LIBINTL) 149 $(GN_LIBINTL)
170 150
151gnunet_namestore_dbtool_SOURCES = \
152 gnunet-namestore-dbtool.c
153gnunet_namestore_dbtool_LDADD = \
154 $(top_builddir)/src/util/libgnunetutil.la \
155 libgnunetnamestore.la \
156 $(GN_LIBINTL)
157
158
171 159
172gnunet_namestore_fcfsd_SOURCES = \ 160gnunet_namestore_fcfsd_SOURCES = \
173 gnunet-namestore-fcfsd.c 161 gnunet-namestore-fcfsd.c
@@ -195,18 +183,6 @@ gnunet_service_namestore_LDADD = \
195 183
196 184
197 185
198libgnunet_plugin_namestore_flat_la_SOURCES = \
199 plugin_namestore_flat.c
200libgnunet_plugin_namestore_flat_la_LIBADD = \
201 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
202 $(top_builddir)/src/identity/libgnunetidentity.la \
203 $(top_builddir)/src/statistics/libgnunetstatistics.la \
204 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
205 $(LTLIBINTL)
206libgnunet_plugin_namestore_flat_la_LDFLAGS = \
207 $(GN_PLUGIN_LDFLAGS)
208
209
210libgnunet_plugin_namestore_sqlite_la_SOURCES = \ 186libgnunet_plugin_namestore_sqlite_la_SOURCES = \
211 plugin_namestore_sqlite.c 187 plugin_namestore_sqlite.c
212libgnunet_plugin_namestore_sqlite_la_LIBADD = \ 188libgnunet_plugin_namestore_sqlite_la_LIBADD = \
@@ -231,15 +207,6 @@ libgnunet_plugin_namestore_postgres_la_LIBADD = \
231libgnunet_plugin_namestore_postgres_la_LDFLAGS = \ 207libgnunet_plugin_namestore_postgres_la_LDFLAGS = \
232 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS) 208 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
233 209
234test_namestore_api_store_flat_SOURCES = \
235 test_namestore_api_store.c
236test_namestore_api_store_flat_LDADD = \
237 $(top_builddir)/src/testing/libgnunettesting.la \
238 $(top_builddir)/src/util/libgnunetutil.la \
239 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
240 $(top_builddir)/src/identity/libgnunetidentity.la \
241 libgnunetnamestore.la
242
243test_namestore_api_store_sqlite_SOURCES = \ 210test_namestore_api_store_sqlite_SOURCES = \
244 test_namestore_api_store.c 211 test_namestore_api_store.c
245test_namestore_api_store_sqlite_LDADD = \ 212test_namestore_api_store_sqlite_LDADD = \
@@ -258,16 +225,6 @@ test_namestore_api_store_postgres_LDADD = \
258 $(top_builddir)/src/identity/libgnunetidentity.la \ 225 $(top_builddir)/src/identity/libgnunetidentity.la \
259 libgnunetnamestore.la 226 libgnunetnamestore.la
260 227
261test_namestore_api_store_update_flat_SOURCES = \
262 test_namestore_api_store_update.c
263test_namestore_api_store_update_flat_LDADD = \
264 $(top_builddir)/src/testing/libgnunettesting.la \
265 $(top_builddir)/src/util/libgnunetutil.la \
266 $(top_builddir)/src/identity/libgnunetidentity.la \
267 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
268 $(top_builddir)/src/namecache/libgnunetnamecache.la \
269 libgnunetnamestore.la
270
271test_namestore_api_store_update_sqlite_SOURCES = \ 228test_namestore_api_store_update_sqlite_SOURCES = \
272 test_namestore_api_store_update.c 229 test_namestore_api_store_update.c
273test_namestore_api_store_update_sqlite_LDADD = \ 230test_namestore_api_store_update_sqlite_LDADD = \
@@ -288,36 +245,6 @@ test_namestore_api_store_update_postgres_LDADD = \
288 $(top_builddir)/src/namecache/libgnunetnamecache.la \ 245 $(top_builddir)/src/namecache/libgnunetnamecache.la \
289 libgnunetnamestore.la 246 libgnunetnamestore.la
290 247
291test_namestore_api_lookup_public_flat_SOURCES = \
292 test_namestore_api_lookup_public.c
293test_namestore_api_lookup_public_flat_LDADD = \
294 $(top_builddir)/src/testing/libgnunettesting.la \
295 $(top_builddir)/src/identity/libgnunetidentity.la \
296 $(top_builddir)/src/util/libgnunetutil.la \
297 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
298 $(top_builddir)/src/namecache/libgnunetnamecache.la \
299 libgnunetnamestore.la
300
301test_namestore_api_lookup_public_sqlite_SOURCES = \
302 test_namestore_api_lookup_public.c
303test_namestore_api_lookup_public_sqlite_LDADD = \
304 $(top_builddir)/src/testing/libgnunettesting.la \
305 $(top_builddir)/src/util/libgnunetutil.la \
306 $(top_builddir)/src/identity/libgnunetidentity.la \
307 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
308 $(top_builddir)/src/namecache/libgnunetnamecache.la \
309 libgnunetnamestore.la
310
311test_namestore_api_lookup_public_postgres_SOURCES = \
312 test_namestore_api_lookup_public.c
313test_namestore_api_lookup_public_postgres_LDADD = \
314 $(top_builddir)/src/testing/libgnunettesting.la \
315 $(top_builddir)/src/util/libgnunetutil.la \
316 $(top_builddir)/src/identity/libgnunetidentity.la \
317 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
318 $(top_builddir)/src/namecache/libgnunetnamecache.la \
319 libgnunetnamestore.la
320
321test_namestore_api_lookup_nick_sqlite_SOURCES = \ 248test_namestore_api_lookup_nick_sqlite_SOURCES = \
322 test_namestore_api_lookup_nick.c 249 test_namestore_api_lookup_nick.c
323test_namestore_api_lookup_nick_sqlite_LDADD = \ 250test_namestore_api_lookup_nick_sqlite_LDADD = \
@@ -338,105 +265,6 @@ test_namestore_api_lookup_nick_postgres_LDADD = \
338 $(top_builddir)/src/namecache/libgnunetnamecache.la \ 265 $(top_builddir)/src/namecache/libgnunetnamecache.la \
339 libgnunetnamestore.la 266 libgnunetnamestore.la
340 267
341test_namestore_api_lookup_nick_flat_SOURCES = \
342 test_namestore_api_lookup_nick.c
343test_namestore_api_lookup_nick_flat_LDADD = \
344 $(top_builddir)/src/testing/libgnunettesting.la \
345 $(top_builddir)/src/identity/libgnunetidentity.la \
346 $(top_builddir)/src/util/libgnunetutil.la \
347 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
348 $(top_builddir)/src/namecache/libgnunetnamecache.la \
349 libgnunetnamestore.la
350
351test_namestore_api_lookup_private_flat_SOURCES = \
352 test_namestore_api_lookup_private.c
353test_namestore_api_lookup_private_flat_LDADD = \
354 $(top_builddir)/src/testing/libgnunettesting.la \
355 $(top_builddir)/src/identity/libgnunetidentity.la \
356 $(top_builddir)/src/util/libgnunetutil.la \
357 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
358 $(top_builddir)/src/namecache/libgnunetnamecache.la \
359 libgnunetnamestore.la
360
361test_namestore_api_lookup_private_sqlite_SOURCES = \
362 test_namestore_api_lookup_private.c
363test_namestore_api_lookup_private_sqlite_LDADD = \
364 $(top_builddir)/src/testing/libgnunettesting.la \
365 $(top_builddir)/src/identity/libgnunetidentity.la \
366 $(top_builddir)/src/util/libgnunetutil.la \
367 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
368 $(top_builddir)/src/namecache/libgnunetnamecache.la \
369 libgnunetnamestore.la
370
371test_namestore_api_lookup_private_postgres_SOURCES = \
372 test_namestore_api_lookup_private.c
373test_namestore_api_lookup_private_postgres_LDADD = \
374 $(top_builddir)/src/identity/libgnunetidentity.la \
375 $(top_builddir)/src/testing/libgnunettesting.la \
376 $(top_builddir)/src/util/libgnunetutil.la \
377 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
378 $(top_builddir)/src/namecache/libgnunetnamecache.la \
379 libgnunetnamestore.la
380
381test_namestore_api_lookup_shadow_flat_SOURCES = \
382 test_namestore_api_lookup_shadow.c
383test_namestore_api_lookup_shadow_flat_LDADD = \
384 $(top_builddir)/src/testing/libgnunettesting.la \
385 $(top_builddir)/src/identity/libgnunetidentity.la \
386 $(top_builddir)/src/util/libgnunetutil.la \
387 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
388 $(top_builddir)/src/namecache/libgnunetnamecache.la \
389 libgnunetnamestore.la
390
391test_namestore_api_lookup_shadow_sqlite_SOURCES = \
392 test_namestore_api_lookup_shadow.c
393test_namestore_api_lookup_shadow_sqlite_LDADD = \
394 $(top_builddir)/src/testing/libgnunettesting.la \
395 $(top_builddir)/src/util/libgnunetutil.la \
396 $(top_builddir)/src/identity/libgnunetidentity.la \
397 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
398 $(top_builddir)/src/namecache/libgnunetnamecache.la \
399 libgnunetnamestore.la
400
401test_namestore_api_lookup_shadow_postgres_SOURCES = \
402 test_namestore_api_lookup_shadow.c
403test_namestore_api_lookup_shadow_postgres_LDADD = \
404 $(top_builddir)/src/testing/libgnunettesting.la \
405 $(top_builddir)/src/util/libgnunetutil.la \
406 $(top_builddir)/src/identity/libgnunetidentity.la \
407 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
408 $(top_builddir)/src/namecache/libgnunetnamecache.la \
409 libgnunetnamestore.la
410
411test_namestore_api_lookup_shadow_filter_flat_SOURCES = \
412 test_namestore_api_lookup_shadow_filter.c
413test_namestore_api_lookup_shadow_filter_flat_LDADD = \
414 $(top_builddir)/src/testing/libgnunettesting.la \
415 $(top_builddir)/src/util/libgnunetutil.la \
416 $(top_builddir)/src/identity/libgnunetidentity.la \
417 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
418 $(top_builddir)/src/namecache/libgnunetnamecache.la \
419 libgnunetnamestore.la
420
421test_namestore_api_lookup_shadow_filter_sqlite_SOURCES = \
422 test_namestore_api_lookup_shadow_filter.c
423test_namestore_api_lookup_shadow_filter_sqlite_LDADD = \
424 $(top_builddir)/src/testing/libgnunettesting.la \
425 $(top_builddir)/src/identity/libgnunetidentity.la \
426 $(top_builddir)/src/util/libgnunetutil.la \
427 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
428 $(top_builddir)/src/namecache/libgnunetnamecache.la \
429 libgnunetnamestore.la
430test_namestore_api_lookup_shadow_filter_postgres_SOURCES = \
431 test_namestore_api_lookup_shadow_filter.c
432test_namestore_api_lookup_shadow_filter_postgres_LDADD = \
433 $(top_builddir)/src/testing/libgnunettesting.la \
434 $(top_builddir)/src/identity/libgnunetidentity.la \
435 $(top_builddir)/src/util/libgnunetutil.la \
436 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
437 $(top_builddir)/src/namecache/libgnunetnamecache.la \
438 libgnunetnamestore.la
439
440test_namestore_api_remove_sqlite_SOURCES = \ 268test_namestore_api_remove_sqlite_SOURCES = \
441 test_namestore_api_remove.c 269 test_namestore_api_remove.c
442test_namestore_api_remove_sqlite_LDADD = \ 270test_namestore_api_remove_sqlite_LDADD = \
@@ -455,24 +283,6 @@ test_namestore_api_remove_postgres_LDADD = \
455 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 283 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
456 libgnunetnamestore.la 284 libgnunetnamestore.la
457 285
458test_namestore_api_remove_flat_SOURCES = \
459 test_namestore_api_remove.c
460test_namestore_api_remove_flat_LDADD = \
461 $(top_builddir)/src/testing/libgnunettesting.la \
462 $(top_builddir)/src/identity/libgnunetidentity.la \
463 $(top_builddir)/src/util/libgnunetutil.la \
464 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
465 libgnunetnamestore.la
466
467test_namestore_api_remove_not_existing_record_flat_SOURCES = \
468 test_namestore_api_remove_not_existing_record.c
469test_namestore_api_remove_not_existing_record_flat_LDADD = \
470 $(top_builddir)/src/testing/libgnunettesting.la \
471 $(top_builddir)/src/identity/libgnunetidentity.la \
472 $(top_builddir)/src/util/libgnunetutil.la \
473 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
474 libgnunetnamestore.la
475
476test_namestore_api_remove_not_existing_record_sqlite_SOURCES = \ 286test_namestore_api_remove_not_existing_record_sqlite_SOURCES = \
477 test_namestore_api_remove_not_existing_record.c 287 test_namestore_api_remove_not_existing_record.c
478test_namestore_api_remove_not_existing_record_sqlite_LDADD = \ 288test_namestore_api_remove_not_existing_record_sqlite_LDADD = \
@@ -491,14 +301,6 @@ test_namestore_api_remove_not_existing_record_postgres_LDADD = \
491 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 301 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
492 libgnunetnamestore.la 302 libgnunetnamestore.la
493 303
494test_namestore_api_zone_to_name_flat_SOURCES = \
495 test_namestore_api_zone_to_name.c
496test_namestore_api_zone_to_name_flat_LDADD = \
497 $(top_builddir)/src/identity/libgnunetidentity.la \
498 $(top_builddir)/src/testing/libgnunettesting.la \
499 $(top_builddir)/src/util/libgnunetutil.la \
500 libgnunetnamestore.la
501
502test_namestore_api_zone_to_name_sqlite_SOURCES = \ 304test_namestore_api_zone_to_name_sqlite_SOURCES = \
503 test_namestore_api_zone_to_name.c 305 test_namestore_api_zone_to_name.c
504test_namestore_api_zone_to_name_sqlite_LDADD = \ 306test_namestore_api_zone_to_name_sqlite_LDADD = \
@@ -515,15 +317,6 @@ test_namestore_api_zone_to_name_postgres_LDADD = \
515 $(top_builddir)/src/util/libgnunetutil.la \ 317 $(top_builddir)/src/util/libgnunetutil.la \
516 libgnunetnamestore.la 318 libgnunetnamestore.la
517 319
518test_namestore_api_monitoring_flat_SOURCES = \
519 test_namestore_api_monitoring.c
520test_namestore_api_monitoring_flat_LDADD = \
521 $(top_builddir)/src/testing/libgnunettesting.la \
522 libgnunetnamestore.la \
523 $(top_builddir)/src/identity/libgnunetidentity.la \
524 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
525 $(top_builddir)/src/util/libgnunetutil.la
526
527test_namestore_api_monitoring_sqlite_SOURCES = \ 320test_namestore_api_monitoring_sqlite_SOURCES = \
528 test_namestore_api_monitoring.c 321 test_namestore_api_monitoring.c
529test_namestore_api_monitoring_sqlite_LDADD = \ 322test_namestore_api_monitoring_sqlite_LDADD = \
@@ -542,41 +335,52 @@ test_namestore_api_monitoring_postgres_LDADD = \
542 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 335 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
543 $(top_builddir)/src/util/libgnunetutil.la 336 $(top_builddir)/src/util/libgnunetutil.la
544 337
545test_namestore_api_monitoring_existing_flat_SOURCES = \ 338test_namestore_api_monitoring_existing_sqlite_SOURCES = \
546 test_namestore_api_monitoring_existing.c 339 test_namestore_api_monitoring_existing.c
547test_namestore_api_monitoring_existing_flat_LDADD = \ 340test_namestore_api_monitoring_existing_sqlite_LDADD = \
548 $(top_builddir)/src/testing/libgnunettesting.la \ 341 $(top_builddir)/src/testing/libgnunettesting.la \
549 $(top_builddir)/src/identity/libgnunetidentity.la \ 342 $(top_builddir)/src/identity/libgnunetidentity.la \
550 libgnunetnamestore.la \ 343 libgnunetnamestore.la \
551 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 344 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
552 $(top_builddir)/src/util/libgnunetutil.la 345 $(top_builddir)/src/util/libgnunetutil.la
553 346
554test_namestore_api_monitoring_existing_sqlite_SOURCES = \ 347test_namestore_api_monitoring_existing_postgres_SOURCES = \
555 test_namestore_api_monitoring_existing.c 348 test_namestore_api_monitoring_existing.c
556test_namestore_api_monitoring_existing_sqlite_LDADD = \ 349test_namestore_api_monitoring_existing_postgres_LDADD = \
557 $(top_builddir)/src/testing/libgnunettesting.la \ 350 $(top_builddir)/src/testing/libgnunettesting.la \
558 $(top_builddir)/src/identity/libgnunetidentity.la \
559 libgnunetnamestore.la \ 351 libgnunetnamestore.la \
560 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 352 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
353 $(top_builddir)/src/identity/libgnunetidentity.la \
561 $(top_builddir)/src/util/libgnunetutil.la 354 $(top_builddir)/src/util/libgnunetutil.la
562 355
563test_namestore_api_monitoring_existing_postgres_SOURCES = \ 356test_namestore_api_tx_rollback_sqlite_SOURCES = \
564 test_namestore_api_monitoring_existing.c 357 test_namestore_api_tx_rollback.c
565test_namestore_api_monitoring_existing_postgres_LDADD = \ 358test_namestore_api_tx_rollback_sqlite_LDADD = \
566 $(top_builddir)/src/testing/libgnunettesting.la \ 359 $(top_builddir)/src/testing/libgnunettesting.la \
360 $(top_builddir)/src/identity/libgnunetidentity.la \
567 libgnunetnamestore.la \ 361 libgnunetnamestore.la \
568 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 362 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
363 $(top_builddir)/src/util/libgnunetutil.la
364
365test_namestore_api_tx_rollback_postgres_SOURCES = \
366 test_namestore_api_tx_rollback.c
367test_namestore_api_tx_rollback_postgres_LDADD = \
368 $(top_builddir)/src/testing/libgnunettesting.la \
569 $(top_builddir)/src/identity/libgnunetidentity.la \ 369 $(top_builddir)/src/identity/libgnunetidentity.la \
370 libgnunetnamestore.la \
371 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
570 $(top_builddir)/src/util/libgnunetutil.la 372 $(top_builddir)/src/util/libgnunetutil.la
571 373
572test_namestore_api_zone_iteration_flat_SOURCES = \ 374if HAVE_EXPERIMENTAL
573 test_namestore_api_zone_iteration.c 375test_namestore_api_edit_records_postgres_SOURCES = \
574test_namestore_api_zone_iteration_flat_LDADD = \ 376 test_namestore_api_edit_records.c
377test_namestore_api_edit_records_postgres_LDADD = \
575 $(top_builddir)/src/testing/libgnunettesting.la \ 378 $(top_builddir)/src/testing/libgnunettesting.la \
576 $(top_builddir)/src/identity/libgnunetidentity.la \ 379 $(top_builddir)/src/identity/libgnunetidentity.la \
577 $(top_builddir)/src/util/libgnunetutil.la \ 380 libgnunetnamestore.la \
578 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 381 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
579 libgnunetnamestore.la 382 $(top_builddir)/src/util/libgnunetutil.la
383endif
580 384
581test_namestore_api_zone_iteration_sqlite_SOURCES = \ 385test_namestore_api_zone_iteration_sqlite_SOURCES = \
582 test_namestore_api_zone_iteration.c 386 test_namestore_api_zone_iteration.c
@@ -605,30 +409,31 @@ perf_namestore_api_zone_iteration_postgres_LDADD = \
605 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 409 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
606 libgnunetnamestore.la 410 libgnunetnamestore.la
607 411
608perf_namestore_api_zone_iteration_sqlite_SOURCES = \ 412perf_namestore_api_import_sqlite_SOURCES = \
609 perf_namestore_api_zone_iteration.c 413 perf_namestore_api_import.c
610perf_namestore_api_zone_iteration_sqlite_LDADD = \ 414perf_namestore_api_import_sqlite_LDADD = \
611 $(top_builddir)/src/testing/libgnunettesting.la \ 415 $(top_builddir)/src/testing/libgnunettesting.la \
612 $(top_builddir)/src/identity/libgnunetidentity.la \
613 $(top_builddir)/src/util/libgnunetutil.la \ 416 $(top_builddir)/src/util/libgnunetutil.la \
417 $(top_builddir)/src/identity/libgnunetidentity.la \
614 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 418 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
615 libgnunetnamestore.la 419 libgnunetnamestore.la
616 420
617perf_namestore_api_zone_iteration_flat_SOURCES = \ 421perf_namestore_api_import_postgres_SOURCES = \
618 perf_namestore_api_zone_iteration.c 422 perf_namestore_api_import.c
619perf_namestore_api_zone_iteration_flat_LDADD = \ 423perf_namestore_api_import_postgres_LDADD = \
620 $(top_builddir)/src/testing/libgnunettesting.la \ 424 $(top_builddir)/src/testing/libgnunettesting.la \
621 $(top_builddir)/src/identity/libgnunetidentity.la \
622 $(top_builddir)/src/util/libgnunetutil.la \ 425 $(top_builddir)/src/util/libgnunetutil.la \
426 $(top_builddir)/src/identity/libgnunetidentity.la \
623 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 427 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
624 libgnunetnamestore.la 428 libgnunetnamestore.la
625 429
626test_namestore_api_zone_iteration_nick_flat_SOURCES = \ 430
627 test_namestore_api_zone_iteration_nick.c 431perf_namestore_api_zone_iteration_sqlite_SOURCES = \
628test_namestore_api_zone_iteration_nick_flat_LDADD = \ 432 perf_namestore_api_zone_iteration.c
433perf_namestore_api_zone_iteration_sqlite_LDADD = \
629 $(top_builddir)/src/testing/libgnunettesting.la \ 434 $(top_builddir)/src/testing/libgnunettesting.la \
630 $(top_builddir)/src/util/libgnunetutil.la \
631 $(top_builddir)/src/identity/libgnunetidentity.la \ 435 $(top_builddir)/src/identity/libgnunetidentity.la \
436 $(top_builddir)/src/util/libgnunetutil.la \
632 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 437 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
633 libgnunetnamestore.la 438 libgnunetnamestore.la
634 439
@@ -650,15 +455,6 @@ test_namestore_api_zone_iteration_nick_postgres_LDADD = \
650 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 455 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
651 libgnunetnamestore.la 456 libgnunetnamestore.la
652 457
653test_namestore_api_zone_iteration_specific_zone_flat_SOURCES = \
654 test_namestore_api_zone_iteration_specific_zone.c
655test_namestore_api_zone_iteration_specific_zone_flat_LDADD = \
656 $(top_builddir)/src/testing/libgnunettesting.la \
657 $(top_builddir)/src/identity/libgnunetidentity.la \
658 $(top_builddir)/src/util/libgnunetutil.la \
659 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
660 libgnunetnamestore.la
661
662test_namestore_api_zone_iteration_specific_zone_sqlite_SOURCES = \ 458test_namestore_api_zone_iteration_specific_zone_sqlite_SOURCES = \
663 test_namestore_api_zone_iteration_specific_zone.c 459 test_namestore_api_zone_iteration_specific_zone.c
664test_namestore_api_zone_iteration_specific_zone_sqlite_LDADD = \ 460test_namestore_api_zone_iteration_specific_zone_sqlite_LDADD = \
@@ -677,15 +473,6 @@ test_namestore_api_zone_iteration_specific_zone_postgres_LDADD = \
677 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 473 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
678 libgnunetnamestore.la 474 libgnunetnamestore.la
679 475
680test_namestore_api_zone_iteration_stop_flat_SOURCES = \
681 test_namestore_api_zone_iteration_stop.c
682test_namestore_api_zone_iteration_stop_flat_LDADD = \
683 $(top_builddir)/src/testing/libgnunettesting.la \
684 $(top_builddir)/src/identity/libgnunetidentity.la \
685 $(top_builddir)/src/util/libgnunetutil.la \
686 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
687 libgnunetnamestore.la
688
689test_namestore_api_zone_iteration_stop_sqlite_SOURCES = \ 476test_namestore_api_zone_iteration_stop_sqlite_SOURCES = \
690 test_namestore_api_zone_iteration_stop.c 477 test_namestore_api_zone_iteration_stop.c
691test_namestore_api_zone_iteration_stop_sqlite_LDADD = \ 478test_namestore_api_zone_iteration_stop_sqlite_LDADD = \
@@ -704,13 +491,6 @@ test_namestore_api_zone_iteration_stop_postgres_LDADD = \
704 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 491 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
705 libgnunetnamestore.la 492 libgnunetnamestore.la
706 493
707test_plugin_namestore_flat_SOURCES = \
708 test_plugin_namestore.c
709test_plugin_namestore_flat_LDADD = \
710 $(top_builddir)/src/testing/libgnunettesting.la \
711 $(top_builddir)/src/identity/libgnunetidentity.la \
712 $(top_builddir)/src/util/libgnunetutil.la
713
714test_plugin_namestore_sqlite_SOURCES = \ 494test_plugin_namestore_sqlite_SOURCES = \
715 test_plugin_namestore.c 495 test_plugin_namestore.c
716test_plugin_namestore_sqlite_LDADD = \ 496test_plugin_namestore_sqlite_LDADD = \
@@ -730,20 +510,18 @@ check_SCRIPTS = \
730 test_namestore_lookup.sh \ 510 test_namestore_lookup.sh \
731 test_namestore_delete.sh 511 test_namestore_delete.sh
732 512
733check_SCRIPTS += \ 513# FIXME
734 test_plugin_rest_namestore.sh 514#check_SCRIPTS += \
515# test_plugin_rest_namestore.sh
735 516
736EXTRA_DIST = \ 517EXTRA_DIST = \
737 test_common.c \ 518 test_common.c \
738 test_namestore_api.conf \ 519 test_namestore_api.conf \
739 test_namestore_api_postgres.conf \ 520 test_namestore_api_postgres.conf \
740 test_namestore_api_sqlite.conf \ 521 test_namestore_api_sqlite.conf \
741 test_namestore_api_flat.conf \
742 perf_namestore_api_postgres.conf \ 522 perf_namestore_api_postgres.conf \
743 perf_namestore_api_sqlite.conf \ 523 perf_namestore_api_sqlite.conf \
744 perf_namestore_api_flat.conf \
745 test_plugin_namestore_sqlite.conf \ 524 test_plugin_namestore_sqlite.conf \
746 test_plugin_namestore_postgres.conf \ 525 test_plugin_namestore_postgres.conf \
747 test_plugin_namestore_flat.conf \
748 test_hostkey \ 526 test_hostkey \
749 $(check_SCRIPTS) 527 $(check_SCRIPTS)