aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2012-03-01 16:17:42 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2012-03-01 16:17:42 +0000
commit9121b5fdbb38b5ee48695edf5c45bfca1eeb0a29 (patch)
tree4f068c748a15f56427bab8669ec4b16a75d8f67c /src/namestore/Makefile.am
parent95fe108b12cbc93c5e4ea6504931b5c3239ff4c5 (diff)
downloadgnunet-9121b5fdbb38b5ee48695edf5c45bfca1eeb0a29.tar.gz
gnunet-9121b5fdbb38b5ee48695edf5c45bfca1eeb0a29.zip
- more changes: sign & verify working and tested
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 5f2e23e8b..4d9410f7b 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -24,11 +24,13 @@ endif
24 24
25check_PROGRAMS = \ 25check_PROGRAMS = \
26 $(SQLITE_TESTS) \ 26 $(SQLITE_TESTS) \
27 test_namestore_api_sign_verify \
27 test_namestore_api \ 28 test_namestore_api \
28 test_namestore_api_put \ 29 test_namestore_api_put \
29 test_namestore_api_lookup \ 30 test_namestore_api_lookup \
30 test_namestore_api_create \ 31 test_namestore_api_create \
31 test_namestore_api_remove \ 32 test_namestore_api_remove \
33 test_namestore_api_remove_not_existing_record \
32 test_namestore_api_zone_iteration \ 34 test_namestore_api_zone_iteration \
33 test_namestore_record_serialization 35 test_namestore_record_serialization
34 36
@@ -78,6 +80,12 @@ libgnunet_plugin_namestore_sqlite_la_LIBADD = \
78libgnunet_plugin_namestore_sqlite_la_LDFLAGS = \ 80libgnunet_plugin_namestore_sqlite_la_LDFLAGS = \
79 $(GN_PLUGIN_LDFLAGS) 81 $(GN_PLUGIN_LDFLAGS)
80 82
83test_namestore_api_sign_verify_SOURCES = \
84 test_namestore_api_sign_verify.c
85test_namestore_api_sign_verify_LDADD = \
86 $(top_builddir)/src/util/libgnunetutil.la \
87 $(top_builddir)/src/namestore/libgnunetnamestore.la
88
81test_namestore_api_SOURCES = \ 89test_namestore_api_SOURCES = \
82 test_namestore_api.c 90 test_namestore_api.c
83test_namestore_api_LDADD = \ 91test_namestore_api_LDADD = \
@@ -108,6 +116,11 @@ test_namestore_api_remove_LDADD = \
108 $(top_builddir)/src/util/libgnunetutil.la \ 116 $(top_builddir)/src/util/libgnunetutil.la \
109 $(top_builddir)/src/namestore/libgnunetnamestore.la 117 $(top_builddir)/src/namestore/libgnunetnamestore.la
110 118
119test_namestore_api_remove_not_existing_record_SOURCES = \
120 test_namestore_api_remove_not_existing_record.c
121test_namestore_api_remove_not_existing_record_LDADD = \
122 $(top_builddir)/src/util/libgnunetutil.la \
123 $(top_builddir)/src/namestore/libgnunetnamestore.la
111 124
112test_namestore_api_zone_iteration_SOURCES = \ 125test_namestore_api_zone_iteration_SOURCES = \
113 test_namestore_api_zone_iteration.c 126 test_namestore_api_zone_iteration.c