aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-10-08 19:55:45 +0000
committerChristian Grothoff <christian@grothoff.org>2013-10-08 19:55:45 +0000
commitbe86840fb6144a631ff18237bc31abb7a97938f7 (patch)
treedfa68dcd690a40c5c060cd6ad7ad017696333655 /src/namestore/Makefile.am
parent5049585e7942ad3fe3f8742832a2b4f76ec5a954 (diff)
downloadgnunet-be86840fb6144a631ff18237bc31abb7a97938f7.tar.gz
gnunet-be86840fb6144a631ff18237bc31abb7a97938f7.zip
towards implementing postgres backend for namestore (#2987)
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am38
1 files changed, 18 insertions, 20 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index f19c9bff9..f6aa2a085 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -22,19 +22,17 @@ endif
22if HAVE_SQLITE 22if HAVE_SQLITE
23SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la 23SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
24if HAVE_TESTING 24if HAVE_TESTING
25SQLITE_TESTS = test_plugin_namestore_sqlite 25SQLITE_TESTS = test_plugin_namestore_sqlite
26endif 26endif
27endif 27endif
28 28
29if HAVE_POSTGRES 29if HAVE_POSTGRES
30# postgres doesn't even build yet; thus: experimental! 30# postgres doesn't even build yet; thus: experimental!
31if HAVE_EXPERIMENTAL
32POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la 31POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la
33if HAVE_TESTING 32if HAVE_TESTING
34POSTGRES_TESTS = test_plugin_namestore_postgres 33POSTGRES_TESTS = test_plugin_namestore_postgres
35endif 34endif
36endif 35endif
37endif
38 36
39# testcases do not even build yet; thus: experimental! 37# testcases do not even build yet; thus: experimental!
40if HAVE_TESTING 38if HAVE_TESTING
@@ -50,7 +48,7 @@ TESTING_TESTS = \
50 test_namestore_api_zone_iteration_stop \ 48 test_namestore_api_zone_iteration_stop \
51 test_namestore_api_monitoring \ 49 test_namestore_api_monitoring \
52 test_namestore_api_monitoring_existing 50 test_namestore_api_monitoring_existing
53#test_namestore_api_zone_to_name 51#test_namestore_api_zone_to_name
54endif 52endif
55 53
56if HAVE_SQLITE 54if HAVE_SQLITE
@@ -65,7 +63,7 @@ endif
65if ENABLE_TEST_RUN 63if ENABLE_TEST_RUN
66TESTS = \ 64TESTS = \
67 $(check_PROGRAMS) \ 65 $(check_PROGRAMS) \
68 $(check_SCRIPTS) 66 $(check_SCRIPTS)
69endif 67endif
70 68
71lib_LTLIBRARIES = \ 69lib_LTLIBRARIES = \
@@ -80,16 +78,16 @@ libgnunetnamestore_la_LIBADD = \
80 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 78 $(top_builddir)/src/statistics/libgnunetstatistics.la \
81 $(top_builddir)/src/dns/libgnunetdnsparser.la \ 79 $(top_builddir)/src/dns/libgnunetdnsparser.la \
82 $(top_builddir)/src/util/libgnunetutil.la \ 80 $(top_builddir)/src/util/libgnunetutil.la \
83 $(GN_LIBINTL) 81 $(GN_LIBINTL)
84libgnunetnamestore_la_LDFLAGS = \ 82libgnunetnamestore_la_LDFLAGS = \
85 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 83 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
86 -version-info 0:1:0 84 -version-info 0:1:0
87 85
88libexec_PROGRAMS = \ 86libexec_PROGRAMS = \
89 gnunet-service-namestore 87 gnunet-service-namestore
90 88
91bin_PROGRAMS = \ 89bin_PROGRAMS = \
92 gnunet-namestore 90 gnunet-namestore
93 91
94if HAVE_MHD 92if HAVE_MHD
95libexec_PROGRAMS += \ 93libexec_PROGRAMS += \
@@ -97,7 +95,7 @@ libexec_PROGRAMS += \
97endif 95endif
98 96
99gnunet_namestore_SOURCES = \ 97gnunet_namestore_SOURCES = \
100 gnunet-namestore.c 98 gnunet-namestore.c
101gnunet_namestore_LDADD = \ 99gnunet_namestore_LDADD = \
102 $(top_builddir)/src/util/libgnunetutil.la \ 100 $(top_builddir)/src/util/libgnunetutil.la \
103 $(top_builddir)/src/identity/libgnunetidentity.la \ 101 $(top_builddir)/src/identity/libgnunetidentity.la \
@@ -110,7 +108,7 @@ gnunet_namestore_DEPENDENCIES = \
110 108
111 109
112gnunet_namestore_fcfsd_SOURCES = \ 110gnunet_namestore_fcfsd_SOURCES = \
113 gnunet-namestore-fcfsd.c 111 gnunet-namestore-fcfsd.c
114gnunet_namestore_fcfsd_LDADD = -lmicrohttpd \ 112gnunet_namestore_fcfsd_LDADD = -lmicrohttpd \
115 $(top_builddir)/src/util/libgnunetutil.la \ 113 $(top_builddir)/src/util/libgnunetutil.la \
116 $(top_builddir)/src/identity/libgnunetidentity.la \ 114 $(top_builddir)/src/identity/libgnunetidentity.la \
@@ -141,7 +139,7 @@ plugin_LTLIBRARIES = \
141 $(POSTGRES_PLUGIN) 139 $(POSTGRES_PLUGIN)
142 140
143libgnunet_plugin_namestore_sqlite_la_SOURCES = \ 141libgnunet_plugin_namestore_sqlite_la_SOURCES = \
144 plugin_namestore_sqlite.c 142 plugin_namestore_sqlite.c
145libgnunet_plugin_namestore_sqlite_la_LIBADD = \ 143libgnunet_plugin_namestore_sqlite_la_LIBADD = \
146 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 144 $(top_builddir)/src/namestore/libgnunetnamestore.la \
147 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 145 $(top_builddir)/src/statistics/libgnunetstatistics.la \
@@ -156,7 +154,7 @@ libgnunet_plugin_namestore_sqlite_la_DEPENDENCIES = \
156 154
157 155
158libgnunet_plugin_namestore_postgres_la_SOURCES = \ 156libgnunet_plugin_namestore_postgres_la_SOURCES = \
159 plugin_namestore_postgres.c 157 plugin_namestore_postgres.c
160libgnunet_plugin_namestore_postgres_la_LIBADD = \ 158libgnunet_plugin_namestore_postgres_la_LIBADD = \
161 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 159 $(top_builddir)/src/namestore/libgnunetnamestore.la \
162 $(top_builddir)/src/postgres/libgnunetpostgres.la \ 160 $(top_builddir)/src/postgres/libgnunetpostgres.la \
@@ -239,48 +237,48 @@ test_namestore_api_monitoring_SOURCES = \
239test_namestore_api_monitoring_LDADD = \ 237test_namestore_api_monitoring_LDADD = \
240 $(top_builddir)/src/testing/libgnunettesting.la \ 238 $(top_builddir)/src/testing/libgnunettesting.la \
241 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 239 $(top_builddir)/src/namestore/libgnunetnamestore.la \
242 $(top_builddir)/src/util/libgnunetutil.la 240 $(top_builddir)/src/util/libgnunetutil.la
243 241
244test_namestore_api_monitoring_existing_SOURCES = \ 242test_namestore_api_monitoring_existing_SOURCES = \
245 test_namestore_api_monitoring_existing.c 243 test_namestore_api_monitoring_existing.c
246test_namestore_api_monitoring_existing_LDADD = \ 244test_namestore_api_monitoring_existing_LDADD = \
247 $(top_builddir)/src/testing/libgnunettesting.la \ 245 $(top_builddir)/src/testing/libgnunettesting.la \
248 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 246 $(top_builddir)/src/namestore/libgnunetnamestore.la \
249 $(top_builddir)/src/util/libgnunetutil.la 247 $(top_builddir)/src/util/libgnunetutil.la
250 248
251test_namestore_api_zone_iteration_SOURCES = \ 249test_namestore_api_zone_iteration_SOURCES = \
252 test_namestore_api_zone_iteration.c 250 test_namestore_api_zone_iteration.c
253test_namestore_api_zone_iteration_LDADD = \ 251test_namestore_api_zone_iteration_LDADD = \
254 $(top_builddir)/src/testing/libgnunettesting.la \ 252 $(top_builddir)/src/testing/libgnunettesting.la \
255 $(top_builddir)/src/util/libgnunetutil.la \ 253 $(top_builddir)/src/util/libgnunetutil.la \
256 $(top_builddir)/src/namestore/libgnunetnamestore.la 254 $(top_builddir)/src/namestore/libgnunetnamestore.la
257 255
258test_namestore_api_zone_iteration_specific_zone_SOURCES = \ 256test_namestore_api_zone_iteration_specific_zone_SOURCES = \
259 test_namestore_api_zone_iteration_specific_zone.c 257 test_namestore_api_zone_iteration_specific_zone.c
260test_namestore_api_zone_iteration_specific_zone_LDADD = \ 258test_namestore_api_zone_iteration_specific_zone_LDADD = \
261 $(top_builddir)/src/testing/libgnunettesting.la \ 259 $(top_builddir)/src/testing/libgnunettesting.la \
262 $(top_builddir)/src/util/libgnunetutil.la \ 260 $(top_builddir)/src/util/libgnunetutil.la \
263 $(top_builddir)/src/namestore/libgnunetnamestore.la 261 $(top_builddir)/src/namestore/libgnunetnamestore.la
264 262
265test_namestore_api_zone_iteration_stop_SOURCES = \ 263test_namestore_api_zone_iteration_stop_SOURCES = \
266 test_namestore_api_zone_iteration_stop.c 264 test_namestore_api_zone_iteration_stop.c
267test_namestore_api_zone_iteration_stop_LDADD = \ 265test_namestore_api_zone_iteration_stop_LDADD = \
268 $(top_builddir)/src/testing/libgnunettesting.la \ 266 $(top_builddir)/src/testing/libgnunettesting.la \
269 $(top_builddir)/src/util/libgnunetutil.la \ 267 $(top_builddir)/src/util/libgnunetutil.la \
270 $(top_builddir)/src/namestore/libgnunetnamestore.la 268 $(top_builddir)/src/namestore/libgnunetnamestore.la
271 269
272test_namestore_record_serialization_SOURCES = \ 270test_namestore_record_serialization_SOURCES = \
273 test_namestore_record_serialization.c 271 test_namestore_record_serialization.c
274test_namestore_record_serialization_LDADD = \ 272test_namestore_record_serialization_LDADD = \
275 $(top_builddir)/src/testing/libgnunettesting.la \ 273 $(top_builddir)/src/testing/libgnunettesting.la \
276 $(top_builddir)/src/util/libgnunetutil.la \ 274 $(top_builddir)/src/util/libgnunetutil.la \
277 $(top_builddir)/src/namestore/libgnunetnamestore.la 275 $(top_builddir)/src/namestore/libgnunetnamestore.la
278 276
279test_plugin_namestore_sqlite_SOURCES = \ 277test_plugin_namestore_sqlite_SOURCES = \
280 test_plugin_namestore.c 278 test_plugin_namestore.c
281test_plugin_namestore_sqlite_LDADD = \ 279test_plugin_namestore_sqlite_LDADD = \
282 $(top_builddir)/src/testing/libgnunettesting.la \ 280 $(top_builddir)/src/testing/libgnunettesting.la \
283 $(top_builddir)/src/util/libgnunetutil.la 281 $(top_builddir)/src/util/libgnunetutil.la
284 282
285test_plugin_namestore_postgres_SOURCES = \ 283test_plugin_namestore_postgres_SOURCES = \
286 test_plugin_namestore.c 284 test_plugin_namestore.c
@@ -291,7 +289,7 @@ test_plugin_namestore_postgres_LDADD = \
291check_SCRIPTS = \ 289check_SCRIPTS = \
292 test_namestore_put.sh \ 290 test_namestore_put.sh \
293 test_namestore_lookup.sh \ 291 test_namestore_lookup.sh \
294 test_namestore_delete.sh 292 test_namestore_delete.sh
295 293
296EXTRA_DIST = \ 294EXTRA_DIST = \
297 test_namestore_api.conf \ 295 test_namestore_api.conf \