aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/meson.build
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2023-09-28 14:23:13 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2023-09-28 14:23:13 +0200
commitd43a6c820edcf173fe4822bdf15a3ecb6ca32cf6 (patch)
tree6a327cfc4c95ff6ab7de88f943c0221030bcfe10 /src/namestore/meson.build
parent2a7fbf3dd32a57fd6a8fc4516c75cbc984bfb5f2 (diff)
downloadgnunet-d43a6c820edcf173fe4822bdf15a3ecb6ca32cf6.tar.gz
gnunet-d43a6c820edcf173fe4822bdf15a3ecb6ca32cf6.zip
BUILD: Meson add more file targets
Diffstat (limited to 'src/namestore/meson.build')
-rw-r--r--src/namestore/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/namestore/meson.build b/src/namestore/meson.build
index 133c98d6c..ea44779cd 100644
--- a/src/namestore/meson.build
+++ b/src/namestore/meson.build
@@ -32,6 +32,22 @@ libgnunetnamestore_dep = declare_dependency(link_with : libgnunetnamestore)
32pkg.generate(libgnunetnamestore, url: 'https://www.gnunet.org', 32pkg.generate(libgnunetnamestore, url: 'https://www.gnunet.org',
33 description : 'Provides API for storing GNS records to a database') 33 description : 'Provides API for storing GNS records to a database')
34 34
35shared_module('gnunet_plugin_rest_namestore',
36 ['plugin_rest_namestore.c'],
37 dependencies: [libgnunetrest_dep,
38 libgnunetidentity_dep,
39 libgnunetgnsrecordjson_dep,
40 libgnunetgnsrecord_dep,
41 libgnunetnamestore_dep,
42 libgnunetjson_dep,
43 libgnunetutil_dep,
44 json_dep,
45 mhd_dep],
46 include_directories: [incdir, configuration_inc],
47 install: true,
48 install_dir: get_option('libdir') / 'gnunet' / 'libexec')
49
50
35shared_module('gnunet_plugin_namestore_sqlite', 51shared_module('gnunet_plugin_namestore_sqlite',
36 libgnunetpluginnamestore_sqlite_src, 52 libgnunetpluginnamestore_sqlite_src,
37 dependencies: [libgnunetutil_dep, 53 dependencies: [libgnunetutil_dep,