aboutsummaryrefslogtreecommitdiff
path: root/src/nat/Makefile.am
diff options
context:
space:
mode:
authorMoon <moon@140774ce-b5e7-0310-ab8b-a85725594a96>2010-10-09 13:53:47 +0000
committerMoon <moon@140774ce-b5e7-0310-ab8b-a85725594a96>2010-10-09 13:53:47 +0000
commit922a0672749ba9d496d1dd8f6596bb4f8035e71d (patch)
treeccd4b351bd5acd5cc3b8b1cc358c712d6c0c116d /src/nat/Makefile.am
parentdc24b5bf44bf8d9460b2571fe529403637aa3e16 (diff)
downloadgnunet-922a0672749ba9d496d1dd8f6596bb4f8035e71d.tar.gz
gnunet-922a0672749ba9d496d1dd8f6596bb4f8035e71d.zip
rework UPnP code to use GNUnet scheduler and network API
disable NAT-PMP support for now
Diffstat (limited to 'src/nat/Makefile.am')
-rw-r--r--src/nat/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/src/nat/Makefile.am b/src/nat/Makefile.am
index c47348b7c..1b53095f3 100644
--- a/src/nat/Makefile.am
+++ b/src/nat/Makefile.am
@@ -1,5 +1,3 @@
1SUBDIRS = .
2
3INCLUDES = -I$(top_srcdir)/src/include 1INCLUDES = -I$(top_srcdir)/src/include
4 2
5if MINGW 3if MINGW
@@ -18,11 +16,16 @@ endif
18 16
19libgnunetnat_la_SOURCES = \ 17libgnunetnat_la_SOURCES = \
20 upnp.c upnp.h \ 18 upnp.c upnp.h \
21 natpmp.c natpmp.h \ 19 upnp-commands.c upnp-commands.h \
20 upnp-discover.c upnp-discover.h \
21 upnp-igd-parse.c upnp-igd-parse.h \
22 upnp-minixml.c upnp-minixml.h \
23 upnp-reply-parse.c upnp-reply-parse.h bsdqueue.h \
22 nat.c 24 nat.c
23 25
24libgnunetnat_la_CFLAGS = \ 26libgnunetnat_la_CFLAGS = \
25 -I$(top_scrdir)/include 27 -I$(top_scrdir)/include \
28 -DDEBUG_UPNP -g -O0
26 29
27libgnunetnat_la_LIBADD = \ 30libgnunetnat_la_LIBADD = \
28 $(top_builddir)/src/util/libgnunetutil.la \ 31 $(top_builddir)/src/util/libgnunetutil.la \
@@ -46,6 +49,6 @@ test_nat_SOURCES = \
46 49
47test_nat_LDADD = \ 50test_nat_LDADD = \
48 $(top_builddir)/src/nat/libgnunetnat.la \ 51 $(top_builddir)/src/nat/libgnunetnat.la \
49 $(top_builddir)/src/util/libgnunetutil.la 52 $(top_builddir)/src/util/libgnunetutil.la \
50 53 @LIBCURL@
51endif 54endif