aboutsummaryrefslogtreecommitdiff
path: root/src/nse/Makefile.am
diff options
context:
space:
mode:
authorNathan S. Evans <evans@in.tum.de>2011-07-16 11:11:40 +0000
committerNathan S. Evans <evans@in.tum.de>2011-07-16 11:11:40 +0000
commit41479de2a35d2c73cf1f6357af37e8324122e90e (patch)
tree1bb9e1838cf3b7031a0c15696225a4c54af4f0c0 /src/nse/Makefile.am
parentd365e39801ca22440b48ca2fb39c41604d0efc66 (diff)
downloadgnunet-41479de2a35d2c73cf1f6357af37e8324122e90e.tar.gz
gnunet-41479de2a35d2c73cf1f6357af37e8324122e90e.zip
nse updates
Diffstat (limited to 'src/nse/Makefile.am')
-rw-r--r--src/nse/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/nse/Makefile.am b/src/nse/Makefile.am
index fa9d43f4d..a13d6d8b1 100644
--- a/src/nse/Makefile.am
+++ b/src/nse/Makefile.am
@@ -40,13 +40,15 @@ gnunet_service_nse_LDADD = \
40 $(top_builddir)/src/nse/libgnunetnse.la \ 40 $(top_builddir)/src/nse/libgnunetnse.la \
41 $(top_builddir)/src/util/libgnunetutil.la \ 41 $(top_builddir)/src/util/libgnunetutil.la \
42 $(top_builddir)/src/core/libgnunetcore.la \ 42 $(top_builddir)/src/core/libgnunetcore.la \
43 $(top_builddir)/src/statistics/libgnunetstatistics.la \
43 -lm \ 44 -lm \
44 $(GN_LIBINTL) 45 $(GN_LIBINTL)
45gnunet_service_nse_DEPENDENCIES = \ 46gnunet_service_nse_DEPENDENCIES = \
46 libgnunetnse.la 47 libgnunetnse.la
47 48
48check_PROGRAMS = \ 49check_PROGRAMS = \
49 test_nse_api 50 test_nse_api \
51 test_nse_multipeer
50 52
51if ENABLE_TEST_RUN 53if ENABLE_TEST_RUN
52TESTS = $(check_PROGRAMS) $(check_SCRIPTS) 54TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
@@ -58,9 +60,15 @@ test_nse_api_LDADD = \
58 $(top_builddir)/src/nse/libgnunetnse.la \ 60 $(top_builddir)/src/nse/libgnunetnse.la \
59 $(top_builddir)/src/util/libgnunetutil.la 61 $(top_builddir)/src/util/libgnunetutil.la
60 62
63test_nse_multipeer_SOURCES = \
64 test_nse_multipeer.c
65test_nse_multipeer_LDADD = \
66 $(top_builddir)/src/nse/libgnunetnse.la \
67 $(top_builddir)/src/util/libgnunetutil.la \
68 $(top_builddir)/src/testing/libgnunettesting.la
61 69
62EXTRA_DIST = \ 70EXTRA_DIST = \
63 test_nse_api_data.conf \ 71 test_nse.conf \
64 $(check_SCRIPTS) 72 $(check_SCRIPTS)
65 73
66 74