aboutsummaryrefslogtreecommitdiff
path: root/src/nse/Makefile.am
diff options
context:
space:
mode:
authorNathan S. Evans <evans@in.tum.de>2011-07-08 17:10:45 +0000
committerNathan S. Evans <evans@in.tum.de>2011-07-08 17:10:45 +0000
commit5058b5b92455e26dd740b5c0344f78e95cd0fc2e (patch)
tree0077531e5ff8c9c9348b301a10618b0328bef90e /src/nse/Makefile.am
parenta6627549cdea39c0c5eb75966598e4ee7c31cad1 (diff)
downloadgnunet-5058b5b92455e26dd740b5c0344f78e95cd0fc2e.tar.gz
gnunet-5058b5b92455e26dd740b5c0344f78e95cd0fc2e.zip
initial nse commit
Diffstat (limited to 'src/nse/Makefile.am')
-rw-r--r--src/nse/Makefile.am65
1 files changed, 65 insertions, 0 deletions
diff --git a/src/nse/Makefile.am b/src/nse/Makefile.am
new file mode 100644
index 000000000..bb8e5f509
--- /dev/null
+++ b/src/nse/Makefile.am
@@ -0,0 +1,65 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0
9 XLIB = -lgcov
10endif
11
12
13lib_LTLIBRARIES = libgnunetnse.la
14
15libgnunetnse_la_SOURCES = \
16 nse_api.c nse.h
17libgnunetnse_la_LIBADD = \
18 $(top_builddir)/src/util/libgnunetutil.la \
19 $(GN_LIBINTL) $(XLIB)
20libgnunetnse_la_LDFLAGS = \
21 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
22 -version-info 0:0:0
23
24
25bin_PROGRAMS = \
26 gnunet-service-nse
27
28# gnunet_nse_SOURCES = \
29# gnunet-nse.c
30# gnunet_nse_LDADD = \
31# $(top_builddir)/src/nse/libgnunetnse.la \
32# $(top_builddir)/src/util/libgnunetutil.la \
33# $(GN_LIBINTL)
34# gnunet_nse_DEPENDENCIES = \
35# libgnunetnse.la
36
37gnunet_service_nse_SOURCES = \
38 gnunet-service-nse.c
39gnunet_service_nse_LDADD = \
40 $(top_builddir)/src/nse/libgnunetnse.la \
41 $(top_builddir)/src/util/libgnunetutil.la \
42 $(top_builddir)/src/core/libgnunetcore.la \
43 $(GN_LIBINTL)
44gnunet_service_nse_DEPENDENCIES = \
45 libgnunetnse.la
46
47check_PROGRAMS = \
48 test_nse_api
49
50if ENABLE_TEST_RUN
51TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
52endif
53
54test_nse_api_SOURCES = \
55 test_nse_api.c
56test_nse_api_LDADD = \
57 $(top_builddir)/src/nse/libgnunetnse.la \
58 $(top_builddir)/src/util/libgnunetutil.la
59
60
61EXTRA_DIST = \
62 test_nse_api_data.conf \
63 $(check_SCRIPTS)
64
65