aboutsummaryrefslogtreecommitdiff
path: root/src/peerinfo-tool/Makefile.am
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2019-04-03 21:15:27 +0200
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2019-04-03 21:15:27 +0200
commitcd3db61291fd47b5acde1ae3add16c7ccfc2f996 (patch)
tree00135a5868fa8c4bf4e4c12b2f86562b78764d60 /src/peerinfo-tool/Makefile.am
parenta045962087fe78566bb1aa84693071df857a5d9c (diff)
downloadgnunet-cd3db61291fd47b5acde1ae3add16c7ccfc2f996.tar.gz
gnunet-cd3db61291fd47b5acde1ae3add16c7ccfc2f996.zip
fix rest plugin build
Diffstat (limited to 'src/peerinfo-tool/Makefile.am')
-rw-r--r--src/peerinfo-tool/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/peerinfo-tool/Makefile.am b/src/peerinfo-tool/Makefile.am
index 429224650..a5fd60246 100644
--- a/src/peerinfo-tool/Makefile.am
+++ b/src/peerinfo-tool/Makefile.am
@@ -10,11 +10,33 @@ if USE_COVERAGE
10 XLIB = -lgcov 10 XLIB = -lgcov
11endif 11endif
12 12
13if HAVE_MHD
14if HAVE_JSON
15REST_PLUGIN = libgnunet_plugin_rest_peerinfo.la
16endif
17endif
18
13plugindir = $(libdir)/gnunet 19plugindir = $(libdir)/gnunet
14 20
21plugin_LTLIBRARIES = $(REST_PLUGIN)
22
15bin_PROGRAMS = \ 23bin_PROGRAMS = \
16 gnunet-peerinfo 24 gnunet-peerinfo
17 25
26libgnunet_plugin_rest_peerinfo_la_SOURCES = \
27 plugin_rest_peerinfo.c
28libgnunet_plugin_rest_peerinfo_la_LIBADD = \
29 $(top_builddir)/src/hello/libgnunethello.la \
30 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
31 $(top_builddir)/src/transport/libgnunettransport.la \
32 $(top_builddir)/src/rest/libgnunetrest.la \
33 $(top_builddir)/src/json/libgnunetjson.la \
34 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
35 $(LTLIBINTL) -ljansson -lmicrohttpd
36libgnunet_plugin_rest_peerinfo_la_LDFLAGS = \
37 $(GN_PLUGIN_LDFLAGS)
38
39
18gnunet_peerinfo_SOURCES = \ 40gnunet_peerinfo_SOURCES = \
19 gnunet-peerinfo.c \ 41 gnunet-peerinfo.c \
20 gnunet-peerinfo_plugins.c gnunet-peerinfo_plugins.h 42 gnunet-peerinfo_plugins.c gnunet-peerinfo_plugins.h