aboutsummaryrefslogtreecommitdiff
path: root/src/peerstore/Makefile.am
diff options
context:
space:
mode:
authorOmar Tarabai <tarabai@devegypt.com>2014-06-05 09:08:28 +0000
committerOmar Tarabai <tarabai@devegypt.com>2014-06-05 09:08:28 +0000
commitf8a8dad6b6ff2d1dd28098372f203264b2caa060 (patch)
tree51760410f7176970b68f386d8665a51968e6e6ab /src/peerstore/Makefile.am
parentecc4ae9b8bbd5e5433b83a1527cd9b83487e9bec (diff)
downloadgnunet-f8a8dad6b6ff2d1dd28098372f203264b2caa060.tar.gz
gnunet-f8a8dad6b6ff2d1dd28098372f203264b2caa060.zip
peerstore: additional test cases
Diffstat (limited to 'src/peerstore/Makefile.am')
-rw-r--r--src/peerstore/Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/src/peerstore/Makefile.am b/src/peerstore/Makefile.am
index e65817569..5b3c918db 100644
--- a/src/peerstore/Makefile.am
+++ b/src/peerstore/Makefile.am
@@ -65,7 +65,9 @@ libgnunet_plugin_peerstore_sqlite_la_DEPENDENCIES = \
65 libgnunetpeerstore.la 65 libgnunetpeerstore.la
66 66
67check_PROGRAMS = \ 67check_PROGRAMS = \
68 test_peerstore_api_store 68 test_peerstore_api_store \
69 test_peerstore_api_iterate \
70 test_peerstore_api_watch
69 71
70if ENABLE_TEST_RUN 72if ENABLE_TEST_RUN
71AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; 73AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
@@ -77,5 +79,18 @@ test_peerstore_api_store_SOURCES = \
77test_peerstore_api_store_LDADD = \ 79test_peerstore_api_store_LDADD = \
78 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \ 80 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
79 $(top_builddir)/src/testing/libgnunettesting.la \ 81 $(top_builddir)/src/testing/libgnunettesting.la \
80 $(top_builddir)/src/util/libgnunetutil.la 82 $(top_builddir)/src/util/libgnunetutil.la
83
84test_peerstore_api_iterate_SOURCES = \
85 test_peerstore_api_iterate.c
86test_peerstore_api_iterate_LDADD = \
87 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
88 $(top_builddir)/src/testing/libgnunettesting.la \
89 $(top_builddir)/src/util/libgnunetutil.la
81 90
91test_peerstore_api_watch_SOURCES = \
92 test_peerstore_api_watch.c
93test_peerstore_api_watch_LDADD = \
94 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
95 $(top_builddir)/src/testing/libgnunettesting.la \
96 $(top_builddir)/src/util/libgnunetutil.la