aboutsummaryrefslogtreecommitdiff
path: root/src/psycstore/Makefile.am
diff options
context:
space:
mode:
authorChristophe Genevey Metat <genevey.christophe@gmail.com>2016-07-12 09:58:04 +0000
committerChristophe Genevey Metat <genevey.christophe@gmail.com>2016-07-12 09:58:04 +0000
commit97d142230b783a3d667cdfedb7fc0397ce831c66 (patch)
treef08017db62178245d04c8210d598ce16b2b6bfbc /src/psycstore/Makefile.am
parenta00afbdaae8de7fd752aab1ed5028833a85eeea7 (diff)
downloadgnunet-97d142230b783a3d667cdfedb7fc0397ce831c66.tar.gz
gnunet-97d142230b783a3d667cdfedb7fc0397ce831c66.zip
fix Makefile
Diffstat (limited to 'src/psycstore/Makefile.am')
-rw-r--r--src/psycstore/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/src/psycstore/Makefile.am b/src/psycstore/Makefile.am
index ee61b8c78..4da0a89d8 100644
--- a/src/psycstore/Makefile.am
+++ b/src/psycstore/Makefile.am
@@ -20,6 +20,13 @@ if USE_COVERAGE
20 XLIB = -lgcov 20 XLIB = -lgcov
21endif 21endif
22 22
23if HAVE_MYSQL
24MYSQL_PLUGIN = libgnunet_plugin_psycstore_mysql.la
25if HAVE_TESTING
26MYSQL_TESTS = test_plugin_psycstore_mysql
27endif
28endif
29
23if HAVE_SQLITE 30if HAVE_SQLITE
24SQLITE_PLUGIN = libgnunet_plugin_psycstore_sqlite.la 31SQLITE_PLUGIN = libgnunet_plugin_psycstore_sqlite.la
25if HAVE_TESTING 32if HAVE_TESTING
@@ -53,7 +60,8 @@ gnunet_service_psycstore_LDADD = \
53 $(GN_LIBINTL) 60 $(GN_LIBINTL)
54 61
55plugin_LTLIBRARIES = \ 62plugin_LTLIBRARIES = \
56 $(SQLITE_PLUGIN) 63 $(SQLITE_PLUGIN) \
64 $(MYSQL_PLUGIN)
57 65
58libgnunet_plugin_psycstore_mysql_la_SOURCES = \ 66libgnunet_plugin_psycstore_mysql_la_SOURCES = \
59 plugin_psycstore_mysql.c 67 plugin_psycstore_mysql.c
@@ -83,6 +91,7 @@ if HAVE_SQLITE
83if HAVE_TESTING 91if HAVE_TESTING
84check_PROGRAMS = \ 92check_PROGRAMS = \
85 $(SQLITE_TESTS) \ 93 $(SQLITE_TESTS) \
94 $(MYSQL_TESTS) \
86 test_psycstore 95 test_psycstore
87endif 96endif
88endif 97endif
@@ -108,3 +117,10 @@ test_plugin_psycstore_sqlite_SOURCES = \
108test_plugin_psycstore_sqlite_LDADD = \ 117test_plugin_psycstore_sqlite_LDADD = \
109 $(top_builddir)/src/testing/libgnunettesting.la \ 118 $(top_builddir)/src/testing/libgnunettesting.la \
110 $(top_builddir)/src/util/libgnunetutil.la 119 $(top_builddir)/src/util/libgnunetutil.la
120
121test_plugin_psycstore_mysql_SOURCES = \
122 test_plugin_psycstore.c
123test_plugin_psycstore_mysql_LDADD = \
124 $(top_builddir)/src/testing/libgnunettesting.la \
125 $(top_builddir)/src/util/libgnunetutil.la
126