aboutsummaryrefslogtreecommitdiff
path: root/src/regex/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2013-01-24 15:46:53 +0000
committerBart Polot <bart@net.in.tum.de>2013-01-24 15:46:53 +0000
commit311a626e040a397213609434fc506d14880a454f (patch)
tree62a478bc42bd2ccbb8731390fd2896435635d567 /src/regex/Makefile.am
parent74c58d3c492508ab3204ac06577dcdb2af2a8d11 (diff)
downloadgnunet-311a626e040a397213609434fc506d14880a454f.tar.gz
gnunet-311a626e040a397213609434fc506d14880a454f.zip
Moved regex profiler and profiler daemon from mesh to regex, adaped to regex dht lib
Diffstat (limited to 'src/regex/Makefile.am')
-rw-r--r--src/regex/Makefile.am26
1 files changed, 25 insertions, 1 deletions
diff --git a/src/regex/Makefile.am b/src/regex/Makefile.am
index 26f25258e..3fb4e2522 100644
--- a/src/regex/Makefile.am
+++ b/src/regex/Makefile.am
@@ -80,7 +80,9 @@ libgnunetregextest_la_DEPENDENCIES = \
80 80
81 81
82noinst_PROGRAMS = $(noinst_mysql_progs) \ 82noinst_PROGRAMS = $(noinst_mysql_progs) \
83 perf-regex 83 perf-regex \
84 gnunet-regex-profiler \
85 gnunet-daemon-regexprofiler
84 86
85perf_regex_SOURCES = \ 87perf_regex_SOURCES = \
86 perf-regex.c 88 perf-regex.c
@@ -92,6 +94,28 @@ perf_regex_DEPENDENCIES = \
92 libgnunetregex.la \ 94 libgnunetregex.la \
93 libgnunetregextest.la 95 libgnunetregextest.la
94 96
97gnunet_regex_profiler_SOURCES = \
98 gnunet-regex-profiler.c
99gnunet_regex_profiler_LDADD = \
100 $(top_builddir)/src/util/libgnunetutil.la \
101 $(top_builddir)/src/testbed/libgnunettestbed.la \
102 $(top_builddir)/src/regex/libgnunetregex.la \
103 $(top_builddir)/src/statistics/libgnunetstatistics.la
104gnunet_regex_profiler_DEPENDENCIES = \
105 libgnunetregex.la
106
107gnunet_daemon_regexprofiler_SOURCES = \
108 gnunet-daemon-regexprofiler.c
109gnunet_daemon_regexprofiler_LDADD = \
110 $(top_builddir)/src/util/libgnunetutil.la \
111 $(top_builddir)/src/dht/libgnunetdht.la \
112 $(top_builddir)/src/regex/libgnunetregex.la \
113 $(top_builddir)/src/statistics/libgnunetstatistics.la
114gnunet_daemon_regexprofiler_DEPENDENCIES = \
115 $(top_builddir)/src/dht/libgnunetdht.la \
116 libgnunetregex.la
117
118
95 119
96check_PROGRAMS = \ 120check_PROGRAMS = \
97 test_regex_eval_api \ 121 test_regex_eval_api \