aboutsummaryrefslogtreecommitdiff
path: root/src/scalarproduct/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-08-23 13:39:32 +0000
committerChristian Grothoff <christian@grothoff.org>2013-08-23 13:39:32 +0000
commit22ab4538a2f7a21c0c831599a56d50c147de0ae5 (patch)
tree65a234903970dea6cab9cdfce75e10c72f9e44f3 /src/scalarproduct/Makefile.am
parent1a4262ba723c6806e2260f6431e273e29c1143b9 (diff)
downloadgnunet-22ab4538a2f7a21c0c831599a56d50c147de0ae5.tar.gz
gnunet-22ab4538a2f7a21c0c831599a56d50c147de0ae5.zip
-starting to rename vectorproduct to scalarproduct, as this is not doing a cross product
Diffstat (limited to 'src/scalarproduct/Makefile.am')
-rw-r--r--src/scalarproduct/Makefile.am112
1 files changed, 112 insertions, 0 deletions
diff --git a/src/scalarproduct/Makefile.am b/src/scalarproduct/Makefile.am
new file mode 100644
index 000000000..1f0912e50
--- /dev/null
+++ b/src/scalarproduct/Makefile.am
@@ -0,0 +1,112 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3pkgcfgdir= $(pkgdatadir)/config.d/
4
5libexecdir= $(pkglibdir)/libexec/
6
7pkgcfg_DATA = \
8 vectorproduct.conf
9
10if MINGW
11 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
12endif
13
14if USE_COVERAGE
15 AM_CFLAGS = -fprofile-arcs -ftest-coverage
16endif
17
18bin_PROGRAMS = \
19 gnunet-vectorproduct
20
21libexec_PROGRAMS = \
22 gnunet-service-vectorproduct
23
24# FIXME: add option "configure --with-evil"?
25#if HAVE_EXPERIMENTAL
26#libexec_PROGRAMS += \
27# gnunet-service-evil-consensus
28#endif
29
30lib_LTLIBRARIES = \
31 libgnunetvectorproduct.la
32
33gnunet_vectorproduct_SOURCES = \
34 gnunet-vectorproduct.c
35gnunet_vectorproduct_LDADD = \
36 $(top_builddir)/src/util/libgnunetutil.la \
37 $(top_builddir)/src/vectorproduct/libgnunetvectorproduct.la \
38 -lgcrypt \
39 $(GN_LIBINTL)
40gnunet_vectorproduct_DEPENDENCIES = \
41 libgnunetvectorproduct.la
42
43gnunet_service_vectorproduct_SOURCES = \
44 gnunet-service-vectorproduct.c
45gnunet_service_vectorproduct_LDADD = \
46 $(top_builddir)/src/util/libgnunetutil.la \
47 $(top_builddir)/src/core/libgnunetcore.la \
48 $(top_builddir)/src/mesh/libgnunetmesh.la \
49 $(top_builddir)/src/set/libgnunetset.la \
50 -lgcrypt \
51 $(GN_LIBINTL)
52
53libgnunetvectorproduct_la_SOURCES = \
54 vectorproduct_api.c
55libgnunetvectorproduct_la_LIBADD = \
56 $(top_builddir)/src/util/libgnunetutil.la \
57 $(top_builddir)/src/statistics/libgnunetstatistics.la \
58 -lgcrypt \
59 $(LTLIBINTL)
60libgnunetvectorproduct_la_LDFLAGS = \
61 $(GN_LIB_LDFLAGS)
62
63check_PROGRAMS = \
64 test_vectorproduct_api_regression \
65 test_vectorproduct_api \
66 test_vectorproduct_api_4peers
67#FIXME unfinished
68#test_vectorproduct_api_regression2
69
70if ENABLE_TEST_RUN
71 TESTS = $(check_PROGRAMS)
72endif
73
74test_consensus_api_SOURCES = \
75 test_consensus_api.c
76test_consensus_api_LDADD = \
77 $(top_builddir)/src/util/libgnunetutil.la \
78 $(top_builddir)/src/testing/libgnunettesting.la \
79 $(top_builddir)/src/consensus/libgnunetconsensus.la
80
81test_vectorproduct_api_SOURCES = \
82 test_vectorproduct_api.c
83test_vectorproduct_api_LDADD = \
84 $(top_builddir)/src/util/libgnunetutil.la \
85 $(top_builddir)/src/vectorproduct/libgnunetvectorproduct.la \
86 -lgcrypt
87
88#FIXME unfinished
89#test_vectorproduct_api_regression2_SOURCES = \
90# test_vectorproduct_api_regression2.c
91#test_vectorproduct_api_regression2_LDADD = \
92# $(top_builddir)/src/vectorproduct/libgnunetvectorproduct.la \
93# $(top_builddir)/src/util/libgnunetutil.la \
94# -lgcrypt
95
96test_vectorproduct_api_regression_SOURCES = \
97 test_vectorproduct_api_regression.c
98test_vectorproduct_api_regression_LDADD = \
99 $(top_builddir)/src/util/libgnunetutil.la \
100 $(top_builddir)/src/vectorproduct/libgnunetvectorproduct.la \
101 -lgcrypt
102
103test_vectorproduct_api_4peers_SOURCES = \
104 test_vectorproduct_api_4peers.c
105test_vectorproduct_api_4peers_LDADD = \
106 $(top_builddir)/src/util/libgnunetutil.la \
107 $(top_builddir)/src/vectorproduct/libgnunetvectorproduct.la \
108 -lgcrypt
109
110EXTRA_DIST = \
111 test_vectorproduct.conf
112