aboutsummaryrefslogtreecommitdiff
path: root/src/scalarproduct/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-09-05 19:00:01 +0000
committerChristian Grothoff <christian@grothoff.org>2015-09-05 19:00:01 +0000
commit3f68c3e171fc5f572f5a7dbca685aeaa66f741a5 (patch)
tree35270d5acf5fef9a805e206b4c09b9b5675e3ad2 /src/scalarproduct/Makefile.am
parent1d89d84649d80a26ef39017d8a6f7edf5cb8d0c4 (diff)
downloadgnunet-3f68c3e171fc5f572f5a7dbca685aeaa66f741a5.tar.gz
gnunet-3f68c3e171fc5f572f5a7dbca685aeaa66f741a5.zip
-test skeleton
Diffstat (limited to 'src/scalarproduct/Makefile.am')
-rw-r--r--src/scalarproduct/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/scalarproduct/Makefile.am b/src/scalarproduct/Makefile.am
index c09e38393..57df0e840 100644
--- a/src/scalarproduct/Makefile.am
+++ b/src/scalarproduct/Makefile.am
@@ -102,7 +102,16 @@ check_SCRIPTS = \
102 test_scalarproduct_negative.sh \ 102 test_scalarproduct_negative.sh \
103 test_scalarproduct_negativezero.sh 103 test_scalarproduct_negativezero.sh
104 104
105check_PROGRAMS = \
106 test_ecc_scalarproduct
107
105if ENABLE_TEST_RUN 108if ENABLE_TEST_RUN
106 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; 109 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
107 TESTS = $(check_SCRIPTS) 110 TESTS = $(check_SCRIPTS) $(check_PROGRAMS)
108endif 111endif
112
113
114test_ecc_scalarproduct_SOURCES = \
115 test_ecc_scalarproduct.c
116test_ecc_scalarproduct_LDADD = \
117 $(top_builddir)/src/util/libgnunetutil.la