aboutsummaryrefslogtreecommitdiff
path: root/src/scalarproduct/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-12-23 19:31:55 +0000
committerChristian Grothoff <christian@grothoff.org>2013-12-23 19:31:55 +0000
commit5d363f7f824eb038571681017a35794e4e07e378 (patch)
treecd91c570d01dcdd7d67696065b817e27ff58925e /src/scalarproduct/Makefile.am
parentcbe126c37f2e6fdccdbe20e723c06b8b0b12d1c6 (diff)
downloadgnunet-5d363f7f824eb038571681017a35794e4e07e378.tar.gz
gnunet-5d363f7f824eb038571681017a35794e4e07e378.zip
-fix build system issues
Diffstat (limited to 'src/scalarproduct/Makefile.am')
-rw-r--r--src/scalarproduct/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/scalarproduct/Makefile.am b/src/scalarproduct/Makefile.am
index 4bfdfcd7d..11a937378 100644
--- a/src/scalarproduct/Makefile.am
+++ b/src/scalarproduct/Makefile.am
@@ -5,10 +5,10 @@ pkgcfgdir= $(pkgdatadir)/config.d/
5libexecdir= $(pkglibdir)/libexec/ 5libexecdir= $(pkglibdir)/libexec/
6 6
7pkgcfg_DATA = \ 7pkgcfg_DATA = \
8 scalarproduct.conf 8 scalarproduct.conf
9 9
10if MINGW 10if MINGW
11 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols 11 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
12endif 12endif
13 13
14if USE_COVERAGE 14if USE_COVERAGE
@@ -30,7 +30,7 @@ gnunet_scalarproduct_LDADD = \
30 $(top_builddir)/src/util/libgnunetutil.la \ 30 $(top_builddir)/src/util/libgnunetutil.la \
31 $(top_builddir)/src/scalarproduct/libgnunetscalarproduct.la \ 31 $(top_builddir)/src/scalarproduct/libgnunetscalarproduct.la \
32 -lgcrypt \ 32 -lgcrypt \
33 $(GN_LIBINTL) 33 $(GN_LIBINTL)
34gnunet_scalarproduct_DEPENDENCIES = \ 34gnunet_scalarproduct_DEPENDENCIES = \
35 libgnunetscalarproduct.la 35 libgnunetscalarproduct.la
36 36
@@ -44,7 +44,8 @@ gnunet_service_scalarproduct_LDADD = \
44 $(GN_LIBINTL) 44 $(GN_LIBINTL)
45 45
46libgnunetscalarproduct_la_SOURCES = \ 46libgnunetscalarproduct_la_SOURCES = \
47 scalarproduct_api.c 47 scalarproduct_api.c \
48 scalarproduct.h
48libgnunetscalarproduct_la_LIBADD = \ 49libgnunetscalarproduct_la_LIBADD = \
49 $(top_builddir)/src/util/libgnunetutil.la \ 50 $(top_builddir)/src/util/libgnunetutil.la \
50 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 51 $(top_builddir)/src/statistics/libgnunetstatistics.la \
@@ -61,7 +62,7 @@ check_SCRIPTS = \
61 test_scalarproduct.sh \ 62 test_scalarproduct.sh \
62 test_scalarproduct_negative.sh \ 63 test_scalarproduct_negative.sh \
63 test_scalarproduct_negativezero.sh 64 test_scalarproduct_negativezero.sh
64 65
65if ENABLE_TEST_RUN 66if ENABLE_TEST_RUN
66 TESTS = $(check_SCRIPTS) 67 TESTS = $(check_SCRIPTS)
67endif 68endif