aboutsummaryrefslogtreecommitdiff
path: root/src/secretsharing/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2023-10-18 13:37:38 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2023-10-18 13:37:38 +0200
commit9ef4abad615bea12d13be542b8ae5fbeb2dfee32 (patch)
tree8875a687e004d331c9ea6a1d511a328c72b88113 /src/secretsharing/Makefile.am
parente95236b3ed78cd597c15f34b89385295702b627f (diff)
downloadgnunet-9ef4abad615bea12d13be542b8ae5fbeb2dfee32.tar.gz
gnunet-9ef4abad615bea12d13be542b8ae5fbeb2dfee32.zip
NEWS: Refactoring components under src/ into lib/, plugin/, cli/ and service/
This also includes a necessary API refactoring of crypto from IDENTITY to UTIL.
Diffstat (limited to 'src/secretsharing/Makefile.am')
-rw-r--r--src/secretsharing/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/secretsharing/Makefile.am b/src/secretsharing/Makefile.am
index 3a86236cd..30b3f8057 100644
--- a/src/secretsharing/Makefile.am
+++ b/src/secretsharing/Makefile.am
@@ -30,7 +30,7 @@ lib_LTLIBRARIES = \
30# libgnunetsecretsharing.la \ 30# libgnunetsecretsharing.la \
31# $(top_builddir)/src/testing/libgnunettesting.la \ 31# $(top_builddir)/src/testing/libgnunettesting.la \
32# $(top_builddir)/src/testbed/libgnunettestbed.la \ 32# $(top_builddir)/src/testbed/libgnunettestbed.la \
33# $(top_builddir)/src/util/libgnunetutil.la \ 33# $(top_builddir)/src/lib/util/libgnunetutil.la \
34# $(GN_LIBINTL) 34# $(GN_LIBINTL)
35 35
36gnunet_service_secretsharing_SOURCES = \ 36gnunet_service_secretsharing_SOURCES = \
@@ -39,7 +39,7 @@ gnunet_service_secretsharing_SOURCES = \
39 secretsharing_protocol.h 39 secretsharing_protocol.h
40gnunet_service_secretsharing_CFLAGS = $(AM_CFLAGS) 40gnunet_service_secretsharing_CFLAGS = $(AM_CFLAGS)
41gnunet_service_secretsharing_LDADD = \ 41gnunet_service_secretsharing_LDADD = \
42 $(top_builddir)/src/util/libgnunetutil.la \ 42 $(top_builddir)/src/lib/util/libgnunetutil.la \
43 $(top_builddir)/src/consensus/libgnunetconsensus.la \ 43 $(top_builddir)/src/consensus/libgnunetconsensus.la \
44 $(LIBGCRYPT_LIBS) \ 44 $(LIBGCRYPT_LIBS) \
45 $(GN_LIBINTL) 45 $(GN_LIBINTL)
@@ -49,7 +49,7 @@ libgnunetsecretsharing_la_SOURCES = \
49 secretsharing_common.c \ 49 secretsharing_common.c \
50 secretsharing.h 50 secretsharing.h
51libgnunetsecretsharing_la_LIBADD = \ 51libgnunetsecretsharing_la_LIBADD = \
52 $(top_builddir)/src/util/libgnunetutil.la \ 52 $(top_builddir)/src/lib/util/libgnunetutil.la \
53 $(LIBGCRYPT_LIBS) \ 53 $(LIBGCRYPT_LIBS) \
54 $(LTLIBINTL) 54 $(LTLIBINTL)
55libgnunetsecretsharing_la_LDFLAGS = \ 55libgnunetsecretsharing_la_LDFLAGS = \
@@ -68,7 +68,7 @@ test_secretsharing_api_SOURCES = \
68test_secretsharing_api_LDADD = \ 68test_secretsharing_api_LDADD = \
69 libgnunetsecretsharing.la \ 69 libgnunetsecretsharing.la \
70 $(top_builddir)/src/testing/libgnunettesting.la \ 70 $(top_builddir)/src/testing/libgnunettesting.la \
71 $(top_builddir)/src/util/libgnunetutil.la 71 $(top_builddir)/src/lib/util/libgnunetutil.la
72 72
73EXTRA_DIST = \ 73EXTRA_DIST = \
74 test_secretsharing.conf 74 test_secretsharing.conf