aboutsummaryrefslogtreecommitdiff
path: root/src/service/namestore/meson.build
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2023-11-08 17:09:17 +0100
committerMartin Schanzenbach <schanzen@gnunet.org>2023-11-08 17:09:17 +0100
commit03607140c1868109c3903634906ab45ce60db288 (patch)
tree7e2926f9b21fe85308f75621f1e3b64b7c4ffc71 /src/service/namestore/meson.build
parent2548d309de0249b60d491b01e4fa8184db0a2915 (diff)
downloadgnunet-03607140c1868109c3903634906ab45ce60db288.tar.gz
gnunet-03607140c1868109c3903634906ab45ce60db288.zip
NAMESTORE: Fix test memory corruption (still fishy; cause unknown)
Diffstat (limited to 'src/service/namestore/meson.build')
-rw-r--r--src/service/namestore/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/service/namestore/meson.build b/src/service/namestore/meson.build
index 616c8ad01..4169e7fde 100644
--- a/src/service/namestore/meson.build
+++ b/src/service/namestore/meson.build
@@ -65,7 +65,6 @@ configure_file(copy: true,
65 output: 'test_namestore_api_sqlite.conf') 65 output: 'test_namestore_api_sqlite.conf')
66 66
67namestoreapitestnames = [ 67namestoreapitestnames = [
68 'test_namestore_api_edit_records',
69 'test_namestore_api_lookup_nick', 68 'test_namestore_api_lookup_nick',
70 'test_namestore_api_monitoring', 69 'test_namestore_api_monitoring',
71 'test_namestore_api_monitoring_existing', 70 'test_namestore_api_monitoring_existing',
@@ -81,6 +80,10 @@ namestoreapitestnames = [
81 'test_namestore_api_zone_to_name' 80 'test_namestore_api_zone_to_name'
82 ] 81 ]
83 82
83if get_option('experimental')
84 namestoreapitestnames +='test_namestore_api_edit_records'
85endif
86
84foreach tn : namestoreapitestnames 87foreach tn : namestoreapitestnames
85 t = executable (tn + '_sqlite', 88 t = executable (tn + '_sqlite',
86 [tn + '.c'], 89 [tn + '.c'],