aboutsummaryrefslogtreecommitdiff
path: root/src/service/regex/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2023-10-19 09:03:33 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2023-10-19 09:03:33 +0200
commit7f72b05249f6ac663cee7a033f3cac5d9400ede7 (patch)
treed15cec717aa9568adc1876ec1b717cf18596e1f6 /src/service/regex/Makefile.am
parent5ae8ee063302cc6c1fc7b74328af46a11cb02cdc (diff)
downloadgnunet-7f72b05249f6ac663cee7a033f3cac5d9400ede7.tar.gz
gnunet-7f72b05249f6ac663cee7a033f3cac5d9400ede7.zip
BUILD: Move regex/dns to service
Diffstat (limited to 'src/service/regex/Makefile.am')
-rw-r--r--src/service/regex/Makefile.am181
1 files changed, 181 insertions, 0 deletions
diff --git a/src/service/regex/Makefile.am b/src/service/regex/Makefile.am
new file mode 100644
index 000000000..14cdb054b
--- /dev/null
+++ b/src/service/regex/Makefile.am
@@ -0,0 +1,181 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage
6endif
7
8pkgcfgdir= $(pkgdatadir)/config.d/
9
10libexecdir= $(pkglibdir)/libexec/
11
12plugindir = $(libdir)/gnunet
13
14pkgcfg_DATA = \
15 regex.conf
16
17libexec_PROGRAMS = \
18 gnunet-service-regex \
19 gnunet-daemon-regexprofiler
20
21REGEX_INTERNAL = \
22 regex_internal_lib.h \
23 regex_internal.h regex_internal.c \
24 regex_internal_dht.c
25REGEX_INTERNAL_TEST = \
26 $(REGEX_INTERNAL) \
27 regex_test_lib.c regex_test_lib.h \
28 regex_test_graph.c \
29 regex_test_random.c
30
31gnunet_service_regex_SOURCES = \
32 $(REGEX_INTERNAL) gnunet-service-regex.c
33gnunet_service_regex_LDADD = -lm \
34 libgnunetregexblock.la \
35 $(top_builddir)/src/service/dht/libgnunetdht.la \
36 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
37 $(top_builddir)/src/lib/util/libgnunetutil.la \
38 $(GN_LIBINTL)
39
40lib_LTLIBRARIES = \
41 libgnunetregexblock.la \
42 libgnunetregex.la
43
44libgnunetregexblock_la_SOURCES = \
45 regex_block_lib.c regex_block_lib.h
46libgnunetregexblock_la_LIBADD = \
47 $(top_builddir)/src/lib/util/libgnunetutil.la \
48 $(XLIB) \
49 $(LTLIBINTL)
50libgnunetregexblock_la_LDFLAGS = \
51 $(GN_LIB_LDFLAGS) \
52 -version-info 1:0:0
53
54
55libgnunetregex_la_SOURCES = \
56 regex_api_announce.c \
57 regex_api_search.c \
58 regex_ipc.h
59libgnunetregex_la_LIBADD = \
60 $(top_builddir)/src/lib/util/libgnunetutil.la
61libgnunetregex_la_LDFLAGS = \
62 $(GN_LIBINTL) \
63 $(GN_LIB_LDFLAGS) \
64 -version-info 3:1:0
65
66
67plugin_LTLIBRARIES = \
68 libgnunet_plugin_block_regex.la
69
70libgnunet_plugin_block_regex_la_SOURCES = \
71 plugin_block_regex.c
72libgnunet_plugin_block_regex_la_LIBADD = \
73 libgnunetregexblock.la \
74 $(top_builddir)/src/lib/block/libgnunetblock.la \
75 $(top_builddir)/src/lib/block/libgnunetblockgroup.la \
76 $(top_builddir)/src/lib/util/libgnunetutil.la
77libgnunet_plugin_block_regex_la_LDFLAGS = \
78 $(GN_LIBINTL) \
79 $(GN_PLUGIN_LDFLAGS)
80
81# FIXME we phased out mysql. If we want to keep, needs rewrite
82#if HAVE_MYSQL
83#noinst_mysql_progs = \
84# gnunet-regex-simulation-profiler
85
86#gnunet_regex_simulation_profiler_SOURCES = \
87# $(REGEX_INTERNAL) gnunet-regex-simulation-profiler.c
88#gnunet_regex_simulation_profiler_LDADD = \
89# libgnunetregexblock.la \
90# $(top_builddir)/src/lib/util/libgnunetutil.la \
91# $(top_builddir)/src/service/dht/libgnunetdht.la \
92# $(top_builddir)/src/lib/block/libgnunetblock.la \
93# $(top_builddir)/src/service/statistics/libgnunetstatistics.la
94#endif
95
96noinst_PROGRAMS = $(noinst_mysql_progs) \
97 perf-regex
98
99perf_regex_SOURCES = \
100 $(REGEX_INTERNAL_TEST) perf-regex.c
101perf_regex_LDADD = -lm \
102 $(top_builddir)/src/service/dht/libgnunetdht.la \
103 libgnunetregexblock.la \
104 $(top_builddir)/src/lib/util/libgnunetutil.la \
105 $(top_builddir)/src/service/statistics/libgnunetstatistics.la
106perf_regex_LDFLAGS = \
107 $(GN_LIBINTL)
108
109gnunet_daemon_regexprofiler_SOURCES = \
110 $(REGEX_INTERNAL_TEST) gnunet-daemon-regexprofiler.c
111gnunet_daemon_regexprofiler_LDADD = -lm \
112 $(top_builddir)/src/service/dht/libgnunetdht.la \
113 libgnunetregexblock.la \
114 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
115 $(top_builddir)/src/lib/util/libgnunetutil.la
116gnunet_daemon_regexprofiler_LDFLAGS = \
117 $(GN_LIBINTL)
118
119check_PROGRAMS = \
120 test_regex_integration \
121 test_regex_eval_api \
122 test_regex_iterate_api \
123 test_regex_proofs \
124 test_regex_graph_api \
125 test_regex_api
126
127if ENABLE_TEST_RUN
128 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
129 TESTS = $(check_PROGRAMS)
130endif
131
132test_regex_eval_api_SOURCES = \
133 $(REGEX_INTERNAL_TEST) test_regex_eval_api.c
134test_regex_eval_api_LDADD = -lm \
135 $(top_builddir)/src/service/dht/libgnunetdht.la \
136 libgnunetregexblock.la \
137 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
138 $(top_builddir)/src/lib/util/libgnunetutil.la
139
140test_regex_integration_SOURCES = \
141 test_regex_integration.c
142test_regex_integration_LDADD = -lm \
143 libgnunetregex.la \
144 $(top_builddir)/src/service/testing/libgnunettesting.la \
145 $(top_builddir)/src/lib/util/libgnunetutil.la
146
147test_regex_api_SOURCES = \
148 test_regex_api.c
149test_regex_api_LDADD = -lm \
150 libgnunetregex.la \
151 $(top_builddir)/src/service/testing/libgnunettesting.la \
152 $(top_builddir)/src/lib/util/libgnunetutil.la
153
154test_regex_iterate_api_SOURCES = \
155 $(REGEX_INTERNAL) test_regex_iterate_api.c
156test_regex_iterate_api_LDADD = -lm \
157 libgnunetregexblock.la \
158 $(top_builddir)/src/service/dht/libgnunetdht.la \
159 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
160 $(top_builddir)/src/lib/util/libgnunetutil.la
161
162test_regex_proofs_SOURCES = \
163 $(REGEX_INTERNAL_TEST) test_regex_proofs.c
164test_regex_proofs_LDADD = -lm \
165 $(top_builddir)/src/service/dht/libgnunetdht.la \
166 libgnunetregexblock.la \
167 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
168 $(top_builddir)/src/lib/util/libgnunetutil.la
169
170test_regex_graph_api_SOURCES = \
171 $(REGEX_INTERNAL_TEST) test_regex_graph_api.c
172test_regex_graph_api_LDADD = -lm \
173 $(top_builddir)/src/service/dht/libgnunetdht.la \
174 libgnunetregexblock.la \
175 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
176 $(top_builddir)/src/lib/util/libgnunetutil.la
177
178
179EXTRA_DIST = \
180 regex_simulation_profiler_test.conf \
181 test_regex_api_data.conf