aboutsummaryrefslogtreecommitdiff
path: root/src/service/revocation/meson.build
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2023-10-19 14:42:43 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2023-10-19 14:42:43 +0200
commitdc222ad3a32cfa1755ea634f547c99f58cff7c05 (patch)
treef8a6b586db5d60f7616c9dd30bb3b49211bb5c9d /src/service/revocation/meson.build
parent3de5a3245a944944b2853e613d2cd7b72f2ac24d (diff)
downloadgnunet-dc222ad3a32cfa1755ea634f547c99f58cff7c05.tar.gz
gnunet-dc222ad3a32cfa1755ea634f547c99f58cff7c05.zip
meson: reintroduce libgnunet build with meson
Diffstat (limited to 'src/service/revocation/meson.build')
-rw-r--r--src/service/revocation/meson.build22
1 files changed, 0 insertions, 22 deletions
diff --git a/src/service/revocation/meson.build b/src/service/revocation/meson.build
index 9a526af36..14e352ffa 100644
--- a/src/service/revocation/meson.build
+++ b/src/service/revocation/meson.build
@@ -13,7 +13,6 @@ if get_option('monolith')
13 foreach p : libgnunetrevocation_src + gnunetservicerevocation_src 13 foreach p : libgnunetrevocation_src + gnunetservicerevocation_src
14 gnunet_src += 'revocation/' + p 14 gnunet_src += 'revocation/' + p
15 endforeach 15 endforeach
16 subdir_done()
17endif 16endif
18 17
19libgnunetrevocation = library('gnunetrevocation', 18libgnunetrevocation = library('gnunetrevocation',
@@ -28,27 +27,6 @@ libgnunetrevocation_dep = declare_dependency(link_with : libgnunetrevocation)
28pkg.generate(libgnunetrevocation, url: 'https://www.gnunet.org', 27pkg.generate(libgnunetrevocation, url: 'https://www.gnunet.org',
29 description : 'Provides API to perform key revocation in GNUnet') 28 description : 'Provides API to perform key revocation in GNUnet')
30 29
31shared_module('gnunet_plugin_block_revocation',
32 ['plugin_block_revocation.c'],
33 dependencies: [libgnunetutil_dep,
34 libgnunetidentity_dep,
35 libgnunetrevocation_dep,
36 libgnunetblock_dep],
37 include_directories: [incdir, configuration_inc],
38 install: true,
39 install_dir: get_option('libdir')/'gnunet')
40
41executable ('gnunet-revocation',
42 ['gnunet-revocation.c'],
43 dependencies: [libgnunetrevocation_dep,
44 libgnunetutil_dep,
45 libgnunetstatistics_dep,
46 libgnunetcore_dep,
47 libgnunetsetu_dep,
48 libgnunetidentity_dep],
49 include_directories: [incdir, configuration_inc],
50 install: true,
51 install_dir: get_option('bindir'))
52executable ('gnunet-service-revocation', 30executable ('gnunet-service-revocation',
53 gnunetservicerevocation_src, 31 gnunetservicerevocation_src,
54 dependencies: [libgnunetrevocation_dep, 32 dependencies: [libgnunetrevocation_dep,