aboutsummaryrefslogtreecommitdiff
path: root/src/set/Makefile.am
diff options
context:
space:
mode:
authorChristian Fuchs <christian.fuchs@cfuchs.net>2013-11-20 16:20:26 +0000
committerChristian Fuchs <christian.fuchs@cfuchs.net>2013-11-20 16:20:26 +0000
commit225260a0a885e09a417395a5c9de7b6da549f290 (patch)
tree4859d85f24bc17a4197ea2465cc4034102626124 /src/set/Makefile.am
parent52a5e73ced4c456e5d6951158844f047048bd4e0 (diff)
downloadgnunet-225260a0a885e09a417395a5c9de7b6da549f290.tar.gz
gnunet-225260a0a885e09a417395a5c9de7b6da549f290.zip
added intersection to set's automake script
renamed shared variable in set-service's common structure reordered code in intersection i assume: finished reworking intersection, still misses dynamic bloomfilter size re-added struct SetState to intersection, which keeps track of the newest (and only this!) element count in the set's hashmap. removed iterator over the set for counting (see line above) a bugfix here and there
Diffstat (limited to 'src/set/Makefile.am')
-rw-r--r--src/set/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/set/Makefile.am b/src/set/Makefile.am
index 72d3d82a0..a2ca25f94 100644
--- a/src/set/Makefile.am
+++ b/src/set/Makefile.am
@@ -45,12 +45,14 @@ gnunet_set_ibf_profiler_LDADD = \
45gnunet_service_set_SOURCES = \ 45gnunet_service_set_SOURCES = \
46 gnunet-service-set.c \ 46 gnunet-service-set.c \
47 gnunet-service-set_union.c \ 47 gnunet-service-set_union.c \
48 gnunet-service-set_intersection.c \
48 ibf.c \ 49 ibf.c \
49 strata_estimator.c 50 strata_estimator.c
50gnunet_service_set_LDADD = \ 51gnunet_service_set_LDADD = \
51 $(top_builddir)/src/util/libgnunetutil.la \ 52 $(top_builddir)/src/util/libgnunetutil.la \
52 $(top_builddir)/src/core/libgnunetcore.la \ 53 $(top_builddir)/src/core/libgnunetcore.la \
53 $(top_builddir)/src/mesh/libgnunetmesh.la \ 54 $(top_builddir)/src/mesh/libgnunetmesh.la \
55 $(top_builddir)/src/block/libgnunetblock.la \
54 $(GN_LIBINTL) 56 $(GN_LIBINTL)
55 57
56libgnunetset_la_SOURCES = \ 58libgnunetset_la_SOURCES = \