aboutsummaryrefslogtreecommitdiff
path: root/src/set/Makefile.am
diff options
context:
space:
mode:
authorFlorian Dold <florian.dold@gmail.com>2015-08-30 20:54:44 +0000
committerFlorian Dold <florian.dold@gmail.com>2015-08-30 20:54:44 +0000
commit2e25d8c868521f318381a8b87c9f8c1c7c402b7c (patch)
treea5d9b8fca78e55da9d8c62ff8fe6d1d480a459e0 /src/set/Makefile.am
parentc92948f72526fe599680c06cbe80d0ffdc11f597 (diff)
downloadgnunet-2e25d8c868521f318381a8b87c9f8c1c7c402b7c.tar.gz
gnunet-2e25d8c868521f318381a8b87c9f8c1c7c402b7c.zip
add test case for 'GNUNET_SET_copy_lazy', fix bugs
Diffstat (limited to 'src/set/Makefile.am')
-rw-r--r--src/set/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/set/Makefile.am b/src/set/Makefile.am
index b91a54683..669a28658 100644
--- a/src/set/Makefile.am
+++ b/src/set/Makefile.am
@@ -67,7 +67,8 @@ if HAVE_TESTING
67check_PROGRAMS = \ 67check_PROGRAMS = \
68 test_set_api \ 68 test_set_api \
69 test_set_union_result_full \ 69 test_set_union_result_full \
70 test_set_intersection_result_full 70 test_set_intersection_result_full \
71 test_set_union_copy
71endif 72endif
72 73
73if ENABLE_TEST_RUN 74if ENABLE_TEST_RUN
@@ -96,5 +97,12 @@ test_set_intersection_result_full_LDADD = \
96 $(top_builddir)/src/testing/libgnunettesting.la \ 97 $(top_builddir)/src/testing/libgnunettesting.la \
97 libgnunetset.la 98 libgnunetset.la
98 99
100test_set_union_copy_SOURCES = \
101 test_set_union_copy.c
102test_set_union_copy_LDADD = \
103 $(top_builddir)/src/util/libgnunetutil.la \
104 $(top_builddir)/src/testing/libgnunettesting.la \
105 libgnunetset.la
106
99EXTRA_DIST = \ 107EXTRA_DIST = \
100 test_set.conf 108 test_set.conf