aboutsummaryrefslogtreecommitdiff
path: root/src/set/Makefile.am
diff options
context:
space:
mode:
authorFlorian Dold <florian.dold@gmail.com>2013-04-24 11:48:31 +0000
committerFlorian Dold <florian.dold@gmail.com>2013-04-24 11:48:31 +0000
commit9113520987972a798a23d1d21544d8ec4daa078c (patch)
tree178a1bca3b9083d554de20227cd0a8f1190c958c /src/set/Makefile.am
parent6a9bc072e64367297498b93cd6d975995203d2e9 (diff)
downloadgnunet-9113520987972a798a23d1d21544d8ec4daa078c.tar.gz
gnunet-9113520987972a798a23d1d21544d8ec4daa078c.zip
started implementing union operation for set
Diffstat (limited to 'src/set/Makefile.am')
-rw-r--r--src/set/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/set/Makefile.am b/src/set/Makefile.am
index 06f418465..c1639823e 100644
--- a/src/set/Makefile.am
+++ b/src/set/Makefile.am
@@ -29,6 +29,7 @@ gnunet_set_SOURCES = \
29gnunet_set_LDADD = \ 29gnunet_set_LDADD = \
30 $(top_builddir)/src/util/libgnunetutil.la \ 30 $(top_builddir)/src/util/libgnunetutil.la \
31 $(top_builddir)/src/set/libgnunetset.la \ 31 $(top_builddir)/src/set/libgnunetset.la \
32 $(top_builddir)/src/stream/libgnunetstream.la \
32 $(top_builddir)/src/testbed/libgnunettestbed.la \ 33 $(top_builddir)/src/testbed/libgnunettestbed.la \
33 $(GN_LIBINTL) 34 $(GN_LIBINTL)
34gnunet_set_DEPENDENCIES = \ 35gnunet_set_DEPENDENCIES = \
@@ -36,6 +37,8 @@ gnunet_set_DEPENDENCIES = \
36 37
37gnunet_service_set_SOURCES = \ 38gnunet_service_set_SOURCES = \
38 gnunet-service-set.c \ 39 gnunet-service-set.c \
40 gnunet-service-set_union.c \
41 mq.c \
39 ibf.c \ 42 ibf.c \
40 strata_estimator.c 43 strata_estimator.c
41gnunet_service_set_LDADD = \ 44gnunet_service_set_LDADD = \
@@ -44,12 +47,16 @@ gnunet_service_set_LDADD = \
44 $(top_builddir)/src/stream/libgnunetstream.la \ 47 $(top_builddir)/src/stream/libgnunetstream.la \
45 $(top_builddir)/src/mesh/libgnunetmesh.la \ 48 $(top_builddir)/src/mesh/libgnunetmesh.la \
46 $(GN_LIBINTL) 49 $(GN_LIBINTL)
50# hack for mq.c, see automake Objects ‘created with both libtool and without’
51# remove once GNUNET_MQ is in util/
52gnunet_service_set_CFLAGS = $(AM_CFLAGS)
47 53
48libgnunetset_la_SOURCES = \ 54libgnunetset_la_SOURCES = \
49 set_api.c \ 55 set_api.c \
50 mq.c 56 mq.c
51libgnunetset_la_LIBADD = \ 57libgnunetset_la_LIBADD = \
52 $(top_builddir)/src/util/libgnunetutil.la \ 58 $(top_builddir)/src/util/libgnunetutil.la \
59 $(top_builddir)/src/stream/libgnunetstream.la \
53 $(LTLIBINTL) 60 $(LTLIBINTL)
54libgnunetset_la_LDFLAGS = \ 61libgnunetset_la_LDFLAGS = \
55 $(GN_LIB_LDFLAGS) 62 $(GN_LIB_LDFLAGS)
@@ -67,6 +74,8 @@ test_set_api_LDADD = \
67 $(top_builddir)/src/util/libgnunetutil.la \ 74 $(top_builddir)/src/util/libgnunetutil.la \
68 $(top_builddir)/src/testing/libgnunettesting.la \ 75 $(top_builddir)/src/testing/libgnunettesting.la \
69 $(top_builddir)/src/set/libgnunetset.la 76 $(top_builddir)/src/set/libgnunetset.la
77test_set_api_DEPENDENCIES = \
78 libgnunetset.la
70 79
71EXTRA_DIST = \ 80EXTRA_DIST = \
72 test_set.conf 81 test_set.conf