aboutsummaryrefslogtreecommitdiff
path: root/src/set/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2023-10-19 09:54:35 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2023-10-19 09:54:35 +0200
commit98c00bad3d29a80c514818615c224a29307400cc (patch)
tree75681e421f4aec753eb509c037ed6e353447cc73 /src/set/Makefile.am
parentb7a1d4379ebcff1c878d068cbd8df34fd16d81d4 (diff)
downloadgnunet-98c00bad3d29a80c514818615c224a29307400cc.tar.gz
gnunet-98c00bad3d29a80c514818615c224a29307400cc.zip
BUILD: Move set/consensus/secretsharing to contrib/service
Diffstat (limited to 'src/set/Makefile.am')
-rw-r--r--src/set/Makefile.am122
1 files changed, 0 insertions, 122 deletions
diff --git a/src/set/Makefile.am b/src/set/Makefile.am
deleted file mode 100644
index 88d4d39ad..000000000
--- a/src/set/Makefile.am
+++ /dev/null
@@ -1,122 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8plugindir = $(libdir)/gnunet
9
10pkgcfg_DATA = \
11 set.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = -fprofile-arcs -ftest-coverage
15endif
16
17noinst_PROGRAMS = \
18 gnunet-set-ibf-profiler \
19 gnunet-set-profiler
20
21libexec_PROGRAMS = \
22 gnunet-service-set
23
24lib_LTLIBRARIES = \
25 libgnunetset.la
26
27gnunet_set_profiler_SOURCES = \
28 gnunet-set-profiler.c
29gnunet_set_profiler_LDADD = \
30 $(top_builddir)/src/lib/util/libgnunetutil.la \
31 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
32 libgnunetset.la \
33 $(top_builddir)/src/service/testing/libgnunettesting.la \
34 $(GN_LIBINTL)
35
36
37gnunet_set_ibf_profiler_SOURCES = \
38 gnunet-set-ibf-profiler.c \
39 ibf.c
40gnunet_set_ibf_profiler_LDADD = \
41 $(top_builddir)/src/lib/util/libgnunetutil.la \
42 $(GN_LIBINTL)
43
44gnunet_service_set_SOURCES = \
45 gnunet-service-set.c gnunet-service-set.h \
46 gnunet-service-set_union.c gnunet-service-set_union.h \
47 gnunet-service-set_intersection.c gnunet-service-set_intersection.h \
48 ibf.c ibf.h \
49 gnunet-service-set_union_strata_estimator.c gnunet-service-set_union_strata_estimator.h \
50 gnunet-service-set_protocol.h
51gnunet_service_set_LDADD = \
52 $(top_builddir)/src/lib/util/libgnunetutil.la \
53 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
54 $(top_builddir)/src/service/core/libgnunetcore.la \
55 $(top_builddir)/src/service/cadet/libgnunetcadet.la \
56 $(top_builddir)/src/lib/block/libgnunetblock.la \
57 libgnunetset.la \
58 $(GN_LIBINTL)
59
60libgnunetset_la_SOURCES = \
61 set_api.c set.h
62libgnunetset_la_LIBADD = \
63 $(top_builddir)/src/lib/util/libgnunetutil.la \
64 $(LTLIBINTL)
65libgnunetset_la_LDFLAGS = \
66 $(GN_LIB_LDFLAGS)
67
68check_PROGRAMS = \
69 # test_set_api \
70 # test_set_union_result_symmetric \
71 # test_set_intersection_result_full \
72 test_set_union_copy
73
74if ENABLE_TEST_RUN
75AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
76TESTS = $(check_PROGRAMS)
77endif
78
79test_set_api_SOURCES = \
80 test_set_api.c
81test_set_api_LDADD = \
82 $(top_builddir)/src/lib/util/libgnunetutil.la \
83 $(top_builddir)/src/service/testing/libgnunettesting.la \
84 libgnunetset.la
85
86test_set_union_result_symmetric_SOURCES = \
87 test_set_union_result_symmetric.c
88test_set_union_result_symmetric_LDADD = \
89 $(top_builddir)/src/lib/util/libgnunetutil.la \
90 $(top_builddir)/src/service/testing/libgnunettesting.la \
91 libgnunetset.la
92
93test_set_intersection_result_full_SOURCES = \
94 test_set_intersection_result_full.c
95test_set_intersection_result_full_LDADD = \
96 $(top_builddir)/src/lib/util/libgnunetutil.la \
97 $(top_builddir)/src/service/testing/libgnunettesting.la \
98 libgnunetset.la
99
100test_set_union_copy_SOURCES = \
101 test_set_union_copy.c
102test_set_union_copy_LDADD = \
103 $(top_builddir)/src/lib/util/libgnunetutil.la \
104 $(top_builddir)/src/service/testing/libgnunettesting.la \
105 libgnunetset.la
106
107plugin_LTLIBRARIES = \
108 libgnunet_plugin_block_set_test.la
109
110libgnunet_plugin_block_set_test_la_SOURCES = \
111 plugin_block_set_test.c
112libgnunet_plugin_block_set_test_la_LIBADD = \
113 $(top_builddir)/src/lib/block/libgnunetblock.la \
114 $(top_builddir)/src/lib/block/libgnunetblockgroup.la \
115 $(top_builddir)/src/lib/util/libgnunetutil.la \
116 $(LTLIBINTL)
117libgnunet_plugin_block_set_test_la_LDFLAGS = \
118 $(GN_PLUGIN_LDFLAGS)
119
120
121EXTRA_DIST = \
122 test_set.conf