aboutsummaryrefslogtreecommitdiff
path: root/src/set/Makefile.am
diff options
context:
space:
mode:
authorFlorian Dold <florian.dold@gmail.com>2013-06-19 10:48:54 +0000
committerFlorian Dold <florian.dold@gmail.com>2013-06-19 10:48:54 +0000
commita900b29ddaa9ea46c731b054b5e3ef3e725b95a8 (patch)
tree52e1a9697b0abf4618cd5684359ec5f0a040898a /src/set/Makefile.am
parent17353bc0a47c89bda205f23e7995377c9bfe7769 (diff)
downloadgnunet-a900b29ddaa9ea46c731b054b5e3ef3e725b95a8.tar.gz
gnunet-a900b29ddaa9ea46c731b054b5e3ef3e725b95a8.zip
- opaque mq structs
- mq for mesh - faster hashing for IBFs - mesh replaces stream in set - new set profiler (work in progress)
Diffstat (limited to 'src/set/Makefile.am')
-rw-r--r--src/set/Makefile.am24
1 files changed, 15 insertions, 9 deletions
diff --git a/src/set/Makefile.am b/src/set/Makefile.am
index 71e71c867..c2449e0ea 100644
--- a/src/set/Makefile.am
+++ b/src/set/Makefile.am
@@ -16,7 +16,7 @@ if USE_COVERAGE
16endif 16endif
17 17
18bin_PROGRAMS = \ 18bin_PROGRAMS = \
19 gnunet-set 19 gnunet-set-profiler gnunet-set-ibf-profiler
20 20
21libexec_PROGRAMS = \ 21libexec_PROGRAMS = \
22 gnunet-service-set 22 gnunet-service-set
@@ -24,17 +24,24 @@ libexec_PROGRAMS = \
24lib_LTLIBRARIES = \ 24lib_LTLIBRARIES = \
25 libgnunetset.la 25 libgnunetset.la
26 26
27gnunet_set_SOURCES = \ 27gnunet_set_profiler_SOURCES = \
28 gnunet-set.c 28 gnunet-set-profiler.c
29gnunet_set_LDADD = \ 29gnunet_set_profiler_LDADD = \
30 $(top_builddir)/src/util/libgnunetutil.la \ 30 $(top_builddir)/src/util/libgnunetutil.la \
31 $(top_builddir)/src/set/libgnunetset.la \ 31 $(top_builddir)/src/set/libgnunetset.la \
32 $(top_builddir)/src/stream/libgnunetstream.la \ 32 $(top_builddir)/src/testing/libgnunettesting.la \
33 $(top_builddir)/src/testbed/libgnunettestbed.la \
34 $(GN_LIBINTL) 33 $(GN_LIBINTL)
35gnunet_set_DEPENDENCIES = \ 34gnunet_set_profiler_DEPENDENCIES = \
36 libgnunetset.la 35 libgnunetset.la
37 36
37
38gnunet_set_ibf_profiler_SOURCES = \
39 gnunet-set-ibf-profiler.c \
40 ibf.c
41gnunet_set_ibf_profiler_LDADD = \
42 $(top_builddir)/src/util/libgnunetutil.la \
43 $(GN_LIBINTL)
44
38gnunet_service_set_SOURCES = \ 45gnunet_service_set_SOURCES = \
39 gnunet-service-set.c \ 46 gnunet-service-set.c \
40 gnunet-service-set_union.c \ 47 gnunet-service-set_union.c \
@@ -43,8 +50,7 @@ gnunet_service_set_SOURCES = \
43gnunet_service_set_LDADD = \ 50gnunet_service_set_LDADD = \
44 $(top_builddir)/src/util/libgnunetutil.la \ 51 $(top_builddir)/src/util/libgnunetutil.la \
45 $(top_builddir)/src/core/libgnunetcore.la \ 52 $(top_builddir)/src/core/libgnunetcore.la \
46 $(top_builddir)/src/stream/libgnunetstream.la \ 53 $(top_builddir)/src/mesh/libgnunetmesh2.la \
47 $(top_builddir)/src/mesh/libgnunetmesh.la \
48 $(GN_LIBINTL) 54 $(GN_LIBINTL)
49 55
50libgnunetset_la_SOURCES = \ 56libgnunetset_la_SOURCES = \