aboutsummaryrefslogtreecommitdiff
path: root/src/set/Makefile.am
diff options
context:
space:
mode:
authorFlorian Dold <florian.dold@gmail.com>2013-11-05 00:08:13 +0000
committerFlorian Dold <florian.dold@gmail.com>2013-11-05 00:08:13 +0000
commitca2c7bdfa64a30c0013598f0718dcfe7e6d98b2a (patch)
tree3bedd0e18f88371c2e75bd1953e0bc321629c828 /src/set/Makefile.am
parent6c3bf6b3486fd31402ab991f5ddef76bf9cd93c4 (diff)
downloadgnunet-ca2c7bdfa64a30c0013598f0718dcfe7e6d98b2a.tar.gz
gnunet-ca2c7bdfa64a30c0013598f0718dcfe7e6d98b2a.zip
- implemented missing set functionality
- secretsharing api changes
Diffstat (limited to 'src/set/Makefile.am')
-rw-r--r--src/set/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/set/Makefile.am b/src/set/Makefile.am
index 878ff0cbd..72d3d82a0 100644
--- a/src/set/Makefile.am
+++ b/src/set/Makefile.am
@@ -63,7 +63,7 @@ libgnunetset_la_LDFLAGS = \
63 63
64if HAVE_TESTING 64if HAVE_TESTING
65check_PROGRAMS = \ 65check_PROGRAMS = \
66 test_set_api 66 test_set_api test_set_union_result_full
67endif 67endif
68 68
69if ENABLE_TEST_RUN 69if ENABLE_TEST_RUN
@@ -79,6 +79,15 @@ test_set_api_LDADD = \
79test_set_api_DEPENDENCIES = \ 79test_set_api_DEPENDENCIES = \
80 libgnunetset.la 80 libgnunetset.la
81 81
82test_set_union_result_full_SOURCES = \
83 test_set_union_result_full.c
84test_set_union_result_full_LDADD = \
85 $(top_builddir)/src/util/libgnunetutil.la \
86 $(top_builddir)/src/testing/libgnunettesting.la \
87 $(top_builddir)/src/set/libgnunetset.la
88test_set_union_result_full_DEPENDENCIES = \
89 libgnunetset.la
90
82EXTRA_DIST = \ 91EXTRA_DIST = \
83 test_set.conf 92 test_set.conf
84 93