aboutsummaryrefslogtreecommitdiff
path: root/src/set/Makefile.am
diff options
context:
space:
mode:
authorChristian Fuchs <christian.fuchs@cfuchs.net>2014-01-26 16:47:56 +0000
committerChristian Fuchs <christian.fuchs@cfuchs.net>2014-01-26 16:47:56 +0000
commitd412dbaf5d4014aa1a491ebf0a2a5aaa50e588fe (patch)
treea9fcf216115c35cee54ee8ffcc7291aced63d6f3 /src/set/Makefile.am
parent11784c93530f249e4106954cf025e99d10a1f9d1 (diff)
downloadgnunet-d412dbaf5d4014aa1a491ebf0a2a5aaa50e588fe.tar.gz
gnunet-d412dbaf5d4014aa1a491ebf0a2a5aaa50e588fe.zip
- activated testcase for set intersection, as it not works correctly
- some bugfixes for intersection - corrected a logics bug in intersection
Diffstat (limited to 'src/set/Makefile.am')
-rw-r--r--src/set/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/set/Makefile.am b/src/set/Makefile.am
index a2bbab9a6..a02d80b9e 100644
--- a/src/set/Makefile.am
+++ b/src/set/Makefile.am
@@ -66,7 +66,7 @@ libgnunetset_la_LDFLAGS = \
66 66
67if HAVE_TESTING 67if HAVE_TESTING
68check_PROGRAMS = \ 68check_PROGRAMS = \
69 test_set_api test_set_union_result_full 69 test_set_api test_set_union_result_full test_set_intersection_result_full
70endif 70endif
71 71
72if ENABLE_TEST_RUN 72if ENABLE_TEST_RUN
@@ -92,6 +92,15 @@ test_set_union_result_full_LDADD = \
92test_set_union_result_full_DEPENDENCIES = \ 92test_set_union_result_full_DEPENDENCIES = \
93 libgnunetset.la 93 libgnunetset.la
94 94
95test_set_intersection_result_full_SOURCES = \
96 test_set_intersection_result_full.c
97test_set_intersection_result_full_LDADD = \
98 $(top_builddir)/src/util/libgnunetutil.la \
99 $(top_builddir)/src/testing/libgnunettesting.la \
100 $(top_builddir)/src/set/libgnunetset.la
101test_set_intersection_result_full_DEPENDENCIES = \
102 libgnunetset.la
103
95EXTRA_DIST = \ 104EXTRA_DIST = \
96 test_set.conf 105 test_set.conf
97 106