aboutsummaryrefslogtreecommitdiff
path: root/src/testbed/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2013-09-17 11:17:43 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2013-09-17 11:17:43 +0000
commitd0a73863512d8b07db1568962a8a45cc1440f274 (patch)
treeb4400d698d486601e9d708bb997d69653ab5a7ce /src/testbed/Makefile.am
parente2bfb8f7ce648be8e3596ea0c7aa86f5c0fbff4d (diff)
downloadgnunet-d0a73863512d8b07db1568962a8a45cc1440f274.tar.gz
gnunet-d0a73863512d8b07db1568962a8a45cc1440f274.zip
- remove python wrapper for barriers test case
Diffstat (limited to 'src/testbed/Makefile.am')
-rw-r--r--src/testbed/Makefile.am20
1 files changed, 5 insertions, 15 deletions
diff --git a/src/testbed/Makefile.am b/src/testbed/Makefile.am
index 2cf13570d..71abf0459 100644
--- a/src/testbed/Makefile.am
+++ b/src/testbed/Makefile.am
@@ -2,8 +2,6 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include
2 2
3if MINGW 3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols 4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5else
6 TEST_API_BARRIERS= test_testbed_api_barriers.py
7endif 5endif
8 6
9if USE_COVERAGE 7if USE_COVERAGE
@@ -39,8 +37,8 @@ CLEANFILES = $(check_SCRIPTS) \
39 buildvars.pyc 37 buildvars.pyc
40 38
41noinst_PROGRAMS = \ 39noinst_PROGRAMS = \
42 gnunet-service-test-barriers \ 40 gnunet-service-test-barriers
43 test-getcwd 41
44gnunet_service_testbed_SOURCES = \ 42gnunet_service_testbed_SOURCES = \
45 gnunet-service-testbed.h \ 43 gnunet-service-testbed.h \
46 gnunet-service-testbed.c \ 44 gnunet-service-testbed.c \
@@ -193,7 +191,7 @@ if ENABLE_TEST_RUN
193 test_testbed_api_testbed_run_topologysmallworldring \ 191 test_testbed_api_testbed_run_topologysmallworldring \
194 test_testbed_api_testbed_run_topologyfromfile \ 192 test_testbed_api_testbed_run_topologyfromfile \
195 test_testbed_api_testbed_run_topologyscalefree \ 193 test_testbed_api_testbed_run_topologyscalefree \
196 $(TEST_API_BARRIERS) 194 test_testbed_api_barriers
197endif 195endif
198 196
199test_testbed_api_hosts_SOURCES = \ 197test_testbed_api_hosts_SOURCES = \
@@ -371,11 +369,6 @@ test_testbed_api_barriers_LDADD = \
371 $(top_builddir)/src/util/libgnunetutil.la \ 369 $(top_builddir)/src/util/libgnunetutil.la \
372 libgnunettestbed.la 370 libgnunettestbed.la
373 371
374do_subst = sed -e 's,[@]libexecdir[@],$(libexecdir),g' -e 's,[@]exec_prefix[@],$(exec_prefix),g'
375
376buildvars.py: buildvars.py.in Makefile
377 $(do_subst) < $(srcdir)/buildvars.py.in > $@
378
379gnunet_service_test_barriers_SOURCES = \ 372gnunet_service_test_barriers_SOURCES = \
380 gnunet-service-test-barriers.c \ 373 gnunet-service-test-barriers.c \
381 test_testbed_api_barriers.h 374 test_testbed_api_barriers.h
@@ -395,10 +388,7 @@ EXTRA_DIST = \
395 test_testbed_api_testbed_run_topologysmallworld.conf \ 388 test_testbed_api_testbed_run_topologysmallworld.conf \
396 test_testbed_api_testbed_run_topologyfromfile.conf \ 389 test_testbed_api_testbed_run_topologyfromfile.conf \
397 test_testbed_api_testbed_run_topologyscalefree.conf \ 390 test_testbed_api_testbed_run_topologyscalefree.conf \
391 test_testbed_api_barriers.conf.in \
398 overlay_topology.txt \ 392 overlay_topology.txt \
399 sample_hosts.txt \ 393 sample_hosts.txt \
400 sample.job \ 394 sample.job
401 buildvars.py.in \
402 test_testbed_api_barriers.py
403
404test_getcwd_SOURCES = test_getcwd.c \ No newline at end of file