aboutsummaryrefslogtreecommitdiff
path: root/src/testbed/meson.build
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2023-09-27 17:36:36 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2023-09-27 17:36:36 +0200
commitc076a67de45e9214cea48ff74456861e80984d87 (patch)
tree033e2040872e5f52051343009f378b04f3eaa57f /src/testbed/meson.build
parent43ebcad0d712f59bf987dea55c88e6761a1aad5c (diff)
downloadgnunet-c076a67de45e9214cea48ff74456861e80984d87.tar.gz
gnunet-c076a67de45e9214cea48ff74456861e80984d87.zip
BUILD: Meson add testbed option (dysfunct)
Diffstat (limited to 'src/testbed/meson.build')
-rw-r--r--src/testbed/meson.build46
1 files changed, 46 insertions, 0 deletions
diff --git a/src/testbed/meson.build b/src/testbed/meson.build
new file mode 100644
index 000000000..927d1248c
--- /dev/null
+++ b/src/testbed/meson.build
@@ -0,0 +1,46 @@
1configure_file(input : 'testbed.conf',
2 output : 'testbed.conf',
3 configuration : cdata,
4 install: true,
5 install_dir: pkgcfgdir)
6
7
8if get_option('monolith')
9 subdir_done()
10endif
11executable ('gnunet-helper-testbed',
12 ['gnunet-helper-testbed.c'],
13 dependencies: [libgnunetutil_dep,
14 libgnunetcore_dep,
15 libgnunethello_dep,
16 libgnunetpeerinfo_dep,
17 libgnunetstatistics_dep,
18 libgnunettransport_dep,
19 zlib_dep],
20 include_directories: [incdir, configuration_inc],
21 install:true,
22 install_dir: get_option('libdir')/'gnunet'/'libexec')
23executable ('gnunet-daemon-testbed-blacklist',
24 ['gnunet-daemon-testbed-blacklist.c'],
25 dependencies: [libgnunetutil_dep,
26 libgnunetcore_dep,
27 libgnunethello_dep,
28 libgnunetpeerinfo_dep,
29 libgnunetstatistics_dep,
30 libgnunettransport_dep],
31 include_directories: [incdir, configuration_inc],
32 install:true,
33 install_dir: get_option('libdir')/'gnunet'/'libexec')
34
35executable ('gnunet-daemon-underlay',
36 ['gnunet-daemon-testbed-underlay.c'],
37 dependencies: [libgnunetutil_dep,
38 libgnunetcore_dep,
39 libgnunethello_dep,
40 libgnunetpeerinfo_dep,
41 libgnunetstatistics_dep,
42 libgnunettransport_dep,
43 sqlite_dep],
44 include_directories: [incdir, configuration_inc],
45 install:true,
46 install_dir: get_option('libdir')/'gnunet'/'libexec')