aboutsummaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2012-05-30 21:21:49 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2012-05-30 21:21:49 +0000
commit279d169d25efb2a9e77f0efd9b2da4e57e2989e5 (patch)
tree85a8d3f0aa594a78eddb6b37985a0aa2ee403a7f /src/testing/Makefile.am
parent8f654f30c3c4987c9ca1b564d6e6f2d75ae24862 (diff)
downloadgnunet-279d169d25efb2a9e77f0efd9b2da4e57e2989e5.tar.gz
gnunet-279d169d25efb2a9e77f0efd9b2da4e57e2989e5.zip
test case for peer startup in new testing library
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
index dc357fbf7..50b6d77b3 100644
--- a/src/testing/Makefile.am
+++ b/src/testing/Makefile.am
@@ -90,7 +90,8 @@ check_PROGRAMS = \
90 test_testing_topology_internat \ 90 test_testing_topology_internat \
91 test_testing_topology_none \ 91 test_testing_topology_none \
92 test_testing_topology_scale_free \ 92 test_testing_topology_scale_free \
93 test_testing_new_portreservation 93 test_testing_new_portreservation \
94 test_testing_new_peerstartup
94 95
95if ENABLE_TEST_RUN 96if ENABLE_TEST_RUN
96TESTS = \ 97TESTS = \
@@ -99,7 +100,8 @@ TESTS = \
99 test_testing_reconnect \ 100 test_testing_reconnect \
100 test_testing_group \ 101 test_testing_group \
101 test_testing_peergroup \ 102 test_testing_peergroup \
102 test_testing_new_portreservation 103 test_testing_new_portreservation \
104 test_testing_new_peerstartup
103endif 105endif
104 106
105gnunet_testing_SOURCES = \ 107gnunet_testing_SOURCES = \
@@ -271,6 +273,11 @@ test_testing_new_portreservation_LDADD = \
271 $(top_builddir)/src/testing/libgnunettesting_new.la \ 273 $(top_builddir)/src/testing/libgnunettesting_new.la \
272 $(top_builddir)/src/util/libgnunetutil.la 274 $(top_builddir)/src/util/libgnunetutil.la
273 275
276test_testing_new_peerstartup_SOURCES = \
277 test_testing_new_peerstartup.c
278test_testing_new_peerstartup_LDADD = \
279 $(top_builddir)/src/testing/libgnunettesting_new.la \
280 $(top_builddir)/src/util/libgnunetutil.la
274 281
275EXTRA_DIST = \ 282EXTRA_DIST = \
276 test_testing_defaults.conf \ 283 test_testing_defaults.conf \