aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorClaudiu Olteanu <claudiu@140774ce-b5e7-0310-ab8b-a85725594a96>2013-07-14 11:05:51 +0000
committerClaudiu Olteanu <claudiu@140774ce-b5e7-0310-ab8b-a85725594a96>2013-07-14 11:05:51 +0000
commit09be1a7abdd1de923db98e0513ab50aa6c1ac98a (patch)
tree2ac9d26c53e60fbfd77a64258957833e174c709b /src/transport/Makefile.am
parent28edd46f0da55f0ba65d57473ef1b674f5f60221 (diff)
downloadgnunet-09be1a7abdd1de923db98e0513ab50aa6c1ac98a.tar.gz
gnunet-09be1a7abdd1de923db98e0513ab50aa6c1ac98a.zip
Integrating bluetooth plugin
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am33
1 files changed, 32 insertions, 1 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 4ace2bc1e..feff9d918 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -59,7 +59,6 @@ if LINUX
59 test_quota_compliance_wlan_asymmetric 59 test_quota_compliance_wlan_asymmetric
60endif 60endif
61 61
62
63if LINUX 62if LINUX
64install-exec-hook: 63install-exec-hook:
65 $(top_srcdir)/src/transport/install-wlan-helper.sh $(libexecdir) $(SUDO_BINARY) || true 64 $(top_srcdir)/src/transport/install-wlan-helper.sh $(libexecdir) $(SUDO_BINARY) || true
@@ -67,6 +66,23 @@ else
67install-exec-hook: 66install-exec-hook:
68endif 67endif
69 68
69if LINUX
70if HAVE_LIBBLUETOOTH
71 AM_LDFLAGS = -lbluetooth
72 BT_BIN = gnunet-helper-transport-bluetooth
73 BT_PLUGIN_LA = libgnunet_plugin_transport_bluetooth.la
74endif
75endif
76
77if LINUX
78if HAVE_LIBBLUETOOTH
79install-exec-hook2:
80 $(top_srcdir)/src/transport/install-bluetooth-helper.sh $(libexecdir) $(SUDO_BINARY) || true
81endif
82else
83install-exec-hook2:
84endif
85
70if !MINGW 86if !MINGW
71UNIX_PLUGIN_LA = libgnunet_plugin_transport_unix.la 87UNIX_PLUGIN_LA = libgnunet_plugin_transport_unix.la
72UNIX_PLUGIN_TEST = test_transport_api_unix 88UNIX_PLUGIN_TEST = test_transport_api_unix
@@ -118,6 +134,7 @@ libgnunettransport_la_LDFLAGS = \
118libexec_PROGRAMS = \ 134libexec_PROGRAMS = \
119 $(WLAN_BIN) \ 135 $(WLAN_BIN) \
120 $(WLAN_BIN_DUMMY) \ 136 $(WLAN_BIN_DUMMY) \
137 $(BT_BIN) \
121 gnunet-service-transport 138 gnunet-service-transport
122 139
123bin_PROGRAMS = \ 140bin_PROGRAMS = \
@@ -150,6 +167,9 @@ gnunet_transport_wlan_receiver_SOURCES = \
150gnunet_transport_wlan_receiver_LDADD = \ 167gnunet_transport_wlan_receiver_LDADD = \
151 $(top_builddir)/src/util/libgnunetutil.la 168 $(top_builddir)/src/util/libgnunetutil.la
152 169
170gnunet_helper_transport_bluetooth_SOURCES = \
171 gnunet-helper-transport-bluetooth.c
172
153gnunet_transport_SOURCES = \ 173gnunet_transport_SOURCES = \
154 gnunet-transport.c 174 gnunet-transport.c
155gnunet_transport_LDADD = \ 175gnunet_transport_LDADD = \
@@ -312,6 +332,17 @@ libgnunet_plugin_transport_https_server_la_LDFLAGS = \
312libgnunet_plugin_transport_https_server_la_CFLAGS = \ 332libgnunet_plugin_transport_https_server_la_CFLAGS = \
313 $(CFLAGS) -DBUILD_HTTPS 333 $(CFLAGS) -DBUILD_HTTPS
314 334
335libgnunet_plugin_transport_bluetooth_la_SOURCES = \
336 plugin_transport_bluetooth.c plugin_transport_wlan.h
337libgnunet_plugin_transport_bluetooth_la_LIBADD = \
338 $(top_builddir)/src/hello/libgnunethello.la \
339 $(top_builddir)/src/statistics/libgnunetstatistics.la \
340 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
341 $(top_builddir)/src/fragmentation/libgnunetfragmentation.la \
342 $(top_builddir)/src/util/libgnunetutil.la \
343libgnunet_plugin_transport_bluetooth_la_LDFLAGS = \
344 $(GN_PLUGIN_LDFLAGS)
345
315if HAVE_TESTING 346if HAVE_TESTING
316check_PROGRAMS = \ 347check_PROGRAMS = \
317 test_transport_testing_startstop \ 348 test_transport_testing_startstop \