aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorClaudiu Olteanu <claudiu@140774ce-b5e7-0310-ab8b-a85725594a96>2013-07-19 13:55:58 +0000
committerClaudiu Olteanu <claudiu@140774ce-b5e7-0310-ab8b-a85725594a96>2013-07-19 13:55:58 +0000
commit0bf3528ea3b8cac950eee7e3e36b2ae91e3202b0 (patch)
tree8052290e5fad9e23d1788f62b1d11c20822c6dbd /src/transport/Makefile.am
parent5fa6ddca12f243a1dfcedc35986b00ead0f6183a (diff)
downloadgnunet-0bf3528ea3b8cac950eee7e3e36b2ae91e3202b0.tar.gz
gnunet-0bf3528ea3b8cac950eee7e3e36b2ae91e3202b0.zip
Fixing dependencies for bluetooth plugin
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am22
1 files changed, 12 insertions, 10 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index feff9d918..4524f9897 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -211,6 +211,7 @@ plugin_LTLIBRARIES = \
211 $(HTTP_SERVER_PLUGIN_LA) \ 211 $(HTTP_SERVER_PLUGIN_LA) \
212 $(HTTPS_SERVER_PLUGIN_LA) \ 212 $(HTTPS_SERVER_PLUGIN_LA) \
213 $(WLAN_PLUGIN_LA) \ 213 $(WLAN_PLUGIN_LA) \
214 $(BT_PLUGIN_LA) \
214 libgnunet_plugin_transport_template.la 215 libgnunet_plugin_transport_template.la
215 216
216libgnunet_plugin_transport_tcp_la_SOURCES = \ 217libgnunet_plugin_transport_tcp_la_SOURCES = \
@@ -244,6 +245,17 @@ libgnunet_plugin_transport_wlan_la_LIBADD = \
244libgnunet_plugin_transport_wlan_la_LDFLAGS = \ 245libgnunet_plugin_transport_wlan_la_LDFLAGS = \
245 $(GN_PLUGIN_LDFLAGS) 246 $(GN_PLUGIN_LDFLAGS)
246 247
248libgnunet_plugin_transport_bluetooth_la_SOURCES = \
249 plugin_transport_bluetooth.c plugin_transport_wlan.h
250libgnunet_plugin_transport_bluetooth_la_LIBADD = \
251 $(top_builddir)/src/hello/libgnunethello.la \
252 $(top_builddir)/src/statistics/libgnunetstatistics.la \
253 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
254 $(top_builddir)/src/fragmentation/libgnunetfragmentation.la \
255 $(top_builddir)/src/util/libgnunetutil.la
256libgnunet_plugin_transport_bluetooth_la_LDFLAGS = \
257 $(GN_PLUGIN_LDFLAGS)
258
247libgnunet_plugin_transport_udp_la_SOURCES = \ 259libgnunet_plugin_transport_udp_la_SOURCES = \
248 plugin_transport_udp.c plugin_transport_udp.h \ 260 plugin_transport_udp.c plugin_transport_udp.h \
249 plugin_transport_udp_broadcasting.c 261 plugin_transport_udp_broadcasting.c
@@ -332,16 +344,6 @@ libgnunet_plugin_transport_https_server_la_LDFLAGS = \
332libgnunet_plugin_transport_https_server_la_CFLAGS = \ 344libgnunet_plugin_transport_https_server_la_CFLAGS = \
333 $(CFLAGS) -DBUILD_HTTPS 345 $(CFLAGS) -DBUILD_HTTPS
334 346
335libgnunet_plugin_transport_bluetooth_la_SOURCES = \
336 plugin_transport_bluetooth.c plugin_transport_wlan.h
337libgnunet_plugin_transport_bluetooth_la_LIBADD = \
338 $(top_builddir)/src/hello/libgnunethello.la \
339 $(top_builddir)/src/statistics/libgnunetstatistics.la \
340 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
341 $(top_builddir)/src/fragmentation/libgnunetfragmentation.la \
342 $(top_builddir)/src/util/libgnunetutil.la \
343libgnunet_plugin_transport_bluetooth_la_LDFLAGS = \
344 $(GN_PLUGIN_LDFLAGS)
345 347
346if HAVE_TESTING 348if HAVE_TESTING
347check_PROGRAMS = \ 349check_PROGRAMS = \