aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2023-10-15 12:08:10 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2023-10-15 12:08:10 +0200
commit155d1a862a117de213593a977fc2c1d10fde0325 (patch)
tree385d626a39448588b734a9750136dd543fae93c5 /src/transport/Makefile.am
parentb0a7ddd39b8c5c29f672dd269bf0077715947ba6 (diff)
downloadgnunet-155d1a862a117de213593a977fc2c1d10fde0325.tar.gz
gnunet-155d1a862a117de213593a977fc2c1d10fde0325.zip
TRANSPORT: Rename TNG to transport, cleanup makefile
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am20
1 files changed, 4 insertions, 16 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index eb644706c..9815e0f01 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -96,7 +96,7 @@ libgnunettransportmonitor_la_LDFLAGS = \
96 96
97 97
98libexec_PROGRAMS = \ 98libexec_PROGRAMS = \
99 gnunet-service-tng \ 99 gnunet-service-transport \
100 gnunet-communicator-unix \ 100 gnunet-communicator-unix \
101 gnunet-communicator-udp \ 101 gnunet-communicator-udp \
102 gnunet-communicator-tcp 102 gnunet-communicator-tcp
@@ -168,15 +168,6 @@ gnunet_communicator_quic_LDADD = \
168endif 168endif
169endif 169endif
170 170
171#gnunet_transport_profiler_SOURCES = \
172# gnunet-transport-profiler.c
173#gnunet_transport_profiler_LDADD = \
174# libgnunettransport.la \
175# $(top_builddir)/src/hello/libgnunethello.la \
176# $(top_builddir)/src/ats/libgnunetats.la \
177# $(top_builddir)/src/util/libgnunetutil.la \
178# $(GN_LIBINTL)
179
180#gnunet_transport_SOURCES = \ 171#gnunet_transport_SOURCES = \
181# gnunet-transport.c 172# gnunet-transport.c
182#gnunet_transport_LDADD = \ 173#gnunet_transport_LDADD = \
@@ -185,9 +176,9 @@ endif
185# $(top_builddir)/src/util/libgnunetutil.la \ 176# $(top_builddir)/src/util/libgnunetutil.la \
186# $(GN_LIBINTL) 177# $(GN_LIBINTL)
187 178
188gnunet_service_tng_SOURCES = \ 179gnunet_service_transport_SOURCES = \
189 gnunet-service-tng.c transport.h 180 gnunet-service-transport.c transport.h
190gnunet_service_tng_LDADD = \ 181gnunet_service_transport_LDADD = \
191 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \ 182 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
192 $(top_builddir)/src/hello/libgnunethello.la \ 183 $(top_builddir)/src/hello/libgnunethello.la \
193 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 184 $(top_builddir)/src/statistics/libgnunetstatistics.la \
@@ -309,8 +300,6 @@ check_PROGRAMS = \
309 test_communicator_backchannel-udp \ 300 test_communicator_backchannel-udp \
310 test_communicator_bidirect-tcp 301 test_communicator_bidirect-tcp
311 302
312# Only test TNG if we run experimental
313if HAVE_EXPERIMENTAL
314check_SCRIPTS= \ 303check_SCRIPTS= \
315 test_transport_start_testcase.sh \ 304 test_transport_start_testcase.sh \
316 test_transport_simple_send_performance.sh \ 305 test_transport_simple_send_performance.sh \
@@ -322,7 +311,6 @@ check_SCRIPTS= \
322 test_transport_udp_backchannel.sh \ 311 test_transport_udp_backchannel.sh \
323 test_transport_simple_send_dv_circle.sh \ 312 test_transport_simple_send_dv_circle.sh \
324 test_transport_simple_send_dv_inverse.sh 313 test_transport_simple_send_dv_inverse.sh
325endif
326 314
327if ENABLE_TEST_RUN 315if ENABLE_TEST_RUN
328AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 316AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;