aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-02-05 00:53:22 +0000
committerChristian Grothoff <christian@grothoff.org>2015-02-05 00:53:22 +0000
commit15dd8e6cc1199d611d804853e134882bf13b234a (patch)
tree7cc90886eabe8d0ffa397a319e12a87042d0ba28 /src/transport/Makefile.am
parentbf6a2c9deeff7a3b384eb029d8267d6099066df3 (diff)
downloadgnunet-15dd8e6cc1199d611d804853e134882bf13b234a.tar.gz
gnunet-15dd8e6cc1199d611d804853e134882bf13b234a.zip
Various changes:
- removed "in_use" from being passed to ATS, no longer needed as we tell ATS when we cannot follow a suggestion by removing the address; simplifies the code a lot - better handling of state machine, fallback to primary session if address switch to new session timed out - nicer logging - more comments - new testcase failures, because of #3652, #3651 and #3650 (or more that i missed).
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 749550657..7beec3118 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -416,6 +416,9 @@ libgnunet_plugin_transport_https_server_la_CFLAGS = \
416 416
417if HAVE_TESTING 417if HAVE_TESTING
418check_PROGRAMS = \ 418check_PROGRAMS = \
419 test_transport_api_restart_2peers \
420 test_transport_address_switch_tcp \
421 test_transport_address_switch_udp \
419 test_transport_testing_startstop \ 422 test_transport_testing_startstop \
420 test_transport_testing_restart \ 423 test_transport_testing_restart \
421 test_transport_testing \ 424 test_transport_testing \
@@ -435,14 +438,11 @@ check_PROGRAMS = \
435 test_transport_api_bidirectional_connect \ 438 test_transport_api_bidirectional_connect \
436 test_transport_api_tcp \ 439 test_transport_api_tcp \
437 test_transport_api_restart_1peer \ 440 test_transport_api_restart_1peer \
438 test_transport_api_restart_2peers \
439 test_transport_api_timeout_tcp \ 441 test_transport_api_timeout_tcp \
440 test_transport_address_switch_tcp \
441 test_transport_api_limited_sockets_tcp \ 442 test_transport_api_limited_sockets_tcp \
442 test_transport_api_tcp_nat \ 443 test_transport_api_tcp_nat \
443 test_transport_api_udp \ 444 test_transport_api_udp \
444 test_transport_api_timeout_udp \ 445 test_transport_api_timeout_udp \
445 test_transport_address_switch_udp \
446 $(UNIX_PLUGIN_TEST) \ 446 $(UNIX_PLUGIN_TEST) \
447 $(UNIX_PLUGIN_TIMEOUT_TEST) \ 447 $(UNIX_PLUGIN_TIMEOUT_TEST) \
448 $(UNIX_API_ABSTRACT_TEST) \ 448 $(UNIX_API_ABSTRACT_TEST) \