aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2011-06-05 13:07:13 +0000
committerChristian Grothoff <christian@grothoff.org>2011-06-05 13:07:13 +0000
commit187f3ee1b6edac986b7bc46c62c86a138290b147 (patch)
tree809c2751509e7111ad26e802e5df8d2332c24455 /src/transport/Makefile.am
parent2850662595ec7d25aaaf9674e987449375960c23 (diff)
downloadgnunet-187f3ee1b6edac986b7bc46c62c86a138290b147.tar.gz
gnunet-187f3ee1b6edac986b7bc46c62c86a138290b147.zip
adapting testcases to use new API
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am58
1 files changed, 26 insertions, 32 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 2d8e4a40a..71444c4fe 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -128,11 +128,11 @@ gnunet_nat_client_SOURCES = \
128gnunet_transport_SOURCES = \ 128gnunet_transport_SOURCES = \
129 gnunet-transport.c 129 gnunet-transport.c
130gnunet_transport_LDADD = \ 130gnunet_transport_LDADD = \
131 $(top_builddir)/src/transport/libgnunettransport.la \ 131 $(top_builddir)/src/transport/libgnunettransportnew.la \
132 $(top_builddir)/src/util/libgnunetutil.la \ 132 $(top_builddir)/src/util/libgnunetutil.la \
133 $(GN_LIBINTL) 133 $(GN_LIBINTL)
134gnunet_transport_DEPENDENCIES = \ 134gnunet_transport_DEPENDENCIES = \
135 libgnunettransport.la 135 libgnunettransportnew.la
136 136
137if HAVE_LIBGLPK 137if HAVE_LIBGLPK
138 GN_GLPK = -lglpk 138 GN_GLPK = -lglpk
@@ -147,8 +147,6 @@ gnunet_service_transport_LDADD = \
147 $(top_builddir)/src/util/libgnunetutil.la \ 147 $(top_builddir)/src/util/libgnunetutil.la \
148 $(GN_GLPK) \ 148 $(GN_GLPK) \
149 $(GN_LIBINTL) 149 $(GN_LIBINTL)
150gnunet_service_transport_DEPENDENCIES = \
151 libgnunettransport.la
152 150
153plugin_LTLIBRARIES = \ 151plugin_LTLIBRARIES = \
154 libgnunet_plugin_transport_tcp.la \ 152 libgnunet_plugin_transport_tcp.la \
@@ -301,7 +299,7 @@ endif
301test_transport_ats_SOURCES = \ 299test_transport_ats_SOURCES = \
302 test_transport_ats.c 300 test_transport_ats.c
303test_transport_ats_LDADD = -lm \ 301test_transport_ats_LDADD = -lm \
304 $(top_builddir)/src/transport/libgnunettransport.la \ 302 $(top_builddir)/src/transport/libgnunettransportnew.la \
305 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 303 $(top_builddir)/src/statistics/libgnunetstatistics.la \
306 $(top_builddir)/src/testing/libgnunettesting.la \ 304 $(top_builddir)/src/testing/libgnunettesting.la \
307 $(top_builddir)/src/util/libgnunetutil.la 305 $(top_builddir)/src/util/libgnunetutil.la
@@ -309,9 +307,6 @@ test_transport_ats_LDADD = -lm \
309perf_transport_ats_SOURCES = \ 307perf_transport_ats_SOURCES = \
310 perf_transport_ats.c 308 perf_transport_ats.c
311perf_transport_ats_LDADD = \ 309perf_transport_ats_LDADD = \
312 $(top_builddir)/src/transport/libgnunettransport.la \
313 $(top_builddir)/src/statistics/libgnunetstatistics.la \
314 $(top_builddir)/src/testing/libgnunettesting.la \
315 $(GN_GLPK) \ 310 $(GN_GLPK) \
316 $(top_builddir)/src/util/libgnunetutil.la 311 $(top_builddir)/src/util/libgnunetutil.la
317 312
@@ -332,28 +327,28 @@ test_transport_api_tcp_nat_LDADD = \
332test_transport_api_reliability_tcp_SOURCES = \ 327test_transport_api_reliability_tcp_SOURCES = \
333 test_transport_api_reliability.c 328 test_transport_api_reliability.c
334test_transport_api_reliability_tcp_LDADD = \ 329test_transport_api_reliability_tcp_LDADD = \
335 $(top_builddir)/src/transport/libgnunettransport.la \ 330 $(top_builddir)/src/transport/libgnunettransportnew.la \
336 $(top_builddir)/src/hello/libgnunethello.la \ 331 $(top_builddir)/src/hello/libgnunethello.la \
337 $(top_builddir)/src/util/libgnunetutil.la 332 $(top_builddir)/src/util/libgnunetutil.la
338 333
339test_transport_api_reliability_tcp_nat_SOURCES = \ 334test_transport_api_reliability_tcp_nat_SOURCES = \
340 test_transport_api_reliability.c 335 test_transport_api_reliability.c
341test_transport_api_reliability_tcp_nat_LDADD = \ 336test_transport_api_reliability_tcp_nat_LDADD = \
342 $(top_builddir)/src/transport/libgnunettransport.la \ 337 $(top_builddir)/src/transport/libgnunettransportnew.la \
343 $(top_builddir)/src/hello/libgnunethello.la \ 338 $(top_builddir)/src/hello/libgnunethello.la \
344 $(top_builddir)/src/util/libgnunetutil.la 339 $(top_builddir)/src/util/libgnunetutil.la
345 340
346test_transport_api_reliability_wlan_SOURCES = \ 341test_transport_api_reliability_wlan_SOURCES = \
347 test_transport_api_reliability.c 342 test_transport_api_reliability.c
348test_transport_api_reliability_wlan_LDADD = \ 343test_transport_api_reliability_wlan_LDADD = \
349 $(top_builddir)/src/transport/libgnunettransport.la \ 344 $(top_builddir)/src/transport/libgnunettransportnew.la \
350 $(top_builddir)/src/hello/libgnunethello.la \ 345 $(top_builddir)/src/hello/libgnunethello.la \
351 $(top_builddir)/src/util/libgnunetutil.la 346 $(top_builddir)/src/util/libgnunetutil.la
352 347
353test_transport_api_unreliability_wlan_SOURCES = \ 348test_transport_api_unreliability_wlan_SOURCES = \
354 test_transport_api_unreliability.c 349 test_transport_api_unreliability.c
355test_transport_api_unreliability_wlan_LDADD = \ 350test_transport_api_unreliability_wlan_LDADD = \
356 $(top_builddir)/src/transport/libgnunettransport.la \ 351 $(top_builddir)/src/transport/libgnunettransportnew.la \
357 $(top_builddir)/src/hello/libgnunethello.la \ 352 $(top_builddir)/src/hello/libgnunethello.la \
358 $(top_builddir)/src/util/libgnunetutil.la 353 $(top_builddir)/src/util/libgnunetutil.la
359 354
@@ -381,7 +376,6 @@ test_transport_api_unix_LDADD = \
381test_plugin_transport_http_SOURCES = \ 376test_plugin_transport_http_SOURCES = \
382 test_plugin_transport_http.c 377 test_plugin_transport_http.c
383test_plugin_transport_http_LDADD = \ 378test_plugin_transport_http_LDADD = \
384 $(top_builddir)/src/transport/libgnunettransport.la \
385 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 379 $(top_builddir)/src/statistics/libgnunetstatistics.la \
386 @LIBCURL@ \ 380 @LIBCURL@ \
387 $(top_builddir)/src/hello/libgnunethello.la \ 381 $(top_builddir)/src/hello/libgnunethello.la \
@@ -397,14 +391,13 @@ test_transport_api_http_LDADD = \
397test_transport_api_reliability_http_SOURCES = \ 391test_transport_api_reliability_http_SOURCES = \
398 test_transport_api_reliability.c 392 test_transport_api_reliability.c
399test_transport_api_reliability_http_LDADD = \ 393test_transport_api_reliability_http_LDADD = \
400 $(top_builddir)/src/transport/libgnunettransport.la \ 394 $(top_builddir)/src/transport/libgnunettransportnew.la \
401 $(top_builddir)/src/hello/libgnunethello.la \ 395 $(top_builddir)/src/hello/libgnunethello.la \
402 $(top_builddir)/src/util/libgnunetutil.la 396 $(top_builddir)/src/util/libgnunetutil.la
403 397
404test_plugin_transport_https_SOURCES = \ 398test_plugin_transport_https_SOURCES = \
405 test_plugin_transport_https.c 399 test_plugin_transport_https.c
406test_plugin_transport_https_LDADD = \ 400test_plugin_transport_https_LDADD = \
407 $(top_builddir)/src/transport/libgnunettransport.la \
408 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 401 $(top_builddir)/src/statistics/libgnunetstatistics.la \
409 @LIBCURL@ \ 402 @LIBCURL@ \
410 $(top_builddir)/src/hello/libgnunethello.la \ 403 $(top_builddir)/src/hello/libgnunethello.la \
@@ -420,21 +413,21 @@ test_transport_api_https_LDADD = \
420test_transport_api_reliability_https_SOURCES = \ 413test_transport_api_reliability_https_SOURCES = \
421 test_transport_api_reliability.c 414 test_transport_api_reliability.c
422test_transport_api_reliability_https_LDADD = \ 415test_transport_api_reliability_https_LDADD = \
423 $(top_builddir)/src/transport/libgnunettransport.la \ 416 $(top_builddir)/src/transport/libgnunettransportnew.la \
424 $(top_builddir)/src/hello/libgnunethello.la \ 417 $(top_builddir)/src/hello/libgnunethello.la \
425 $(top_builddir)/src/util/libgnunetutil.la 418 $(top_builddir)/src/util/libgnunetutil.la
426 419
427test_transport_api_unreliability_unix_SOURCES = \ 420test_transport_api_unreliability_unix_SOURCES = \
428 test_transport_api_unreliability.c 421 test_transport_api_unreliability.c
429test_transport_api_unreliability_unix_LDADD = \ 422test_transport_api_unreliability_unix_LDADD = \
430 $(top_builddir)/src/transport/libgnunettransport.la \ 423 $(top_builddir)/src/transport/libgnunettransportnew.la \
431 $(top_builddir)/src/hello/libgnunethello.la \ 424 $(top_builddir)/src/hello/libgnunethello.la \
432 $(top_builddir)/src/util/libgnunetutil.la 425 $(top_builddir)/src/util/libgnunetutil.la
433 426
434test_transport_api_unreliability_udp_SOURCES = \ 427test_transport_api_unreliability_udp_SOURCES = \
435 test_transport_api_unreliability.c 428 test_transport_api_unreliability.c
436test_transport_api_unreliability_udp_LDADD = \ 429test_transport_api_unreliability_udp_LDADD = \
437 $(top_builddir)/src/transport/libgnunettransport.la \ 430 $(top_builddir)/src/transport/libgnunettransportnew.la \
438 $(top_builddir)/src/hello/libgnunethello.la \ 431 $(top_builddir)/src/hello/libgnunethello.la \
439 $(top_builddir)/src/util/libgnunetutil.la 432 $(top_builddir)/src/util/libgnunetutil.la
440 433
@@ -452,94 +445,94 @@ endif
452test_quota_compliance_tcp_SOURCES = \ 445test_quota_compliance_tcp_SOURCES = \
453 test_quota_compliance.c 446 test_quota_compliance.c
454test_quota_compliance_tcp_LDADD = \ 447test_quota_compliance_tcp_LDADD = \
455 $(top_builddir)/src/transport/libgnunettransport.la \ 448 $(top_builddir)/src/transport/libgnunettransportnew.la \
456 $(top_builddir)/src/hello/libgnunethello.la \ 449 $(top_builddir)/src/hello/libgnunethello.la \
457 $(top_builddir)/src/util/libgnunetutil.la 450 $(top_builddir)/src/util/libgnunetutil.la
458 451
459test_quota_compliance_tcp_asymmetric_recv_constant_SOURCES = \ 452test_quota_compliance_tcp_asymmetric_recv_constant_SOURCES = \
460 test_quota_compliance.c 453 test_quota_compliance.c
461test_quota_compliance_tcp_asymmetric_recv_constant_LDADD = \ 454test_quota_compliance_tcp_asymmetric_recv_constant_LDADD = \
462 $(top_builddir)/src/transport/libgnunettransport.la \ 455 $(top_builddir)/src/transport/libgnunettransportnew.la \
463 $(top_builddir)/src/hello/libgnunethello.la \ 456 $(top_builddir)/src/hello/libgnunethello.la \
464 $(top_builddir)/src/util/libgnunetutil.la 457 $(top_builddir)/src/util/libgnunetutil.la
465 458
466#test_quota_compliance_tcp_asymmetric_send_constant_SOURCES = \ 459#test_quota_compliance_tcp_asymmetric_send_constant_SOURCES = \
467# test_quota_compliance.c 460# test_quota_compliance.c
468#test_quota_compliance_tcp_asymmetric_send_constant_LDADD = \ 461#test_quota_compliance_tcp_asymmetric_send_constant_LDADD = \
469# $(top_builddir)/src/transport/libgnunettransport.la \ 462# $(top_builddir)/src/transport/libgnunettransportnew.la \
470# $(top_builddir)/src/util/libgnunetutil.la 463# $(top_builddir)/src/util/libgnunetutil.la
471 464
472test_quota_compliance_http_SOURCES = \ 465test_quota_compliance_http_SOURCES = \
473 test_quota_compliance.c 466 test_quota_compliance.c
474test_quota_compliance_http_LDADD = \ 467test_quota_compliance_http_LDADD = \
475 $(top_builddir)/src/transport/libgnunettransport.la \ 468 $(top_builddir)/src/transport/libgnunettransportnew.la \
476 $(top_builddir)/src/hello/libgnunethello.la \ 469 $(top_builddir)/src/hello/libgnunethello.la \
477 $(top_builddir)/src/util/libgnunetutil.la 470 $(top_builddir)/src/util/libgnunetutil.la
478 471
479 test_quota_compliance_http_asymmetric_recv_constant_SOURCES = \ 472 test_quota_compliance_http_asymmetric_recv_constant_SOURCES = \
480 test_quota_compliance.c 473 test_quota_compliance.c
481test_quota_compliance_http_asymmetric_recv_constant_LDADD = \ 474test_quota_compliance_http_asymmetric_recv_constant_LDADD = \
482 $(top_builddir)/src/transport/libgnunettransport.la \ 475 $(top_builddir)/src/transport/libgnunettransportnew.la \
483 $(top_builddir)/src/hello/libgnunethello.la \ 476 $(top_builddir)/src/hello/libgnunethello.la \
484 $(top_builddir)/src/util/libgnunetutil.la 477 $(top_builddir)/src/util/libgnunetutil.la
485 478
486#test_quota_compliance_http_asymmetric_send_constant_SOURCES = \ 479#test_quota_compliance_http_asymmetric_send_constant_SOURCES = \
487# test_quota_compliance.c 480# test_quota_compliance.c
488#test_quota_compliance_http_asymmetric_send_constant_LDADD = \ 481#test_quota_compliance_http_asymmetric_send_constant_LDADD = \
489# $(top_builddir)/src/transport/libgnunettransport.la \ 482# $(top_builddir)/src/transport/libgnunettransportnew.la \
490# $(top_builddir)/src/util/libgnunetutil.la 483# $(top_builddir)/src/util/libgnunetutil.la
491 484
492test_quota_compliance_https_SOURCES = \ 485test_quota_compliance_https_SOURCES = \
493 test_quota_compliance.c 486 test_quota_compliance.c
494test_quota_compliance_https_LDADD = \ 487test_quota_compliance_https_LDADD = \
495 $(top_builddir)/src/transport/libgnunettransport.la \ 488 $(top_builddir)/src/transport/libgnunettransportnew.la \
496 $(top_builddir)/src/hello/libgnunethello.la \ 489 $(top_builddir)/src/hello/libgnunethello.la \
497 $(top_builddir)/src/util/libgnunetutil.la 490 $(top_builddir)/src/util/libgnunetutil.la
498 491
499 test_quota_compliance_https_asymmetric_recv_constant_SOURCES = \ 492 test_quota_compliance_https_asymmetric_recv_constant_SOURCES = \
500 test_quota_compliance.c 493 test_quota_compliance.c
501test_quota_compliance_https_asymmetric_recv_constant_LDADD = \ 494test_quota_compliance_https_asymmetric_recv_constant_LDADD = \
502 $(top_builddir)/src/transport/libgnunettransport.la \ 495 $(top_builddir)/src/transport/libgnunettransportnew.la \
503 $(top_builddir)/src/hello/libgnunethello.la \ 496 $(top_builddir)/src/hello/libgnunethello.la \
504 $(top_builddir)/src/util/libgnunetutil.la 497 $(top_builddir)/src/util/libgnunetutil.la
505 498
506#test_quota_compliance_https_asymmetric_send_constant_SOURCES = \ 499#test_quota_compliance_https_asymmetric_send_constant_SOURCES = \
507# test_quota_compliance.c 500# test_quota_compliance.c
508#test_quota_compliance_https_asymmetric_send_constant_LDADD = \ 501#test_quota_compliance_https_asymmetric_send_constant_LDADD = \
509# $(top_builddir)/src/transport/libgnunettransport.la \ 502# $(top_builddir)/src/transport/libgnunettransportnew.la \
510# $(top_builddir)/src/util/libgnunetutil.la 503# $(top_builddir)/src/util/libgnunetutil.la
511 504
512test_quota_compliance_udp_SOURCES = \ 505test_quota_compliance_udp_SOURCES = \
513 test_quota_compliance.c 506 test_quota_compliance.c
514test_quota_compliance_udp_LDADD = \ 507test_quota_compliance_udp_LDADD = \
515 $(top_builddir)/src/transport/libgnunettransport.la \ 508 $(top_builddir)/src/transport/libgnunettransportnew.la \
516 $(top_builddir)/src/hello/libgnunethello.la \ 509 $(top_builddir)/src/hello/libgnunethello.la \
517 $(top_builddir)/src/util/libgnunetutil.la 510 $(top_builddir)/src/util/libgnunetutil.la
518 511
519test_quota_compliance_udp_asymmetric_recv_constant_SOURCES = \ 512test_quota_compliance_udp_asymmetric_recv_constant_SOURCES = \
520 test_quota_compliance.c 513 test_quota_compliance.c
521test_quota_compliance_udp_asymmetric_recv_constant_LDADD = \ 514test_quota_compliance_udp_asymmetric_recv_constant_LDADD = \
522 $(top_builddir)/src/transport/libgnunettransport.la \ 515 $(top_builddir)/src/transport/libgnunettransportnew.la \
523 $(top_builddir)/src/hello/libgnunethello.la \ 516 $(top_builddir)/src/hello/libgnunethello.la \
524 $(top_builddir)/src/util/libgnunetutil.la 517 $(top_builddir)/src/util/libgnunetutil.la
525 518
526#test_quota_compliance_udp_asymmetric_send_constant_SOURCES = \ 519#test_quota_compliance_udp_asymmetric_send_constant_SOURCES = \
527# test_quota_compliance.c 520# test_quota_compliance.c
528#test_quota_compliance_udp_asymmetric_send_constant_LDADD = \ 521#test_quota_compliance_udp_asymmetric_send_constant_LDADD = \
529# $(top_builddir)/src/transport/libgnunettransport.la \ 522# $(top_builddir)/src/transport/libgnunettransportnew.la \
530# $(top_builddir)/src/util/libgnunetutil.la 523# $(top_builddir)/src/util/libgnunetutil.la
531 524
532test_quota_compliance_unix_SOURCES = \ 525test_quota_compliance_unix_SOURCES = \
533 test_quota_compliance.c 526 test_quota_compliance.c
534test_quota_compliance_unix_LDADD = \ 527test_quota_compliance_unix_LDADD = \
535 $(top_builddir)/src/transport/libgnunettransport.la \ 528 $(top_builddir)/src/transport/libgnunettransportnew.la \
536 $(top_builddir)/src/hello/libgnunethello.la \ 529 $(top_builddir)/src/hello/libgnunethello.la \
537 $(top_builddir)/src/util/libgnunetutil.la 530 $(top_builddir)/src/util/libgnunetutil.la
538 531
539test_quota_compliance_unix_asymmetric_recv_constant_SOURCES = \ 532test_quota_compliance_unix_asymmetric_recv_constant_SOURCES = \
540 test_quota_compliance.c 533 test_quota_compliance.c
541test_quota_compliance_unix_asymmetric_recv_constant_LDADD = \ 534test_quota_compliance_unix_asymmetric_recv_constant_LDADD = \
542 $(top_builddir)/src/transport/libgnunettransport.la \ 535 $(top_builddir)/src/transport/libgnunettransportnew.la \
543 $(top_builddir)/src/hello/libgnunethello.la \ 536 $(top_builddir)/src/hello/libgnunethello.la \
544 $(top_builddir)/src/util/libgnunetutil.la 537 $(top_builddir)/src/util/libgnunetutil.la
545 538
@@ -552,6 +545,7 @@ test_transport_api_multi_LDADD = \
552 $(top_builddir)/src/util/libgnunetutil.la 545 $(top_builddir)/src/util/libgnunetutil.la
553EXTRA_DIST = \ 546EXTRA_DIST = \
554 gnunet-transport-certificate-creation \ 547 gnunet-transport-certificate-creation \
548 ats_mlp_p100_m400.problem \
555 test_transport_api_data.conf \ 549 test_transport_api_data.conf \
556 test_transport_api_tcp_peer1.conf \ 550 test_transport_api_tcp_peer1.conf \
557 test_transport_api_tcp_peer2.conf \ 551 test_transport_api_tcp_peer2.conf \