aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authort3sserakt <t3ss@posteo.de>2022-10-04 14:28:51 +0200
committert3sserakt <t3ss@posteo.de>2022-10-05 13:23:32 +0200
commit247230d737e3e4709392148bfabbde25871b6914 (patch)
treec18f51cafb00b9436af050fffbc7d56d3f09bf95 /src/transport/Makefile.am
parentb47e578091e7451fd5c98cc56447d0fadba15b00 (diff)
downloadgnunet-247230d737e3e4709392148bfabbde25871b6914.tar.gz
gnunet-247230d737e3e4709392148bfabbde25871b6914.zip
- Added distance vector inverse path test case.
- Enhanced port forwarding configuration to restrict port forwarding to specific source IPs. - Add configuration for counting additional connections per peer. - Added caching for Core Messages, if confirmed virtual link is missing. - Added caching for DV forwarding, if confirmed virtual link is missing. - Fixed bug in fragmentation logic. - Fixed bug in queueing logic. - Fixed bug in flow control logic. - Fixed Bug with lifetime of DV learn message. (Validation against replay attack still missing) - removed make warnings - fixed coverty findings
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 2b09ccf63..773fa2877 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -780,8 +780,8 @@ check_SCRIPTS= \
780 test_transport_simple_send.sh \ 780 test_transport_simple_send.sh \
781 test_transport_simple_send_broadcast.sh \ 781 test_transport_simple_send_broadcast.sh \
782 test_transport_udp_backchannel.sh \ 782 test_transport_udp_backchannel.sh \
783 test_transport_simple_send_dv_circle.sh 783 test_transport_simple_send_dv_circle.sh \
784 # test_transport_simple_send_dv_inverse.sh 784 test_transport_simple_send_dv_inverse.sh
785endif 785endif
786 786
787test_transport_start_with_config_SOURCES = \ 787test_transport_start_with_config_SOURCES = \