aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2010-07-28 07:53:18 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2010-07-28 07:53:18 +0000
commit2b2f0a8c002b5c0946cccbdd6bf0012e4f1ad8e2 (patch)
tree8939077da05d4bd12107b9a0e68ce1ba33d5bc8c /src/transport/Makefile.am
parentce575f13f777800c042d9d6bb86fbee068247b5f (diff)
downloadgnunet-2b2f0a8c002b5c0946cccbdd6bf0012e4f1ad8e2.tar.gz
gnunet-2b2f0a8c002b5c0946cccbdd6bf0012e4f1ad8e2.zip
improved test order
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am32
1 files changed, 20 insertions, 12 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 8b6e91a57..3d637759a 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -9,14 +9,14 @@ endif
9if HAVE_MHD 9if HAVE_MHD
10 GN_LIBMHD = -lmicrohttpd 10 GN_LIBMHD = -lmicrohttpd
11 HTTP_PLUGIN_LA = libgnunet_plugin_transport_http.la 11 HTTP_PLUGIN_LA = libgnunet_plugin_transport_http.la
12 HTTP_PLUGIN_CHECK = test_plugin_transport_http \ 12 HTTP_PLUGIN_TEST = test_plugin_transport_http
13 test_transport_api_http \ 13 HTTP_API_TEST = test_transport_api_http
14 test_transport_api_reliability_http 14 HTTP_REL_TEST = test_transport_api_reliability_http
15 15
16 HTTPS_PLUGIN_LA = libgnunet_plugin_transport_https.la 16 HTTPS_PLUGIN_LA = libgnunet_plugin_transport_https.la
17 HTTPS_PLUGIN_CHECK = test_plugin_transport_https \ 17 HTTPS_PLUGIN_TEST = test_plugin_transport_https
18 test_transport_api_https \ 18 HTTPS_API_TEST = test_transport_api_https
19 test_transport_api_reliability_https 19 HTTPS_REL_TEST = test_transport_api_reliability_https
20endif 20endif
21 21
22if USE_COVERAGE 22if USE_COVERAGE
@@ -155,12 +155,16 @@ check_PROGRAMS = \
155 test_transport_api_tcp \ 155 test_transport_api_tcp \
156 test_transport_api_tcp_nat \ 156 test_transport_api_tcp_nat \
157 test_transport_api_udp \ 157 test_transport_api_udp \
158 $(HTTP_PLUGIN_CHECK) \
159 $(HTTPS_PLUGIN_CHECK) \
160 test_transport_api_udp_nat \ 158 test_transport_api_udp_nat \
159 $(HTTP_PLUGIN_TEST) \
160 $(HTTP_API_TEST) \
161 $(HTTPS_PLUGIN_TEST) \
162 $(HTTPS_API_TEST) \
161 test_transport_api_reliability_tcp \ 163 test_transport_api_reliability_tcp \
162 test_transport_api_reliability_tcp_nat \ 164 test_transport_api_reliability_tcp_nat \
163 test_transport_api_reliability_udp 165 test_transport_api_reliability_udp \
166 $(HTTP_REL_TEST) \
167 $(HTTPS_REL_TEST)
164# TODO: add tests for nat, etc. 168# TODO: add tests for nat, etc.
165 169
166TESTS = \ 170TESTS = \
@@ -168,10 +172,14 @@ TESTS = \
168 test_transport_api_tcp_nat \ 172 test_transport_api_tcp_nat \
169 test_transport_api_udp \ 173 test_transport_api_udp \
170 test_transport_api_udp_nat \ 174 test_transport_api_udp_nat \
171 $(HTTP_PLUGIN_CHECK) \ 175 $(HTTP_PLUGIN_TEST) \
172 $(HTTPS_PLUGIN_CHECK) \ 176 $(HTTP_API_TEST) \
177 $(HTTPS_PLUGIN_TEST) \
178 $(HTTPS_API_TEST) \
173 test_transport_api_reliability_tcp \ 179 test_transport_api_reliability_tcp \
174 test_transport_api_reliability_tcp_nat 180 test_transport_api_reliability_tcp_nat \
181 $(HTTP_REL_TEST) \
182 $(HTTPS_REL_TEST)
175 183
176test_transport_api_tcp_SOURCES = \ 184test_transport_api_tcp_SOURCES = \
177 test_transport_api.c 185 test_transport_api.c