aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorClaudiu Olteanu <claudiu@140774ce-b5e7-0310-ab8b-a85725594a96>2013-09-18 12:53:30 +0000
committerClaudiu Olteanu <claudiu@140774ce-b5e7-0310-ab8b-a85725594a96>2013-09-18 12:53:30 +0000
commit2b74f7a94df138bd6f732334033574bdc1727250 (patch)
treebd41e355d72445baee7df830665d38fe80c98987 /src/transport/Makefile.am
parentda43a590f1c47e9907a5b44b978999e043fd74ee (diff)
downloadgnunet-2b74f7a94df138bd6f732334033574bdc1727250.tar.gz
gnunet-2b74f7a94df138bd6f732334033574bdc1727250.zip
Adding W32 functionality
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 9bc58bf04..9e257f068 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -68,7 +68,17 @@ endif
68 68
69if LINUX 69if LINUX
70if HAVE_LIBBLUETOOTH 70if HAVE_LIBBLUETOOTH
71 AM_LDFLAGS = -lbluetooth 71 BT_BIN = gnunet-helper-transport-bluetooth
72 BT_PLUGIN_LA = libgnunet_plugin_transport_bluetooth.la
73 BT_PLUGIN_TEST = test_plugin_bluetooth
74 BT_API_TEST = test_transport_api_bluetooth
75 BT_REL_TEST = test_transport_api_reliability_bluetooth
76 BT_UREL_TEST = test_transport_api_unreliability_bluetooth
77 BT_QUOTA_TEST = test_quota_compliance_bluetooth \
78 test_quota_compliance_bluetooth_asymmetric
79endif
80else
81if MINGW
72 BT_BIN = gnunet-helper-transport-bluetooth 82 BT_BIN = gnunet-helper-transport-bluetooth
73 BT_PLUGIN_LA = libgnunet_plugin_transport_bluetooth.la 83 BT_PLUGIN_LA = libgnunet_plugin_transport_bluetooth.la
74 BT_PLUGIN_TEST = test_plugin_bluetooth 84 BT_PLUGIN_TEST = test_plugin_bluetooth
@@ -175,6 +185,13 @@ gnunet_transport_wlan_receiver_LDADD = \
175 185
176gnunet_helper_transport_bluetooth_SOURCES = \ 186gnunet_helper_transport_bluetooth_SOURCES = \
177 gnunet-helper-transport-bluetooth.c 187 gnunet-helper-transport-bluetooth.c
188if MINGW
189 gnunet_helper_transport_bluetooth_LDADD = \
190 $(top_builddir)/src/util/libgnunetutil.la
191 gnunet_helper_transport_bluetooth_LDFLAGS = -lws2_32
192else
193 gnunet_helper_transport_bluetooth_LDFLAGS = -lbluetooth
194endif
178 195
179gnunet_transport_SOURCES = \ 196gnunet_transport_SOURCES = \
180 gnunet-transport.c 197 gnunet-transport.c