aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2011-09-23 15:41:15 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2011-09-23 15:41:15 +0000
commit43abaee8bf73d3b4a40e458137f78b0461dcf1d9 (patch)
tree823f9fc7e7b5b5a58ec13bc768960411cdb941da /src/transport/Makefile.am
parenta223c4213e71ecf5a69bbdd39ba46c021b85047c (diff)
downloadgnunet-43abaee8bf73d3b4a40e458137f78b0461dcf1d9.tar.gz
gnunet-43abaee8bf73d3b4a40e458137f78b0461dcf1d9.zip
test case for udp and constant packet size
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 2ff0d8cec..a0a61924c 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -215,7 +215,7 @@ libgnunet_plugin_transport_unix_la_LDFLAGS = \
215 $(GN_PLUGIN_LDFLAGS) 215 $(GN_PLUGIN_LDFLAGS)
216 216
217libgnunet_plugin_transport_http_la_SOURCES = \ 217libgnunet_plugin_transport_http_la_SOURCES = \
218 plugin_transport_http.c 218 plugin_transport_http_new.c plugin_transport_http_client.c plugin_transport_http_server.c
219libgnunet_plugin_transport_http_la_LIBADD = \ 219libgnunet_plugin_transport_http_la_LIBADD = \
220 $(top_builddir)/src/hello/libgnunethello.la \ 220 $(top_builddir)/src/hello/libgnunethello.la \
221 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 221 $(top_builddir)/src/statistics/libgnunetstatistics.la \
@@ -232,7 +232,7 @@ libgnunet_plugin_transport_http_la_CPPFLAGS = \
232 @LIBCURL_CPPFLAGS@ 232 @LIBCURL_CPPFLAGS@
233 233
234libgnunet_plugin_transport_https_la_SOURCES = \ 234libgnunet_plugin_transport_https_la_SOURCES = \
235 plugin_transport_http.c 235 plugin_transport_http_new.c plugin_transport_http_client.c plugin_transport_http_server.c
236libgnunet_plugin_transport_https_la_LIBADD = \ 236libgnunet_plugin_transport_https_la_LIBADD = \
237 $(top_builddir)/src/hello/libgnunethello.la \ 237 $(top_builddir)/src/hello/libgnunethello.la \
238 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 238 $(top_builddir)/src/statistics/libgnunetstatistics.la \
@@ -268,6 +268,7 @@ check_PROGRAMS = \
268 test_transport_api_reliability_tcp \ 268 test_transport_api_reliability_tcp \
269 test_transport_api_reliability_tcp_nat \ 269 test_transport_api_reliability_tcp_nat \
270 test_transport_api_unreliability_udp \ 270 test_transport_api_unreliability_udp \
271 test_transport_api_unreliability_constant_udp \
271 $(UNIX_REL_TEST) \ 272 $(UNIX_REL_TEST) \
272 $(HTTP_REL_TEST) \ 273 $(HTTP_REL_TEST) \
273 $(HTTPS_REL_TEST) \ 274 $(HTTPS_REL_TEST) \
@@ -302,6 +303,7 @@ TESTS = \
302 test_transport_api_reliability_tcp \ 303 test_transport_api_reliability_tcp \
303 test_transport_api_reliability_tcp_nat \ 304 test_transport_api_reliability_tcp_nat \
304 test_transport_api_unreliability_udp \ 305 test_transport_api_unreliability_udp \
306 test_transport_api_unreliability_constant_udp \
305 $(UNIX_REL_TEST) \ 307 $(UNIX_REL_TEST) \
306 $(HTTP_REL_TEST) \ 308 $(HTTP_REL_TEST) \
307 $(HTTPS_REL_TEST) \ 309 $(HTTPS_REL_TEST) \
@@ -502,6 +504,13 @@ test_transport_api_unreliability_udp_LDADD = \
502 $(top_builddir)/src/util/libgnunetutil.la \ 504 $(top_builddir)/src/util/libgnunetutil.la \
503 $(top_builddir)/src/transport/libgnunettransporttesting.la 505 $(top_builddir)/src/transport/libgnunettransporttesting.la
504 506
507test_transport_api_unreliability_constant_udp_SOURCES = \
508 test_transport_api_unreliability_constant.c
509test_transport_api_unreliability_constant_udp_LDADD = \
510 $(top_builddir)/src/transport/libgnunettransport.la \
511 $(top_builddir)/src/hello/libgnunethello.la \
512 $(top_builddir)/src/util/libgnunetutil.la \
513 $(top_builddir)/src/transport/libgnunettransporttesting.la
505 514
506if LINUX 515if LINUX
507test_transport_api_wlan_SOURCES = \ 516test_transport_api_wlan_SOURCES = \