aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2010-07-25 13:58:38 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2010-07-25 13:58:38 +0000
commit49bb861ae2f02b2ba5af68cc6aaf13a135032420 (patch)
treec6b25fffd2ff4e9a06b3977d050993a00576f465 /src/transport/Makefile.am
parent12d1bb08b090ea81140656e3b10a0bc095c4b8e1 (diff)
downloadgnunet-49bb861ae2f02b2ba5af68cc6aaf13a135032420.tar.gz
gnunet-49bb861ae2f02b2ba5af68cc6aaf13a135032420.zip
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am29
1 files changed, 28 insertions, 1 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 2a62d0fb6..f4824ab70 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -12,6 +12,9 @@ if HAVE_MHD
12 HTTP_PLUGIN_CHECK = test_plugin_transport_http \ 12 HTTP_PLUGIN_CHECK = test_plugin_transport_http \
13 test_transport_api_http \ 13 test_transport_api_http \
14 test_transport_api_reliability_http 14 test_transport_api_reliability_http
15
16 HTTPS_PLUGIN_LA = libgnunet_plugin_transport_https.la
17 HTTPS_PLUGIN_CHECK = test_plugin_transport_https
15endif 18endif
16 19
17if USE_COVERAGE 20if USE_COVERAGE
@@ -76,6 +79,7 @@ plugin_LTLIBRARIES = \
76 libgnunet_plugin_transport_tcp.la \ 79 libgnunet_plugin_transport_tcp.la \
77 libgnunet_plugin_transport_udp.la \ 80 libgnunet_plugin_transport_udp.la \
78 $(HTTP_PLUGIN_LA) \ 81 $(HTTP_PLUGIN_LA) \
82 $(HTTPS_PLUGIN_LA) \
79 libgnunet_plugin_transport_template.la 83 libgnunet_plugin_transport_template.la
80# TODO: add nat, etc. 84# TODO: add nat, etc.
81 85
@@ -128,6 +132,18 @@ libgnunet_plugin_transport_http_la_LIBADD = \
128libgnunet_plugin_transport_http_la_LDFLAGS = \ 132libgnunet_plugin_transport_http_la_LDFLAGS = \
129 $(GN_LIBMHD) \ 133 $(GN_LIBMHD) \
130 $(GN_PLUGIN_LDFLAGS) 134 $(GN_PLUGIN_LDFLAGS)
135
136libgnunet_plugin_transport_https_la_SOURCES = \
137 plugin_transport_https.c
138libgnunet_plugin_transport_https_la_LIBADD = \
139 $(top_builddir)/src/hello/libgnunethello.la \
140 $(top_builddir)/src/statistics/libgnunetstatistics.la \
141 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
142 @LIBCURL@ \
143 $(top_builddir)/src/util/libgnunetutil.la
144libgnunet_plugin_transport_https_la_LDFLAGS = \
145 $(GN_LIBMHD) \
146 $(GN_PLUGIN_LDFLAGS)
131endif 147endif
132 148
133check_PROGRAMS = \ 149check_PROGRAMS = \
@@ -135,6 +151,7 @@ check_PROGRAMS = \
135 test_transport_api_tcp_nat \ 151 test_transport_api_tcp_nat \
136 test_transport_api_udp \ 152 test_transport_api_udp \
137 $(HTTP_PLUGIN_CHECK) \ 153 $(HTTP_PLUGIN_CHECK) \
154 $(HTTPS_PLUGIN_CHECK) \
138 test_transport_api_udp_nat \ 155 test_transport_api_udp_nat \
139 test_transport_api_reliability_tcp \ 156 test_transport_api_reliability_tcp \
140 test_transport_api_reliability_tcp_nat \ 157 test_transport_api_reliability_tcp_nat \
@@ -147,6 +164,7 @@ TESTS = \
147 test_transport_api_udp \ 164 test_transport_api_udp \
148 test_transport_api_udp_nat \ 165 test_transport_api_udp_nat \
149 $(HTTP_PLUGIN_CHECK) \ 166 $(HTTP_PLUGIN_CHECK) \
167 $(HTTPS_PLUGIN_CHECK) \
150 test_transport_api_reliability_tcp \ 168 test_transport_api_reliability_tcp \
151 test_transport_api_reliability_tcp_nat 169 test_transport_api_reliability_tcp_nat
152 170
@@ -211,7 +229,16 @@ test_transport_api_reliability_http_SOURCES = \
211 test_transport_api_reliability.c 229 test_transport_api_reliability.c
212test_transport_api_reliability_http_LDADD = \ 230test_transport_api_reliability_http_LDADD = \
213 $(top_builddir)/src/transport/libgnunettransport.la \ 231 $(top_builddir)/src/transport/libgnunettransport.la \
214 $(top_builddir)/src/util/libgnunetutil.la 232 $(top_builddir)/src/util/libgnunetutil.la
233
234test_plugin_transport_https_SOURCES = \
235 test_plugin_transport_https.c
236test_plugin_transport_https_LDADD = \
237 $(top_builddir)/src/transport/libgnunettransport.la \
238 $(top_builddir)/src/statistics/libgnunetstatistics.la \
239 @LIBCURL@ \
240 $(top_builddir)/src/util/libgnunetutil.la
241
215endif 242endif
216 243
217EXTRA_DIST = \ 244EXTRA_DIST = \