aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authormarshall <stmr@umich.edu>2023-07-18 12:34:50 -0400
committermarshall <stmr@umich.edu>2023-07-18 12:34:50 -0400
commit4a6e51e3fdec22f4ae368218d53da92524a09d47 (patch)
tree1b0b1994f15fd937605f5e1055459005c63f9bd4 /src/transport/Makefile.am
parentdeb73d21b1576bd9e18eba5674b6612f4cbe46e9 (diff)
downloadgnunet-4a6e51e3fdec22f4ae368218d53da92524a09d47.tar.gz
gnunet-4a6e51e3fdec22f4ae368218d53da92524a09d47.zip
transport: add experimental/quiche guards
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 4a2e185cf..ec036a4c6 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -219,9 +219,13 @@ libexec_PROGRAMS = \
219 gnunet-service-tng \ 219 gnunet-service-tng \
220 gnunet-communicator-unix \ 220 gnunet-communicator-unix \
221 gnunet-communicator-udp \ 221 gnunet-communicator-udp \
222 gnunet-communicator-tcp \ 222 gnunet-communicator-tcp
223if HAVE_EXPERIMENTAL
224if HAVE_QUICHE
225libexec_PROGRAMS += \
223 gnunet-communicator-quic 226 gnunet-communicator-quic
224 227endif
228endif
225 229
226 230
227bin_PROGRAMS = \ 231bin_PROGRAMS = \
@@ -270,6 +274,8 @@ gnunet_communicator_udp_LDADD = \
270 $(top_builddir)/src/util/libgnunetutil.la \ 274 $(top_builddir)/src/util/libgnunetutil.la \
271 $(LIBGCRYPT_LIBS) 275 $(LIBGCRYPT_LIBS)
272 276
277if HAVE_EXPERIMENTAL
278if HAVE_QUICHE
273gnunet_communicator_quic_SOURCES = \ 279gnunet_communicator_quic_SOURCES = \
274 gnunet-communicator-quic.c 280 gnunet-communicator-quic.c
275gnunet_communicator_quic_LDADD = \ 281gnunet_communicator_quic_LDADD = \
@@ -282,6 +288,8 @@ gnunet_communicator_quic_LDADD = \
282 $(top_builddir)/src/util/libgnunetutil.la \ 288 $(top_builddir)/src/util/libgnunetutil.la \
283 -lquiche \ 289 -lquiche \
284 $(LIBGCRYPT_LIBS) 290 $(LIBGCRYPT_LIBS)
291endif
292endif
285 293
286gnunet_helper_transport_wlan_SOURCES = \ 294gnunet_helper_transport_wlan_SOURCES = \
287 gnunet-helper-transport-wlan.c 295 gnunet-helper-transport-wlan.c