aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2011-07-19 11:59:34 +0000
committerChristian Grothoff <christian@grothoff.org>2011-07-19 11:59:34 +0000
commit50e7453045035b43f2a412e21f0cca2a5fd62b84 (patch)
treefd959ec45be58eae675437b1ed6eb97c6e328b68 /src/transport/Makefile.am
parent0e688ba4f7430b63acdac289077e406480498297 (diff)
downloadgnunet-50e7453045035b43f2a412e21f0cca2a5fd62b84.tar.gz
gnunet-50e7453045035b43f2a412e21f0cca2a5fd62b84.zip
run glpk code and tests only if gplk installed, fewer ifdefs
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am28
1 files changed, 13 insertions, 15 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 51f8447ee..4121206c7 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -21,6 +21,14 @@ endif
21 21
22if HAVE_LIBGLPK 22if HAVE_LIBGLPK
23 TRANSPORT_ATS_SRC = gnunet-service-transport_ats.c 23 TRANSPORT_ATS_SRC = gnunet-service-transport_ats.c
24 TEST_TRANSPORT_ATS = \
25 test_transport_ats \
26 test_transport_ats_multiple_peers
27 GN_GLPK = -lglpk
28if HAVE_BENCHMARKS
29 ATS_TRANSPORT_BENCHMARKS = \
30 perf_transport_ats
31endif
24endif 32endif
25 33
26if USE_COVERAGE 34if USE_COVERAGE
@@ -139,10 +147,6 @@ gnunet_transport_LDADD = \
139gnunet_transport_DEPENDENCIES = \ 147gnunet_transport_DEPENDENCIES = \
140 libgnunettransportnew.la 148 libgnunettransportnew.la
141 149
142if HAVE_LIBGLPK
143 GN_GLPK = -lglpk
144endif
145
146gnunet_service_transport_SOURCES = \ 150gnunet_service_transport_SOURCES = \
147 gnunet-service-transport.c $(TRANSPORT_ATS_SRC) 151 gnunet-service-transport.c $(TRANSPORT_ATS_SRC)
148gnunet_service_transport_LDADD = \ 152gnunet_service_transport_LDADD = \
@@ -246,15 +250,10 @@ libgnunet_plugin_transport_https_la_CFLAGS = \
246libgnunet_plugin_transport_https_la_CPPFLAGS = \ 250libgnunet_plugin_transport_https_la_CPPFLAGS = \
247 @LIBCURL_CPPFLAGS@ 251 @LIBCURL_CPPFLAGS@
248 252
249if HAVE_BENCHMARKS
250 TRANSPORT_BENCHMARKS = \
251 perf_transport_ats
252endif
253 253
254check_PROGRAMS = \ 254check_PROGRAMS = \
255 test_transport_ats \ 255 $(TEST_TRANSPORT_ATS) \
256 test_transport_ats_multiple_peers \ 256 $(ATS_TRANSPORT_BENCHMARKS) \
257 $(TRANSPORT_BENCHMARKS) \
258 test_transport_api_tcp \ 257 test_transport_api_tcp \
259 test_transport_api_tcp_nat \ 258 test_transport_api_tcp_nat \
260 test_transport_api_udp \ 259 test_transport_api_udp \
@@ -285,8 +284,7 @@ check_PROGRAMS = \
285 284
286if ENABLE_TEST_RUN 285if ENABLE_TEST_RUN
287TESTS = \ 286TESTS = \
288 test_transport_ats \ 287 $(TEST_TRANSPORT_ATS) \
289 test_transport_ats_multiple_peers \
290 perf_transport_ats \ 288 perf_transport_ats \
291 test_transport_api_tcp \ 289 test_transport_api_tcp \
292 test_transport_api_tcp_nat \ 290 test_transport_api_tcp_nat \
@@ -327,7 +325,7 @@ test_transport_ats_LDADD = -lm \
327 $(GN_GLPK) 325 $(GN_GLPK)
328 326
329test_transport_ats_multiple_peers_SOURCES = \ 327test_transport_ats_multiple_peers_SOURCES = \
330 test_transport_ats_multiple_peers.c 328 test_transport_ats_multiple_peers.c $(TRANSPORT_ATS_SRC)
331test_transport_ats_multiple_peers_LDADD = -lm \ 329test_transport_ats_multiple_peers_LDADD = -lm \
332 $(top_builddir)/src/transport/libgnunettransportnew.la \ 330 $(top_builddir)/src/transport/libgnunettransportnew.la \
333 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 331 $(top_builddir)/src/statistics/libgnunetstatistics.la \
@@ -337,7 +335,7 @@ test_transport_ats_multiple_peers_LDADD = -lm \
337perf_transport_ats_SOURCES = \ 335perf_transport_ats_SOURCES = \
338 perf_transport_ats.c 336 perf_transport_ats.c
339perf_transport_ats_LDADD = \ 337perf_transport_ats_LDADD = \
340 $(GN_GLPK) \ 338 -lglpk \
341 $(top_builddir)/src/util/libgnunetutil.la 339 $(top_builddir)/src/util/libgnunetutil.la
342 340
343test_transport_api_tcp_SOURCES = \ 341test_transport_api_tcp_SOURCES = \