aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2011-08-04 12:58:58 +0000
committerChristian Grothoff <christian@grothoff.org>2011-08-04 12:58:58 +0000
commit58cc7545c068d1deb7f7085822646313d5271b0f (patch)
tree771ba877b5a6f36e2e297de7c6c6adb17f0c8f9d /src/transport/Makefile.am
parent2b3767b6c7f244f55b9738da102f848eb19f984d (diff)
downloadgnunet-58cc7545c068d1deb7f7085822646313d5271b0f.tar.gz
gnunet-58cc7545c068d1deb7f7085822646313d5271b0f.zip
draft
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 6a870c6b0..e004d9c00 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -86,6 +86,7 @@ bin_PROGRAMS = \
86 gnunet-transport \ 86 gnunet-transport \
87 $(WLAN_BIN) \ 87 $(WLAN_BIN) \
88 gnunet-service-transport \ 88 gnunet-service-transport \
89 gnunet-service-transport-new \
89 gnunet-transport-list-connections \ 90 gnunet-transport-list-connections \
90 gnunet-transport-certificate-creation 91 gnunet-transport-certificate-creation
91 92
@@ -146,6 +147,22 @@ gnunet_service_transport_LDADD = \
146 $(GN_GLPK) \ 147 $(GN_GLPK) \
147 $(GN_LIBINTL) 148 $(GN_LIBINTL)
148 149
150gnunet_service_transport_new_SOURCES = \
151 gnunet-service-transport-new.c gnunet-service-transport.h \
152 gnunet-service-transport_blacklist.h \
153 gnunet-service-transport_clients.h \
154 gnunet-service-transport_hello.h \
155 gnunet-service-transport_neighbours.h \
156 gnunet-service-transport_plugins.h \
157 gnunet-service-transport_validation.h
158gnunet_service_transport_new_LDADD = \
159 $(top_builddir)/src/hello/libgnunethello.la \
160 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
161 $(top_builddir)/src/statistics/libgnunetstatistics.la \
162 $(top_builddir)/src/util/libgnunetutil.la \
163 $(GN_GLPK) \
164 $(GN_LIBINTL)
165
149plugin_LTLIBRARIES = \ 166plugin_LTLIBRARIES = \
150 libgnunet_plugin_transport_tcp.la \ 167 libgnunet_plugin_transport_tcp.la \
151 libgnunet_plugin_transport_udp.la \ 168 libgnunet_plugin_transport_udp.la \