aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2014-01-08 17:51:53 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2014-01-08 17:51:53 +0000
commit5f05330cb3d9ec30347c07522de00624de9d6c67 (patch)
tree213d4a9fdd07a2017c5768d609280fce4b6f146c /src/transport/Makefile.am
parentce8e0739623ee25d2a29a75f393027a42bbe4d4f (diff)
downloadgnunet-5f05330cb3d9ec30347c07522de00624de9d6c67.tar.gz
gnunet-5f05330cb3d9ec30347c07522de00624de9d6c67.zip
neighbour monitoring api implemented
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 9851a7907..2808dc5cb 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -405,6 +405,7 @@ check_PROGRAMS = \
405 $(BT_API_TEST) \ 405 $(BT_API_TEST) \
406 $(BT_TIMEOUT_TEST) \ 406 $(BT_TIMEOUT_TEST) \
407 test_transport_api_multi \ 407 test_transport_api_multi \
408 test_transport_api_monitoring \
408 test_transport_blacklisting_no_bl \ 409 test_transport_blacklisting_no_bl \
409 test_transport_blacklisting_outbound_bl_full \ 410 test_transport_blacklisting_outbound_bl_full \
410 test_transport_blacklisting_outbound_bl_plugin \ 411 test_transport_blacklisting_outbound_bl_plugin \
@@ -469,6 +470,7 @@ TESTS = \
469 $(BT_API_TEST) \ 470 $(BT_API_TEST) \
470 $(BT_TIMEOUT_TEST) \ 471 $(BT_TIMEOUT_TEST) \
471 test_transport_api_multi \ 472 test_transport_api_multi \
473 test_transport_api_monitoring \
472 test_transport_blacklisting_no_bl \ 474 test_transport_blacklisting_no_bl \
473 test_transport_blacklisting_outbound_bl_full \ 475 test_transport_blacklisting_outbound_bl_full \
474 test_transport_blacklisting_outbound_bl_plugin \ 476 test_transport_blacklisting_outbound_bl_plugin \
@@ -767,8 +769,6 @@ test_transport_api_manipulation_cfg_LDADD = \
767 $(top_builddir)/src/util/libgnunetutil.la \ 769 $(top_builddir)/src/util/libgnunetutil.la \
768 $(top_builddir)/src/transport/libgnunettransporttesting.la 770 $(top_builddir)/src/transport/libgnunettransporttesting.la
769 771
770
771
772test_transport_api_reliability_tcp_SOURCES = \ 772test_transport_api_reliability_tcp_SOURCES = \
773 test_transport_api_reliability.c 773 test_transport_api_reliability.c
774test_transport_api_reliability_tcp_LDADD = \ 774test_transport_api_reliability_tcp_LDADD = \
@@ -1099,6 +1099,15 @@ test_transport_api_multi_LDADD = \
1099 $(top_builddir)/src/transport/libgnunettransporttesting.la 1099 $(top_builddir)/src/transport/libgnunettransporttesting.la
1100 1100
1101 1101
1102test_transport_api_monitoring_SOURCES = \
1103 test_transport_api_monitoring.c
1104test_transport_api_monitoring_LDADD = \
1105 $(top_builddir)/src/transport/libgnunettransport.la \
1106 $(top_builddir)/src/hello/libgnunethello.la \
1107 $(top_builddir)/src/util/libgnunetutil.la \
1108 $(top_builddir)/src/transport/libgnunettransporttesting.la
1109
1110
1102EXTRA_DIST = \ 1111EXTRA_DIST = \
1103test_plugin_hostkey \ 1112test_plugin_hostkey \
1104test_plugin_hostkey.ecc \ 1113test_plugin_hostkey.ecc \