aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2011-08-06 20:43:50 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2011-08-06 20:43:50 +0000
commit6ad7a1bffd1688f8ee1ecb37eacb3a55f671748c (patch)
tree0035690827086b06505e297aa4795fa5f0429608 /src/transport/Makefile.am
parent372124795880b0d925ee04d11b38f64a49c6ed94 (diff)
downloadgnunet-6ad7a1bffd1688f8ee1ecb37eacb3a55f671748c.tar.gz
gnunet-6ad7a1bffd1688f8ee1ecb37eacb3a55f671748c.zip
plane hacking
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 63edcb15a..74f79013e 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -66,7 +66,11 @@ noinst_PROGRAMS = $(WLAN_BIN_DUMMY)
66 66
67 67
68lib_LTLIBRARIES = \ 68lib_LTLIBRARIES = \
69 libgnunettransport.la 69 libgnunettransport.la \
70 libgnunettransporttesting.la
71
72libgnunettransporttesting_la_SOURCES = \
73 transport-testing.c
70 74
71libgnunettransport_la_SOURCES = \ 75libgnunettransport_la_SOURCES = \
72 transport_api.c transport.h \ 76 transport_api.c transport.h \
@@ -259,6 +263,7 @@ libgnunet_plugin_transport_https_la_CPPFLAGS = \
259 263
260 264
261check_PROGRAMS = \ 265check_PROGRAMS = \
266 test_transport_api_disconnect \
262 $(TEST_TRANSPORT_ATS) \ 267 $(TEST_TRANSPORT_ATS) \
263 $(ATS_TRANSPORT_BENCHMARKS) \ 268 $(ATS_TRANSPORT_BENCHMARKS) \
264 test_transport_api_tcp \ 269 test_transport_api_tcp \
@@ -291,6 +296,7 @@ check_PROGRAMS = \
291 296
292if ENABLE_TEST_RUN 297if ENABLE_TEST_RUN
293TESTS = \ 298TESTS = \
299 test_transport_api_disconnect \
294 $(TEST_TRANSPORT_ATS) \ 300 $(TEST_TRANSPORT_ATS) \
295 $(ATS_TRANSPORT_BENCHMARKS) \ 301 $(ATS_TRANSPORT_BENCHMARKS) \
296 test_transport_api_tcp \ 302 test_transport_api_tcp \
@@ -322,6 +328,16 @@ TESTS = \
322 $(WLAN_UREL_TEST) 328 $(WLAN_UREL_TEST)
323endif 329endif
324 330
331
332test_transport_api_disconnect_SOURCES = \
333 test_transport_api_disconnect.c
334test_transport_api_disconnect_LDADD = \
335 $(top_builddir)/src/transport/libgnunettransport.la \
336 $(top_builddir)/src/statistics/libgnunetstatistics.la \
337 $(top_builddir)/src/testing/libgnunettesting.la \
338 $(top_builddir)/src/util/libgnunetutil.la
339
340
325test_transport_ats_SOURCES = \ 341test_transport_ats_SOURCES = \
326 test_transport_ats.c $(TRANSPORT_ATS_SRC) 342 test_transport_ats.c $(TRANSPORT_ATS_SRC)
327test_transport_ats_LDADD = -lm \ 343test_transport_ats_LDADD = -lm \