aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authort3sserakt <t3ss@posteo.de>2023-10-03 17:17:16 +0200
committert3sserakt <t3ss@posteo.de>2023-10-03 17:17:16 +0200
commit6f68c34aa3deed8e1b5df30d3de1342386523920 (patch)
tree940221996f82d1edd77530ac2b1abbb61ccf08ac /src/transport/Makefile.am
parented76bf2ece671e9543477a9bb9130dfbe5fa5a4d (diff)
parent109f3188ba65b788990427d6d26ba8874a9b84f5 (diff)
downloadgnunet-6f68c34aa3deed8e1b5df30d3de1342386523920.tar.gz
gnunet-6f68c34aa3deed8e1b5df30d3de1342386523920.zip
Merge branch 'master' into l20integration
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am33
1 files changed, 32 insertions, 1 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 5b51f3edd..d7d25b7b0 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -220,7 +220,12 @@ libexec_PROGRAMS = \
220 gnunet-communicator-unix \ 220 gnunet-communicator-unix \
221 gnunet-communicator-udp \ 221 gnunet-communicator-udp \
222 gnunet-communicator-tcp 222 gnunet-communicator-tcp
223 223if HAVE_EXPERIMENTAL
224if HAVE_QUICHE
225libexec_PROGRAMS += \
226 gnunet-communicator-quic
227endif
228endif
224 229
225 230
226bin_PROGRAMS = \ 231bin_PROGRAMS = \
@@ -269,6 +274,22 @@ gnunet_communicator_udp_LDADD = \
269 $(top_builddir)/src/util/libgnunetutil.la \ 274 $(top_builddir)/src/util/libgnunetutil.la \
270 $(LIBGCRYPT_LIBS) 275 $(LIBGCRYPT_LIBS)
271 276
277if HAVE_EXPERIMENTAL
278if HAVE_QUICHE
279gnunet_communicator_quic_SOURCES = \
280 gnunet-communicator-quic.c
281gnunet_communicator_quic_LDADD = \
282 libgnunettransportapplication.la \
283 libgnunettransportcommunicator.la \
284 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
285 $(top_builddir)/src/nat/libgnunetnatnew.la \
286 $(top_builddir)/src/nt/libgnunetnt.la \
287 $(top_builddir)/src/statistics/libgnunetstatistics.la \
288 $(top_builddir)/src/util/libgnunetutil.la \
289 -lquiche \
290 $(LIBGCRYPT_LIBS)
291endif
292endif
272 293
273gnunet_helper_transport_wlan_SOURCES = \ 294gnunet_helper_transport_wlan_SOURCES = \
274 gnunet-helper-transport-wlan.c 295 gnunet-helper-transport-wlan.c
@@ -690,6 +711,7 @@ check_PROGRAMS += \
690 test_communicator_basic-unix \ 711 test_communicator_basic-unix \
691 test_communicator_basic-tcp \ 712 test_communicator_basic-tcp \
692 test_communicator_basic-udp \ 713 test_communicator_basic-udp \
714 test_communicator_basic-quic \
693 test_communicator_rekey-tcp \ 715 test_communicator_rekey-tcp \
694 test_communicator_rekey-udp \ 716 test_communicator_rekey-udp \
695 test_communicator_backchannel-udp \ 717 test_communicator_backchannel-udp \
@@ -768,6 +790,7 @@ TESTS += \
768 test_quota_compliance_udp \ 790 test_quota_compliance_udp \
769 test_communicator_basic-unix \ 791 test_communicator_basic-unix \
770 test_communicator_basic-tcp \ 792 test_communicator_basic-tcp \
793 test_communicator_basic-quic \
771 test_communicator_basic-udp \ 794 test_communicator_basic-udp \
772 test_communicator_rekey-tcp \ 795 test_communicator_rekey-tcp \
773 test_communicator_rekey-udp \ 796 test_communicator_rekey-udp \
@@ -934,6 +957,14 @@ test_communicator_basic_udp_LDADD = \
934 $(top_builddir)/src/util/libgnunetutil.la \ 957 $(top_builddir)/src/util/libgnunetutil.la \
935 $(top_builddir)/src/statistics/libgnunetstatistics.la 958 $(top_builddir)/src/statistics/libgnunetstatistics.la
936 959
960test_communicator_basic_quic_SOURCES = \
961 test_communicator_basic.c
962test_communicator_basic_quic_LDADD = \
963 libgnunettransporttesting2.la \
964 $(top_builddir)/src/testing/libgnunettesting.la \
965 $(top_builddir)/src/util/libgnunetutil.la \
966 $(top_builddir)/src/statistics/libgnunetstatistics.la
967
937test_communicator_rekey_tcp_SOURCES = \ 968test_communicator_rekey_tcp_SOURCES = \
938 test_communicator_basic.c 969 test_communicator_basic.c
939test_communicator_rekey_tcp_LDADD = \ 970test_communicator_rekey_tcp_LDADD = \