aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2014-09-04 12:49:32 +0000
committerChristian Grothoff <christian@grothoff.org>2014-09-04 12:49:32 +0000
commit83995cf89e0515b46d65badd09b641c988a5ea9d (patch)
tree40933754d17c45b1d6592a8842a647a46b57b834 /src/transport/Makefile.am
parent3e36950d8d3f6319544b9d627156c70eaaf9bdaf (diff)
downloadgnunet-83995cf89e0515b46d65badd09b641c988a5ea9d.tar.gz
gnunet-83995cf89e0515b46d65badd09b641c988a5ea9d.zip
address Debian #758937: allow use of curl if it is really the gnutls version and libgnurl is unavailable
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am37
1 files changed, 33 insertions, 4 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index d4a1001c9..dd7bedbae 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -23,6 +23,17 @@ if HAVE_LIBGNURL
23 HTTPS_CLIENT_PLUGIN_TEST = test_plugin_https_client 23 HTTPS_CLIENT_PLUGIN_TEST = test_plugin_https_client
24 HTTP_CLIENT_PLUGIN_LA = libgnunet_plugin_transport_http_client.la 24 HTTP_CLIENT_PLUGIN_LA = libgnunet_plugin_transport_http_client.la
25 HTTPS_CLIENT_PLUGIN_LA = libgnunet_plugin_transport_https_client.la 25 HTTPS_CLIENT_PLUGIN_LA = libgnunet_plugin_transport_https_client.la
26LIB_GNURL=@LIBGNURL@
27CPP_GNURL=@LIBGNURL_CPPFLAGS@
28else
29if HAVE_LIBCURL
30 HTTP_CLIENT_PLUGIN_TEST = test_plugin_http_client
31 HTTPS_CLIENT_PLUGIN_TEST = test_plugin_https_client
32 HTTP_CLIENT_PLUGIN_LA = libgnunet_plugin_transport_http_client.la
33 HTTPS_CLIENT_PLUGIN_LA = libgnunet_plugin_transport_https_client.la
34LIB_GNURL=@LIBCURL@
35CPP_GNURL=@LIBCURL_CPPFLAGS@
36endif
26endif 37endif
27 38
28if HAVE_MHD 39if HAVE_MHD
@@ -42,6 +53,24 @@ if HAVE_LIBGNURL
42 HTTPS_QUOTA_TEST = test_quota_compliance_https \ 53 HTTPS_QUOTA_TEST = test_quota_compliance_https \
43 test_quota_compliance_https_asymmetric 54 test_quota_compliance_https_asymmetric
44 HTTPS_SWITCH = test_transport_address_switch_https 55 HTTPS_SWITCH = test_transport_address_switch_https
56else
57if HAVE_LIBCURL
58 HTTP_API_TEST = test_transport_api_http
59 HTTP_REVERSE_API_TEST = test_transport_api_http_reverse
60 HTTP_API_TIMEOUT_TEST = test_transport_api_timeout_http
61 HTTP_REL_TEST = test_transport_api_reliability_http \
62 test_transport_api_reliability_http_xhr
63 HTTP_QUOTA_TEST = test_quota_compliance_http \
64 test_quota_compliance_http_asymmetric
65 HTTP_SWITCH = test_transport_address_switch_http
66 HTTPS_API_TEST = test_transport_api_https
67 HTTPS_API_TIMEOUT_TEST = test_transport_api_timeout_https
68 HTTPS_REL_TEST = test_transport_api_reliability_https \
69 test_transport_api_reliability_https_xhr
70 HTTPS_QUOTA_TEST = test_quota_compliance_https \
71 test_quota_compliance_https_asymmetric
72 HTTPS_SWITCH = test_transport_address_switch_https
73endif
45endif 74endif
46endif 75endif
47 76
@@ -334,7 +363,7 @@ libgnunet_plugin_transport_http_client_la_LIBADD = \
334 $(top_builddir)/src/hello/libgnunethello.la \ 363 $(top_builddir)/src/hello/libgnunethello.la \
335 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 364 $(top_builddir)/src/statistics/libgnunetstatistics.la \
336 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \ 365 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
337 @LIBGNURL@ \ 366 $(LIB_GNURL) \
338 $(top_builddir)/src/nat/libgnunetnat.la \ 367 $(top_builddir)/src/nat/libgnunetnat.la \
339 $(top_builddir)/src/util/libgnunetutil.la 368 $(top_builddir)/src/util/libgnunetutil.la
340libgnunet_plugin_transport_http_client_la_LDFLAGS = \ 369libgnunet_plugin_transport_http_client_la_LDFLAGS = \
@@ -342,7 +371,7 @@ libgnunet_plugin_transport_http_client_la_LDFLAGS = \
342libgnunet_plugin_transport_http_client_la_CFLAGS = \ 371libgnunet_plugin_transport_http_client_la_CFLAGS = \
343 $(CFLAGS) 372 $(CFLAGS)
344libgnunet_plugin_transport_http_client_la_CPPFLAGS = \ 373libgnunet_plugin_transport_http_client_la_CPPFLAGS = \
345 @LIBGNURL_CPPFLAGS@ $(AM_CPPFLAGS) 374 $(CPP_GNURL) $(AM_CPPFLAGS)
346 375
347 376
348libgnunet_plugin_transport_http_server_la_SOURCES = \ 377libgnunet_plugin_transport_http_server_la_SOURCES = \
@@ -365,7 +394,7 @@ libgnunet_plugin_transport_https_client_la_LIBADD = \
365 $(top_builddir)/src/hello/libgnunethello.la \ 394 $(top_builddir)/src/hello/libgnunethello.la \
366 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 395 $(top_builddir)/src/statistics/libgnunetstatistics.la \
367 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \ 396 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
368 @LIBGNURL@ \ 397 $(LIB_GNURL) \
369 $(top_builddir)/src/nat/libgnunetnat.la \ 398 $(top_builddir)/src/nat/libgnunetnat.la \
370 $(top_builddir)/src/util/libgnunetutil.la 399 $(top_builddir)/src/util/libgnunetutil.la
371libgnunet_plugin_transport_https_client_la_LDFLAGS = \ 400libgnunet_plugin_transport_https_client_la_LDFLAGS = \
@@ -373,7 +402,7 @@ libgnunet_plugin_transport_https_client_la_LDFLAGS = \
373libgnunet_plugin_transport_https_client_la_CFLAGS = \ 402libgnunet_plugin_transport_https_client_la_CFLAGS = \
374 $(CFLAGS) -DBUILD_HTTPS 403 $(CFLAGS) -DBUILD_HTTPS
375libgnunet_plugin_transport_https_client_la_CPPFLAGS = \ 404libgnunet_plugin_transport_https_client_la_CPPFLAGS = \
376 @LIBGNURL_CPPFLAGS@ $(AM_CPPFLAGS) 405 $(CPP_GNURL) $(AM_CPPFLAGS)
377 406
378 407
379libgnunet_plugin_transport_https_server_la_SOURCES = \ 408libgnunet_plugin_transport_https_server_la_SOURCES = \