aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2011-08-12 07:03:34 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2011-08-12 07:03:34 +0000
commitb19fa751b866bb6855ed92beb2bee30917f868c8 (patch)
tree76f0433e011d834a672d10d285369b9b7f1fb17e /src/transport/Makefile.am
parent5434646c91cc203f4113018503b06ada292060d4 (diff)
downloadgnunet-b19fa751b866bb6855ed92beb2bee30917f868c8.tar.gz
gnunet-b19fa751b866bb6855ed92beb2bee30917f868c8.zip
test_transport_api ported to use new testing lib
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am62
1 files changed, 42 insertions, 20 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 5fe5aa32f..a1a6ed73c 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -335,6 +335,7 @@ test_transport_testing_SOURCES = \
335 test_transport_testing.c 335 test_transport_testing.c
336test_transport_testing_LDADD = \ 336test_transport_testing_LDADD = \
337 $(top_builddir)/src/transport/libgnunettransport.la \ 337 $(top_builddir)/src/transport/libgnunettransport.la \
338 $(top_builddir)/src/hello/libgnunethello.la \
338 $(top_builddir)/src/transport/libgnunettransporttesting.la 339 $(top_builddir)/src/transport/libgnunettransporttesting.la
339 340
340test_transport_api_disconnect_SOURCES = \ 341test_transport_api_disconnect_SOURCES = \
@@ -376,70 +377,81 @@ test_transport_api_tcp_SOURCES = \
376test_transport_api_tcp_LDADD = \ 377test_transport_api_tcp_LDADD = \
377 $(top_builddir)/src/transport/libgnunettransport.la \ 378 $(top_builddir)/src/transport/libgnunettransport.la \
378 $(top_builddir)/src/hello/libgnunethello.la \ 379 $(top_builddir)/src/hello/libgnunethello.la \
379 $(top_builddir)/src/util/libgnunetutil.la 380 $(top_builddir)/src/util/libgnunetutil.la \
381 $(top_builddir)/src/transport/libgnunettransporttesting.la
380 382
381test_transport_api_tcp_nat_SOURCES = \ 383test_transport_api_tcp_nat_SOURCES = \
382 test_transport_api.c 384 test_transport_api.c
383test_transport_api_tcp_nat_LDADD = \ 385test_transport_api_tcp_nat_LDADD = \
384 $(top_builddir)/src/transport/libgnunettransport.la \ 386 $(top_builddir)/src/transport/libgnunettransport.la \
385 $(top_builddir)/src/hello/libgnunethello.la \ 387 $(top_builddir)/src/hello/libgnunethello.la \
386 $(top_builddir)/src/util/libgnunetutil.la 388 $(top_builddir)/src/util/libgnunetutil.la \
389 $(top_builddir)/src/transport/libgnunettransporttesting.la
387 390
388test_transport_api_reliability_tcp_SOURCES = \ 391test_transport_api_reliability_tcp_SOURCES = \
389 test_transport_api_reliability.c 392 test_transport_api_reliability.c
390test_transport_api_reliability_tcp_LDADD = \ 393test_transport_api_reliability_tcp_LDADD = \
391 $(top_builddir)/src/transport/libgnunettransport.la \ 394 $(top_builddir)/src/transport/libgnunettransport.la \
392 $(top_builddir)/src/hello/libgnunethello.la \ 395 $(top_builddir)/src/hello/libgnunethello.la \
393 $(top_builddir)/src/util/libgnunetutil.la 396 $(top_builddir)/src/util/libgnunetutil.la \
397 $(top_builddir)/src/transport/libgnunettransporttesting.la
398
394 399
395test_transport_api_multiaddress_tcp_SOURCES = \ 400test_transport_api_multiaddress_tcp_SOURCES = \
396 test_transport_api_multiaddress.c 401 test_transport_api_multiaddress.c
397test_transport_api_multiaddress_tcp_LDADD = \ 402test_transport_api_multiaddress_tcp_LDADD = \
398 $(top_builddir)/src/transport/libgnunettransport.la \ 403 $(top_builddir)/src/transport/libgnunettransport.la \
399 $(top_builddir)/src/hello/libgnunethello.la \ 404 $(top_builddir)/src/hello/libgnunethello.la \
400 $(top_builddir)/src/util/libgnunetutil.la 405 $(top_builddir)/src/util/libgnunetutil.la \
406 $(top_builddir)/src/transport/libgnunettransporttesting.la
401 407
402test_transport_api_reliability_tcp_nat_SOURCES = \ 408test_transport_api_reliability_tcp_nat_SOURCES = \
403 test_transport_api_reliability.c 409 test_transport_api_reliability.c
404test_transport_api_reliability_tcp_nat_LDADD = \ 410test_transport_api_reliability_tcp_nat_LDADD = \
405 $(top_builddir)/src/transport/libgnunettransport.la \ 411 $(top_builddir)/src/transport/libgnunettransport.la \
406 $(top_builddir)/src/hello/libgnunethello.la \ 412 $(top_builddir)/src/hello/libgnunethello.la \
407 $(top_builddir)/src/util/libgnunetutil.la 413 $(top_builddir)/src/util/libgnunetutil.la \
414 $(top_builddir)/src/transport/libgnunettransporttesting.la
408 415
409test_transport_api_reliability_wlan_SOURCES = \ 416test_transport_api_reliability_wlan_SOURCES = \
410 test_transport_api_reliability.c 417 test_transport_api_reliability.c
411test_transport_api_reliability_wlan_LDADD = \ 418test_transport_api_reliability_wlan_LDADD = \
412 $(top_builddir)/src/transport/libgnunettransport.la \ 419 $(top_builddir)/src/transport/libgnunettransport.la \
413 $(top_builddir)/src/hello/libgnunethello.la \ 420 $(top_builddir)/src/hello/libgnunethello.la \
414 $(top_builddir)/src/util/libgnunetutil.la 421 $(top_builddir)/src/util/libgnunetutil.la \
422 $(top_builddir)/src/transport/libgnunettransporttesting.la
415 423
416test_transport_api_unreliability_wlan_SOURCES = \ 424test_transport_api_unreliability_wlan_SOURCES = \
417 test_transport_api_unreliability.c 425 test_transport_api_unreliability.c
418test_transport_api_unreliability_wlan_LDADD = \ 426test_transport_api_unreliability_wlan_LDADD = \
419 $(top_builddir)/src/transport/libgnunettransport.la \ 427 $(top_builddir)/src/transport/libgnunettransport.la \
420 $(top_builddir)/src/hello/libgnunethello.la \ 428 $(top_builddir)/src/hello/libgnunethello.la \
421 $(top_builddir)/src/util/libgnunetutil.la 429 $(top_builddir)/src/util/libgnunetutil.la \
422 430 $(top_builddir)/src/transport/libgnunettransporttesting.la
431
423test_transport_api_udp_SOURCES = \ 432test_transport_api_udp_SOURCES = \
424 test_transport_api.c 433 test_transport_api.c
425test_transport_api_udp_LDADD = \ 434test_transport_api_udp_LDADD = \
426 $(top_builddir)/src/transport/libgnunettransport.la \ 435 $(top_builddir)/src/transport/libgnunettransport.la \
427 $(top_builddir)/src/hello/libgnunethello.la \ 436 $(top_builddir)/src/hello/libgnunethello.la \
428 $(top_builddir)/src/util/libgnunetutil.la 437 $(top_builddir)/src/util/libgnunetutil.la \
438 $(top_builddir)/src/transport/libgnunettransporttesting.la
429 439
430test_transport_api_udp_nat_SOURCES = \ 440test_transport_api_udp_nat_SOURCES = \
431 test_transport_api.c 441 test_transport_api.c
432test_transport_api_udp_nat_LDADD = \ 442test_transport_api_udp_nat_LDADD = \
433 $(top_builddir)/src/transport/libgnunettransport.la \ 443 $(top_builddir)/src/transport/libgnunettransport.la \
434 $(top_builddir)/src/hello/libgnunethello.la \ 444 $(top_builddir)/src/hello/libgnunethello.la \
435 $(top_builddir)/src/util/libgnunetutil.la 445 $(top_builddir)/src/util/libgnunetutil.la \
446 $(top_builddir)/src/transport/libgnunettransporttesting.la
436 447
437test_transport_api_unix_SOURCES = \ 448test_transport_api_unix_SOURCES = \
438 test_transport_api.c 449 test_transport_api.c
439test_transport_api_unix_LDADD = \ 450test_transport_api_unix_LDADD = \
440 $(top_builddir)/src/transport/libgnunettransport.la \ 451 $(top_builddir)/src/transport/libgnunettransport.la \
441 $(top_builddir)/src/hello/libgnunethello.la \ 452 $(top_builddir)/src/hello/libgnunethello.la \
442 $(top_builddir)/src/util/libgnunetutil.la 453 $(top_builddir)/src/util/libgnunetutil.la \
454 $(top_builddir)/src/transport/libgnunettransporttesting.la
443 455
444#test_plugin_transport_http_SOURCES = \ 456#test_plugin_transport_http_SOURCES = \
445# test_plugin_transport_http.c 457# test_plugin_transport_http.c
@@ -454,15 +466,17 @@ test_transport_api_http_SOURCES = \
454test_transport_api_http_LDADD = \ 466test_transport_api_http_LDADD = \
455 $(top_builddir)/src/transport/libgnunettransport.la \ 467 $(top_builddir)/src/transport/libgnunettransport.la \
456 $(top_builddir)/src/hello/libgnunethello.la \ 468 $(top_builddir)/src/hello/libgnunethello.la \
457 $(top_builddir)/src/util/libgnunetutil.la 469 $(top_builddir)/src/util/libgnunetutil.la \
458 470 $(top_builddir)/src/transport/libgnunettransporttesting.la
471
459test_transport_api_reliability_http_SOURCES = \ 472test_transport_api_reliability_http_SOURCES = \
460 test_transport_api_reliability.c 473 test_transport_api_reliability.c
461test_transport_api_reliability_http_LDADD = \ 474test_transport_api_reliability_http_LDADD = \
462 $(top_builddir)/src/transport/libgnunettransport.la \ 475 $(top_builddir)/src/transport/libgnunettransport.la \
463 $(top_builddir)/src/hello/libgnunethello.la \ 476 $(top_builddir)/src/hello/libgnunethello.la \
464 $(top_builddir)/src/util/libgnunetutil.la 477 $(top_builddir)/src/util/libgnunetutil.la \
465 478 $(top_builddir)/src/transport/libgnunettransporttesting.la
479
466#test_plugin_transport_https_SOURCES = \ 480#test_plugin_transport_https_SOURCES = \
467# test_plugin_transport_https.c 481# test_plugin_transport_https.c
468#test_plugin_transport_https_LDADD = \ 482#test_plugin_transport_https_LDADD = \
@@ -476,28 +490,33 @@ test_transport_api_https_SOURCES = \
476test_transport_api_https_LDADD = \ 490test_transport_api_https_LDADD = \
477 $(top_builddir)/src/transport/libgnunettransport.la \ 491 $(top_builddir)/src/transport/libgnunettransport.la \
478 $(top_builddir)/src/hello/libgnunethello.la \ 492 $(top_builddir)/src/hello/libgnunethello.la \
479 $(top_builddir)/src/util/libgnunetutil.la 493 $(top_builddir)/src/util/libgnunetutil.la \
494 $(top_builddir)/src/transport/libgnunettransporttesting.la
480 495
481test_transport_api_reliability_https_SOURCES = \ 496test_transport_api_reliability_https_SOURCES = \
482 test_transport_api_reliability.c 497 test_transport_api_reliability.c
483test_transport_api_reliability_https_LDADD = \ 498test_transport_api_reliability_https_LDADD = \
484 $(top_builddir)/src/transport/libgnunettransport.la \ 499 $(top_builddir)/src/transport/libgnunettransport.la \
485 $(top_builddir)/src/hello/libgnunethello.la \ 500 $(top_builddir)/src/hello/libgnunethello.la \
486 $(top_builddir)/src/util/libgnunetutil.la 501 $(top_builddir)/src/util/libgnunetutil.la \
502 $(top_builddir)/src/transport/libgnunettransporttesting.la
487 503
488test_transport_api_unreliability_unix_SOURCES = \ 504test_transport_api_unreliability_unix_SOURCES = \
489 test_transport_api_unreliability.c 505 test_transport_api_unreliability.c
490test_transport_api_unreliability_unix_LDADD = \ 506test_transport_api_unreliability_unix_LDADD = \
491 $(top_builddir)/src/transport/libgnunettransport.la \ 507 $(top_builddir)/src/transport/libgnunettransport.la \
492 $(top_builddir)/src/hello/libgnunethello.la \ 508 $(top_builddir)/src/hello/libgnunethello.la \
493 $(top_builddir)/src/util/libgnunetutil.la 509 $(top_builddir)/src/util/libgnunetutil.la \
510 $(top_builddir)/src/transport/libgnunettransporttesting.la
494 511
495test_transport_api_unreliability_udp_SOURCES = \ 512test_transport_api_unreliability_udp_SOURCES = \
496 test_transport_api_unreliability.c 513 test_transport_api_unreliability.c
497test_transport_api_unreliability_udp_LDADD = \ 514test_transport_api_unreliability_udp_LDADD = \
498 $(top_builddir)/src/transport/libgnunettransport.la \ 515 $(top_builddir)/src/transport/libgnunettransport.la \
499 $(top_builddir)/src/hello/libgnunethello.la \ 516 $(top_builddir)/src/hello/libgnunethello.la \
500 $(top_builddir)/src/util/libgnunetutil.la 517 $(top_builddir)/src/util/libgnunetutil.la \
518 $(top_builddir)/src/transport/libgnunettransporttesting.la
519
501 520
502if LINUX 521if LINUX
503test_transport_api_wlan_SOURCES = \ 522test_transport_api_wlan_SOURCES = \
@@ -608,7 +627,10 @@ test_transport_api_multi_SOURCES = \
608test_transport_api_multi_LDADD = \ 627test_transport_api_multi_LDADD = \
609 $(top_builddir)/src/transport/libgnunettransport.la \ 628 $(top_builddir)/src/transport/libgnunettransport.la \
610 $(top_builddir)/src/hello/libgnunethello.la \ 629 $(top_builddir)/src/hello/libgnunethello.la \
611 $(top_builddir)/src/util/libgnunetutil.la 630 $(top_builddir)/src/util/libgnunetutil.la \
631 $(top_builddir)/src/transport/libgnunettransporttesting.la
632
633
612EXTRA_DIST = \ 634EXTRA_DIST = \
613 gnunet-transport-certificate-creation \ 635 gnunet-transport-certificate-creation \
614 ats_mlp_p100_m400.problem \ 636 ats_mlp_p100_m400.problem \