aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2011-11-05 09:06:32 +0000
committerChristian Grothoff <christian@grothoff.org>2011-11-05 09:06:32 +0000
commitb8fb774718de49d5a96e6cfa5b38a42b9f3f0e6a (patch)
tree3f1cdfbb5aecf88ab5fe27af29b81202241934b2 /src/transport/Makefile.am
parent0bae85f2b4fe6e55a3f5164066afe64cf499432b (diff)
downloadgnunet-b8fb774718de49d5a96e6cfa5b38a42b9f3f0e6a.tar.gz
gnunet-b8fb774718de49d5a96e6cfa5b38a42b9f3f0e6a.zip
LRN: Add '-Wl,' prefix to -no-undefined
-no-undefined is not a valid compiler option as of GCC 4.6.x (it IS valid linker option). Note that this REQUIRES an extra -no-undefined to be passed to libtool (this is done by GN_LIB_LDLFAGS and GN_PLUGIN_LDFLAGS), because libtool does not understand -Wl,-no-undefined.
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index e5230410c..7beaf584d 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -77,6 +77,8 @@ libgnunettransporttesting_la_LIBADD = \
77 $(GN_LIBINTL) 77 $(GN_LIBINTL)
78libgnunettransporttesting_la_DEPENDENCIES = \ 78libgnunettransporttesting_la_DEPENDENCIES = \
79 libgnunettransport.la 79 libgnunettransport.la
80libgnunettransporttesting_la_LDFLAGS = \
81 $(GN_LIB_LDFLAGS)
80 82
81libgnunettransport_la_SOURCES = \ 83libgnunettransport_la_SOURCES = \
82 transport_api.c transport.h \ 84 transport_api.c transport.h \