aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authort3sserakt <t3ss@posteo.de>2021-10-07 13:07:30 +0200
committert3sserakt <t3ss@posteo.de>2021-10-07 13:07:30 +0200
commitd7fa0579995790840199ec86cb4d518f9d372fcd (patch)
treeb41accedea6cd0fb78d75afee61911b94a1099fb /src/transport/Makefile.am
parent658bceab7ba3aab5121e8874d8508264d3f63ce3 (diff)
downloadgnunet-d7fa0579995790840199ec86cb4d518f9d372fcd.tar.gz
gnunet-d7fa0579995790840199ec86cb4d518f9d372fcd.zip
- add generic topology configuration by file
- cmd simple send using file configuration from file - added cmd to check the logs for backchannel encapsulation - added cmd which notifies the master loop of local loop being prepared to finish - added logging to helper.c - moved code from connecting peers cmd into global functions - added parameters given to the connecting peers cmd - added assertion when notifying the transport service about a new queue, if the communicator has no intial capacity - added optional valgrind cmd to test script - added flag für queues with unlimited length - added check for queues with higher priority - added attribute queue_capacity to struct Queue - bug fixing worker task for kce generation and transport notification about available queue in udp communicator - change value for unlimited queue length from 0 to UINT16_MAX in tcp communicator and service - added loop to stop the test system for the globally known peers in stop testsystem cmd - refactored endless growing array to handle further messages from the local loops, and added logic to handle the local test prepare msg - added utility methods in testing.c - added forwarding of all tests prepared msg in gnunet-cmds-helper.c - added cmd to end loop without shutdown - added without shutdown cmd to simple send testcase - added backchannel check, without shutdown and prepared cmd to udp backchannel testcase.
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 32075ee16..73544a8d5 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -163,12 +163,14 @@ libgnunettransporttesting2_la_SOURCES = \
163 transport_api_cmd_connecting_peers.c \ 163 transport_api_cmd_connecting_peers.c \
164 transport_api_cmd_connecting_peers_v2.c \ 164 transport_api_cmd_connecting_peers_v2.c \
165 transport_api_cmd_connecting_peers_v3.c \ 165 transport_api_cmd_connecting_peers_v3.c \
166 transport_api_cmd_backchannel_check.c \
166 transport_api_cmd_start_peer.c \ 167 transport_api_cmd_start_peer.c \
167 transport_api_cmd_start_peer_v2.c \ 168 transport_api_cmd_start_peer_v2.c \
168 transport_api_cmd_start_peer_v3.c \ 169 transport_api_cmd_start_peer_v3.c \
169 transport_api_cmd_stop_peer.c \ 170 transport_api_cmd_stop_peer.c \
170 transport_api_cmd_send_simple.c \ 171 transport_api_cmd_send_simple.c \
171 transport_api_cmd_send_simple_v2.c \ 172 transport_api_cmd_send_simple_v2.c \
173 transport_api_cmd_send_simple_v3.c \
172 transport-testing2.c transport-testing2.h \ 174 transport-testing2.c transport-testing2.h \
173 transport-testing-cmds.h \ 175 transport-testing-cmds.h \
174 transport-testing-filenames2.c \ 176 transport-testing-filenames2.c \