aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorDavid Barksdale <amatus.amongus@gmail.com>2013-06-27 06:11:55 +0000
committerDavid Barksdale <amatus.amongus@gmail.com>2013-06-27 06:11:55 +0000
commitea7eed529e12dcbed6a6775b818d8b93b9505f18 (patch)
tree521ba312e1268d1afb249db03c1b97d5a79181a1 /src/transport/Makefile.am
parent48e50f64d8c05b2a6dab327156ea86fc92f171cf (diff)
downloadgnunet-ea7eed529e12dcbed6a6775b818d8b93b9505f18.tar.gz
gnunet-ea7eed529e12dcbed6a6775b818d8b93b9505f18.zip
Make building gnunet-testing lib optional.
This is all because emscripten doesn't have getaddrinfo.
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 258a7aae5..4ace2bc1e 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -81,9 +81,13 @@ noinst_PROGRAMS = \
81 $(WLAN_BIN_SENDER) \ 81 $(WLAN_BIN_SENDER) \
82 $(WLAN_BIN_RECEIVER) 82 $(WLAN_BIN_RECEIVER)
83 83
84if HAVE_TESTING
85TESTING_LIBS = libgnunettransporttesting.la
86endif
87
84lib_LTLIBRARIES = \ 88lib_LTLIBRARIES = \
85 libgnunettransport.la \ 89 libgnunettransport.la \
86 libgnunettransporttesting.la 90 $(TESTING_LIBS)
87 91
88libgnunettransporttesting_la_SOURCES = \ 92libgnunettransporttesting_la_SOURCES = \
89 transport-testing.c transport-testing.h 93 transport-testing.c transport-testing.h
@@ -308,6 +312,7 @@ libgnunet_plugin_transport_https_server_la_LDFLAGS = \
308libgnunet_plugin_transport_https_server_la_CFLAGS = \ 312libgnunet_plugin_transport_https_server_la_CFLAGS = \
309 $(CFLAGS) -DBUILD_HTTPS 313 $(CFLAGS) -DBUILD_HTTPS
310 314
315if HAVE_TESTING
311check_PROGRAMS = \ 316check_PROGRAMS = \
312 test_transport_testing_startstop \ 317 test_transport_testing_startstop \
313 test_transport_testing_restart \ 318 test_transport_testing_restart \
@@ -368,6 +373,7 @@ check_PROGRAMS = \
368 $(HTTP_QUOTA_TEST) \ 373 $(HTTP_QUOTA_TEST) \
369 $(HTTPS_QUOTA_TEST) \ 374 $(HTTPS_QUOTA_TEST) \
370 $(WLAN_QUOTA_TEST) 375 $(WLAN_QUOTA_TEST)
376endif
371 377
372if ENABLE_TEST_RUN 378if ENABLE_TEST_RUN
373TESTS = \ 379TESTS = \